IntegriSign for MS Word

Contents

1. Introduction .................................................................................................................. 2

2. Using IntegriSign in MS Word .................................................................................. 2
   2.1. Macro Security ........................................................................................................ 2
   2.2. Authenticate and Secure ........................................................................................ 4
   2.3. Freezing of Document ........................................................................................... 5
   2.4. Signing in Protected documents and templates ..................................................... 6
   2.5. Creating a Signature ............................................................................................. 7
   2.6. Sectional signing .................................................................................................. 8
   2.7. Document Verification ......................................................................................... 8

3. Known Issues .............................................................................................................. 9
   3.1. Text with Special Effects ...................................................................................... 9
   3.2. Auto Text Fields .................................................................................................. 10
   3.3. Insertion of Signature Field towards end of any page in a document ................. 10
1. Introduction

An IntegriSign plug-in allows you to create a document and sign it electronically with your handwritten signature using an ePad device. The plug-in facilitates:

1. **Signature Capture** - The signature trace is captured and stored on the electronic document in a signature object.

2. **Content Hashing** - The signature object is bound to the contents of the document such that any alteration of the document after signing it would render the signature invalid.

3. **Document Verification** – The document can be verified to ensure its integrity (i.e., confirming that it has not been tampered) after the act of signing.

2. Using IntegriSign in MS Word

When IntegriSign Desktop is installed onto a system, plug-in for MS Word 2010/2013/2016 64bit is automatically installed. On opening the application, one will be able to find the IntegriSign menus under “IntegriSign” menu as shown below.

2.1. Macro Security

For IntegriSign to properly work in MS Word, one needs to change the default macro security option. To change the Macro Security settings click on “Developer” menu and then click on “Macro Security” button (i.e. “Yellow Exclamation” button) under “Code” group. For reference, see the image below.
IntegriSign macros are digitally signed. Hence, change the setting to “Disable all macros except digitally signed macros” as shown below.

![Trust Center](image)

Once the above setting is applied, close and open MS Word.

If the “Developer” tab is not visible, follow the steps below to enable the same.

1. Open the Word Options window using “File -> Options”.
2. Select the “Customize Ribbon” at left side in Word Options window.
3. Check the "Developer" option in the list of tabs under the "Customize the Ribbon" section.
4. Click on OK button in the "Word Options" window.

See the below screenshot for reference.
2.2. Authenticate and Secure

The ‘Authenticate and Secure’ window gives you the option of authenticating a specific section within the current document or the entire document for the current signature. The ‘Whole Document’ option when checked includes the entire document for authentication.

The ‘Authenticate and Secure’ window is not shown during signing process by default. To enable this window, uncheck the ‘Do not show Authenticate and Secure window’ in Word – Configuration. This can be accessed from the menu IntegriSign → Configuration. The Freeze Document option in IntegriSign for MS Word – Configuration is irreversible. Document once freezed using this option cannot be unfreezed.
Document can be authenticated automatically in either Save or Print events. These events can be set from IntegriSign-->Configuration.

2.3. Freezing of Document

The plug-in allows you to choose if you want to freeze the whole document from the Authenticate and Secure window. Freezing is accomplished through the act of signing and immobilizes the whole document and does not allow any changes or modifications to be made. You are required to give a password when using the Freeze feature. Freezed document can be unfreezed from Developer → Restrict Editing → Stop Protection.
2.4. Signing in Protected documents and templates

Before protecting the document to be signed, click ‘Insert Signature Field’ to place a signature placeholder on the MS Word document. Then protect the document using the ‘Protect Document’ feature from the ‘IntegriSign’ menu so that you can sign at a later point of time. If the document is protected using the ‘Restrict Editing’ option in the Developer menu, signing the document with content authentication feature is not possible.

Place a signature placeholder in the word document and then protect the document. Select ‘Forms’ in the ‘Protect documents for’ option. Provide a password to complete the protection of the document process. To unprotect, go to Developer ➔ Restrict Editing ➔ Stop Protection.

To initiate the act-of-signing on unsigned placeholders/fields in a protected document, you need to use ‘Sign Signature Field’ option instead of double-clicking the placeholder. ‘Sign Signature Field’ options displays a window listing all the unsigned signature fields. If a document has three unsigned signature fields, the window looks like the one below. When Signature1 is selected, the selected signature is automatically highlighted in the document. Click on the “Sign” button to initiate the act-of-signing.

© IntegriSign
Note: In a protected document,
1. Blank signature fields in the Header/Footer cannot be signed using ‘Sign Signature Field’ option.
2. Signatures in the Header/Footer do not get verified when ‘Verify All Signatures’ option is used.

2.5. Creating a Signature

Signing in MS Word using IntegriSign can be accomplished by using the ‘Insert Signature Field’ option.

Insert Signature Field

1. Compose the document.
2. Create sections, if desired (for further details on how to create sections in Word see Sectional Signing, (Ref: 2.6)
3. Place the cursor where the signature needs to be placed on the document and click on the ‘Insert Signature Field’ button. A placeholder appears on the document with the words “Double-click to Sign”. Double-click this placeholder to sign the document.
4. A screen with the title ‘Authenticate and Secure’ is displayed, which presents the signer with the option of authenticating a specific section within the current document or the entire document.
5. Choose the sections to be authenticated. You may select one or more sections depending on how many sections you wish to authenticate with that signature. Click on help for further information on this feature.
6. You also have the option of freezing the entire document preventing any further modifications. (Please note that freezing a entire document will disable all editing features for the document and cannot be reversed)
7. The signature capture screen is now displayed to capture inputs from the ePad device.
8. Select the Signer name from the list for a registered signer or in case of Public Signing (e.g. customer signing) signer can just enter name in the Signer Name field.
9. Sign using the ePad device. As the signing continues, the signature trace is shown on the signature placeholder. To apply the signature on to document click on the ‘OK’ button, to clear the signature click on ‘Clear’ Button and to cancel the Act-of-Signing click on ‘Cancel’ button in the dialog displayed.

In addition to the basic functions mentioned in the Introduction, IntegriSign MS Word Plug-in also has the following features:

2.6. Sectional signing

The IntegriSign MS Word plug-in allows you to create multiple sections in a document such that each section is treated as an independent document. This is especially useful in cases where the same document is being signed by multiple signers, and should permit a second or third signer to add remarks to any of the sections without affecting the first signer’s signature. For example, the first signer (e.g. John) can create a section and authenticate it with his signature and forward it to the second signer (e.g. Nancy), who can then add her comments to the second section and authenticate it with her signature, and so on.

To Create Sections in MS Word follow the steps below:

a) Go to 'View' on the MS Word toolbar and click on 'Draft'.
b) Place the cursor at the location where the section break is required.
c) Now go to 'Page Layout' toolbar and select 'Breaks'.
d) Select the type of Section break to be inserted, e.g 'Continuous' (If the section breaks are intended to be on the same page).
e) A section break is shown on the document where the cursor was located.

The document may thus be partitioned into any number of sections.

Each section in a document is treated independently and can be signed and authenticated, depending on the functionality intended for the document.

2.7. Document Verification

1. Double-click on the signature in the document.
2. A window is displayed with the image of the current signature, device information and the signer info.
3. If the document is modified after signing, then the signature on the document is invalidated with a large “X” through the signature. Reversing the change made to the document brings the signature back to its original state.
Note:
• In case of protected documents, for document verification use the ‘Verify All Signatures’ option. Any modifications made to the document after signing will cross out the signatures made.

3. Known Issues

3.1. Text with Special Effects

If a signature object is placed right next to the text which has special effects (like Strikethrough, superscript, subscript, shadow etc.), when double clicked for signature, the MS word hangs and one need to restart MS word or even some times the machine itself. To overcome this problem avoid the following

1. Avoid placing the signature field immediately next to the text with special effects without any space in between.
2. The complete text in the document is with special effects (e.g. the whole content of the text is strikethrough)

If the document has self-updating auto-text fields like Page Number, Date etc… the signature authentication status may not provide the correct status.
3.2. Auto Text Fields

Using IntegriSign along with some of the Auto text fields in a Word document's Header and Footer are not supported. Using such fields will modify the signature and makes them invalid. This is because of the fact that, some of the fields update their content over a period of time (after the signature is captured. Using the following mentioned Auto text fields along with IntegriSign are not recommended.

Author, Page#, Date.
Confidential, Page#, Date.
Last printed.
Page X of Y

Note: In some cases, inserting the signature placeholder can alter the Table of Contents (e.g. Page numbers might change) and signing without regenerating the Table of Contents, saving the document will invalidate the signature. Hence, it is advisable to regenerate the Table of Contents after placing all the signature placeholders, save the document before signing it.

3.3. Insertion of Signature Field towards end of any page in a document

If one tries to insert the signature field towards the end of any page in a document, one might encounter the following error

“The program used to create this object is eSign. That program is either not installed on your computer or it is not responding. To edit this object, install eSign or ensure that any dialog boxes in eSign are closed.”

The above error is raised by MS Word and is a bit misleading. The problem is that the default size of the IntegriSign signature field size is 180 x 110 pixels. When the cursor is at the end of the page, MS Word does not accept inserting a field with a height of 110 pixels. Either insert the signature field in the next page or move the cursor by couple of lines towards the upward direction, so that enough space is available for the signature field.

Another alternative is to going to the “Desktop Configuration” and changing the default height of the signature field. If it is set to 50 or so, one can insert the signature field without any problems even in the last line of a page.