Interlink.ePad.ePadCore Namespace

[image]

.NET Framework Class Library
Interlink.ePad.ePadCore Namespace
Send Feedback

Classes

Class | Description
ePadCore | Represents the base class from which all particular ePad Device class will derive and provides common functions.
ePadException | Represent the abnormal event happened.

Structures

Structure | Description
DeviceFWInfo | The device identification info
DevicePadInfo | Represent the device physical characteristics
DeviceSignatureDataRange | Define the signature point (raw data) value range.
ValueRange | Specify integer type data range.

Interfaces

Interface | Description
IePadCore | This interface defines device model independent functionality.
IUSBInDataReportEvent | Defines an interface to process the USB HID IN report.

Delegates

Delegate | Description
SignatureDataDelegate | Define the signature event handler.
USBInReportDelegate | Declare a delegate mothod to process the USB HID IN report.

Enumerations

Enumeration | Description
HERROR | The error code (HError) for the exception type ePadException
Send feedback on this topic to Microsoft.


DeviceFWInfo Structure

[image]

.NET Framework Class Library
DeviceFWInfo Structure
See Also Send Feedback

The device identification info

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure DeviceFWInfo
C#
public struct DeviceFWInfo
Visual C++
public value class DeviceFWInfo
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadCore Namespace


DeviceFWInfo Fields

[image] [image]

.NET Framework Class Library
DeviceFWInfo Fields
DeviceFWInfo Structure See Also Send Feedback

The DeviceFWInfo type exposes the following members.

Fields

Name | Description
BcdRevision | The device bcd number.
BuildNum | The build number.
BusType | The device bus type defined by OS. For example. The USB bus is (0x36fc9e60L, 0xc465, 0x11cf, 0x80, 0x56, 0x44, 0x45, 0x53, 0x54, 0x00, 0x00 .
Pid | The device produce ID.
Vid | The device vendor ID. It is always 0x04df (Interlink Electronics)

See Also

DeviceFWInfo Structure
Interlink.ePad.ePadCore Namespace


BcdRevision Field

[image]

.NET Framework Class Library
DeviceFWInfo..::.BcdRevision Field
DeviceFWInfo Structure See Also Send Feedback

The device bcd number.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public BcdRevision As Short
C#
public short BcdRevision
Visual C++
public:
short BcdRevision
JavaScript
bcdRevision

See Also

DeviceFWInfo Structure
Interlink.ePad.ePadCore Namespace


BuildNum Field

[image]

.NET Framework Class Library
DeviceFWInfo..::.BuildNum Field
DeviceFWInfo Structure See Also Send Feedback

The build number.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public BuildNum As Integer
C#
public int BuildNum
Visual C++
public:
int BuildNum
JavaScript
buildNum

See Also

DeviceFWInfo Structure
Interlink.ePad.ePadCore Namespace


BusType Field

[image]

.NET Framework Class Library
DeviceFWInfo..::.BusType Field
DeviceFWInfo Structure See Also Send Feedback

The device bus type defined by OS. For example. The USB bus is (0x36fc9e60L, 0xc465, 0x11cf, 0x80, 0x56, 0x44, 0x45, 0x53, 0x54, 0x00, 0x00 .

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public BusType As Guid
C#
public Guid BusType
Visual C++
public:
Guid BusType
JavaScript
busType

See Also

DeviceFWInfo Structure
Interlink.ePad.ePadCore Namespace


Pid Field

[image]

.NET Framework Class Library
DeviceFWInfo..::.Pid Field
DeviceFWInfo Structure See Also Send Feedback

The device produce ID.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Pid As Short
C#
public short Pid
Visual C++
public:
short Pid
JavaScript
pid

See Also

DeviceFWInfo Structure
Interlink.ePad.ePadCore Namespace


Vid Field

[image]

.NET Framework Class Library
DeviceFWInfo..::.Vid Field
DeviceFWInfo Structure See Also Send Feedback

The device vendor ID. It is always 0x04df (Interlink Electronics)

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Vid As Short
C#
public short Vid
Visual C++
public:
short Vid
JavaScript
vid

See Also

DeviceFWInfo Structure
Interlink.ePad.ePadCore Namespace


DeviceFWInfo Methods

[image] [image]

.NET Framework Class Library
DeviceFWInfo Methods
DeviceFWInfo Structure See Also Send Feedback

The DeviceFWInfo type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

DeviceFWInfo Structure
Interlink.ePad.ePadCore Namespace


DevicePadInfo Structure

[image]

.NET Framework Class Library
DevicePadInfo Structure
See Also Send Feedback

Represent the device physical characteristics

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure DevicePadInfo
C#
public struct DevicePadInfo
Visual C++
public value class DevicePadInfo
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadCore Namespace


DevicePadInfo Fields

[image] [image]

.NET Framework Class Library
DevicePadInfo Fields
DevicePadInfo Structure See Also Send Feedback

The DevicePadInfo type exposes the following members.

Fields

Name | Description
signAreaHeightInInch | The signablea area height in inch
SignAreaWidthInInch | The signable area width in inch
sigRange | Signature data range

See Also

DevicePadInfo Structure
Interlink.ePad.ePadCore Namespace


signAreaHeightInInch Field

[image]

.NET Framework Class Library
DevicePadInfo..::.signAreaHeightInInch Field
DevicePadInfo Structure See Also Send Feedback

The signablea area height in inch

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public signAreaHeightInInch As Double
C#
public double signAreaHeightInInch
Visual C++
public:
double signAreaHeightInInch
JavaScript
signAreaHeightInInch

See Also

DevicePadInfo Structure
Interlink.ePad.ePadCore Namespace


SignAreaWidthInInch Field

[image]

.NET Framework Class Library
DevicePadInfo..::.SignAreaWidthInInch Field
DevicePadInfo Structure See Also Send Feedback

The signable area width in inch

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public SignAreaWidthInInch As Double
C#
public double SignAreaWidthInInch
Visual C++
public:
double SignAreaWidthInInch
JavaScript
signAreaWidthInInch

See Also

DevicePadInfo Structure
Interlink.ePad.ePadCore Namespace


sigRange Field

[image]

.NET Framework Class Library
DevicePadInfo..::.sigRange Field
DevicePadInfo Structure See Also Send Feedback

Signature data range

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public sigRange As DeviceSignatureDataRange
C#
public DeviceSignatureDataRange sigRange
Visual C++
public:
DeviceSignatureDataRange sigRange
JavaScript
sigRange

See Also

DevicePadInfo Structure
Interlink.ePad.ePadCore Namespace


DevicePadInfo Methods

[image] [image]

.NET Framework Class Library
DevicePadInfo Methods
DevicePadInfo Structure See Also Send Feedback

The DevicePadInfo type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

DevicePadInfo Structure
Interlink.ePad.ePadCore Namespace


DeviceSignatureDataRange Structure

[image]

.NET Framework Class Library
DeviceSignatureDataRange Structure
See Also Send Feedback

Define the signature point (raw data) value range.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure DeviceSignatureDataRange
C#
public struct DeviceSignatureDataRange
Visual C++
public value class DeviceSignatureDataRange
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadCore Namespace


DeviceSignatureDataRange Fields

[image] [image]

.NET Framework Class Library
DeviceSignatureDataRange Fields
DeviceSignatureDataRange Structure See Also Send Feedback

The DeviceSignatureDataRange type exposes the following members.

Fields

Name | Description
PRange | The pressure value range.
TimeStampUnit | The unit of time stamp count in millisecod. For example, if the count frequency is 1200HZ, its count unit is 1.2 millisecond.
XRange | The X-axis value range.
YRange | The Y-axis value range.

See Also

DeviceSignatureDataRange Structure
Interlink.ePad.ePadCore Namespace


PRange Field

[image]

.NET Framework Class Library
DeviceSignatureDataRange..::.PRange Field
DeviceSignatureDataRange Structure See Also Send Feedback

The pressure value range.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public PRange As ValueRange
C#
public ValueRange PRange
Visual C++
public:
ValueRange PRange
JavaScript
pRange

See Also

DeviceSignatureDataRange Structure
Interlink.ePad.ePadCore Namespace


TimeStampUnit Field

[image]

.NET Framework Class Library
DeviceSignatureDataRange..::.TimeStampUnit Field
DeviceSignatureDataRange Structure See Also Send Feedback

The unit of time stamp count in millisecod. For example, if the count frequency is 1200HZ, its count unit is 1.2 millisecond.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public TimeStampUnit As Double
C#
public double TimeStampUnit
Visual C++
public:
double TimeStampUnit
JavaScript
timeStampUnit

See Also

DeviceSignatureDataRange Structure
Interlink.ePad.ePadCore Namespace


XRange Field

[image]

.NET Framework Class Library
DeviceSignatureDataRange..::.XRange Field
DeviceSignatureDataRange Structure See Also Send Feedback

The X-axis value range.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public XRange As ValueRange
C#
public ValueRange XRange
Visual C++
public:
ValueRange XRange
JavaScript
xRange

See Also

DeviceSignatureDataRange Structure
Interlink.ePad.ePadCore Namespace


YRange Field

[image]

.NET Framework Class Library
DeviceSignatureDataRange..::.YRange Field
DeviceSignatureDataRange Structure See Also Send Feedback

The Y-axis value range.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public YRange As ValueRange
C#
public ValueRange YRange
Visual C++
public:
ValueRange YRange
JavaScript
yRange

See Also

DeviceSignatureDataRange Structure
Interlink.ePad.ePadCore Namespace


DeviceSignatureDataRange Methods

[image] [image]

.NET Framework Class Library
DeviceSignatureDataRange Methods
DeviceSignatureDataRange Structure See Also Send Feedback

The DeviceSignatureDataRange type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

DeviceSignatureDataRange Structure
Interlink.ePad.ePadCore Namespace


ePadCore Class

[image]

.NET Framework Class Library
ePadCore Class
See Also Send Feedback

Represents the base class from which all particular ePad Device class will derive and provides common functions.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
<GuidAttribute("1C337710-B168-4af7-90A9-82F581D16250")> _
Public Class ePadCore _
    Implements IePadCore, IDisposable
C#
[ClassInterfaceAttribute(ClassInterfaceType.None)]
[GuidAttribute("1C337710-B168-4af7-90A9-82F581D16250")]
public class ePadCore : IePadCore, IDisposable
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::None)]
[GuidAttribute(L"1C337710-B168-4af7-90A9-82F581D16250")]
public ref class ePadCore : IePadCore,
    IDisposable
JavaScript
Interlink.ePad.ePadCore.ePadCore = function();

Type.createClass(
    'Interlink.ePad.ePadCore.ePadCore',
    null,
    Interlink.ePad.ePadCore.IePadCore,
    IDisposable);

Remarks

In Windows Terminal Server or Citrix Server remote access mode, it is required to call IDisposable::Dispose() method to release the TS/ICA virtual channel at the end of session.

Inheritance Hierarchy

System..::.Object
Interlink.ePad.ePadCore..::.ePadCore
Interlink.ePad.ePadVision..::.ePadVision

See Also

Interlink.ePad.ePadCore Namespace


ePadCore Constructor

[image]

.NET Framework Class Library
ePadCore Constructor
ePadCore Class See Also Send Feedback

ctor

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ePadCore()
Visual C++
public:
ePadCore()
JavaScript
Interlink.ePad.ePadCore.ePadCore = function();

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


ePadCore Methods

[image] [image]

.NET Framework Class Library
ePadCore Methods
ePadCore Class See Also Send Feedback

The ePadCore type exposes the following members.

Methods

Name | Description
Close
Close the connection if applicable.
Dispose | Overloaded.
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize
Finalizer
(Overrides Object..::.Finalize()()().)
GetFeature
Retrive the HID feature report.
GetHashCode
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Open
Open a device specified by device index.
            At any time, only one device can be opened per instance.

If there is any device opened before, this method will close it before opening other desired device.

The device must be open firstly before calling any other methods to access the device functionality.

Reset
Restore the device to its power-up status.
SetFeature
Send out the HID feature report.
ShowConfigurationDialog
Performs the particular ePad derived class defined configuration dialog box.
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


Close Method

[image]

.NET Framework Class Library
ePadCore..::.Close Method
ePadCore Class See Also Send Feedback

Close the connection if applicable.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Close
C#
public virtual void Close()
Visual C++
public:
virtual void Close()
JavaScript
function close();

Implements

IePadCore..::.Close()()()

Exceptions

Exception | Condition
System..::.ObjectDisposedException | The object has been disposed.

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
ePadCore..::.Dispose Method
ePadCore Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Implement IDisposable.
Dispose(Boolean) | The implementation of disposal.

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


Dispose Method

[image]

.NET Framework Class Library
ePadCore..::.Dispose Method
ePadCore Class See Also Send Feedback

Implement IDisposable.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IDisposable..::.Dispose()()()

See Also

ePadCore Class
Dispose Overload
Interlink.ePad.ePadCore Namespace


Dispose Method (Boolean)

[image]

.NET Framework Class Library
ePadCore..::.Dispose Method (Boolean)
ePadCore Class See Also Send Feedback

The implementation of disposal.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
C#
protected virtual void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)
JavaScript
function dispose(disposing);

Parameters

disposing
Type: System..::.Boolean
Whether the disposal is explicit (true) or implicit (false).

See Also

ePadCore Class
Dispose Overload
Interlink.ePad.ePadCore Namespace


Finalize Method

[image]

.NET Framework Class Library
ePadCore..::.Finalize Method
ePadCore Class See Also Send Feedback

Finalizer

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize
C#
protected override void Finalize()
Visual C++
protected:
virtual void Finalize() override
JavaScript
function finalize();

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


GetFeature Method

[image]

.NET Framework Class Library
ePadCore..::.GetFeature Method
ePadCore Class See Also Send Feedback

Retrive the HID feature report.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub GetFeature ( _
    lpReport As Byte() _
)
C#
[ComVisibleAttribute(false)]
public virtual void GetFeature(
    byte[] lpReport
)
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void GetFeature(
    array<unsigned char>^ lpReport
)
JavaScript
function getFeature(lpReport);

Parameters

lpReport
Type: array< System..::.Byte >[]()[]
The byte array to hold the report.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the get report.
System..::.ObjectDisposedException | The object has been disposed.

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


Open Method

[image]

.NET Framework Class Library
ePadCore..::.Open Method
ePadCore Class See Also Send Feedback

Open a device specified by device index.
            At any time, only one device can be opened per instance.

If there is any device opened before, this method will close it before opening other desired device.

The device must be open firstly before calling any other methods to access the device functionality.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Open ( _
    devIndex As Byte _
)
C#
public virtual void Open(
    byte devIndex
)
Visual C++
public:
virtual void Open(
    unsigned char devIndex
)
JavaScript
function open(devIndex);

Parameters

devIndex
Type: System..::.Byte
The device index (0 basis).

Implements

IePadCore..::.Open(Byte)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Couldn't open the device.
System..::.ObjectDisposedException | The object has been disposed.

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


Reset Method

[image]

.NET Framework Class Library
ePadCore..::.Reset Method
ePadCore Class See Also Send Feedback

Restore the device to its power-up status.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset
C#
public virtual void Reset()
Visual C++
public:
virtual void Reset()
JavaScript
function reset();

Implements

IePadCore..::.Reset()()()

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


SetFeature Method

[image]

.NET Framework Class Library
ePadCore..::.SetFeature Method
ePadCore Class See Also Send Feedback

Send out the HID feature report.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overridable Sub SetFeature ( _
    lpReport As Byte() _
)
C#
[ComVisibleAttribute(false)]
public virtual void SetFeature(
    byte[] lpReport
)
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void SetFeature(
    array<unsigned char>^ lpReport
)
JavaScript
function setFeature(lpReport);

Parameters

lpReport
Type: array< System..::.Byte >[]()[]
The byte array of feature report.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the set report.
System..::.ObjectDisposedException | The object has been disposed.

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


ShowConfigurationDialog Method

[image]

.NET Framework Class Library
ePadCore..::.ShowConfigurationDialog Method
ePadCore Class See Also Send Feedback

Performs the particular ePad derived class defined configuration dialog box.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ShowConfigurationDialog
C#
public virtual void ShowConfigurationDialog()
Visual C++
public:
virtual void ShowConfigurationDialog()
JavaScript
function showConfigurationDialog();

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


ePadCore Properties

[image] [image]

.NET Framework Class Library
ePadCore Properties
ePadCore Class See Also Send Feedback

The ePadCore type exposes the following members.

Properties

Name | Description
DeviceCount | Gives the number of attached ePad devices.
FWInfo | The FW identification info.
OpenedDeviceIndex | Gives the current opened device index (0-based). If There is no device opened, its value will be -1.
PadInfo | The device physical info.
ProviderDescription | Gives the description of the particular ePad implementation. The derived class (particular ePad implementation) should override this property to provide the specific description.
SerialNumber | The device serial number. The derived classed should override it.
SerialNumberGUID | The device serial nummber. The derived classed should override it.
SignatureDataRange | The signature data X-axis, Y-axis and pressure ranges.

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


DeviceCount Property

[image]

.NET Framework Class Library
ePadCore..::.DeviceCount Property
ePadCore Class See Also Send Feedback

Gives the number of attached ePad devices.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DeviceCount As Integer
C#
public virtual int DeviceCount { get; }
Visual C++
public:
virtual property int DeviceCount {
    int get ();
}
JavaScript
function get_deviceCount();

Implements

IePadCore..::.DeviceCount

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


FWInfo Property

[image]

.NET Framework Class Library
ePadCore..::.FWInfo Property
ePadCore Class See Also Send Feedback

The FW identification info.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FWInfo As DeviceFWInfo
C#
public virtual DeviceFWInfo FWInfo { get; }
Visual C++
public:
virtual property DeviceFWInfo FWInfo {
    DeviceFWInfo get ();
}
JavaScript
function get_fwInfo();

Implements

IePadCore..::.FWInfo

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


OpenedDeviceIndex Property

[image]

.NET Framework Class Library
ePadCore..::.OpenedDeviceIndex Property
ePadCore Class See Also Send Feedback

Gives the current opened device index (0-based). If There is no device opened, its value will be -1.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OpenedDeviceIndex As Integer
C#
public virtual int OpenedDeviceIndex { get; }
Visual C++
public:
virtual property int OpenedDeviceIndex {
    int get ();
}
JavaScript
function get_openedDeviceIndex();

Implements

IePadCore..::.OpenedDeviceIndex

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


PadInfo Property

[image]

.NET Framework Class Library
ePadCore..::.PadInfo Property
ePadCore Class See Also Send Feedback

The device physical info.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PadInfo As DevicePadInfo
C#
public virtual DevicePadInfo PadInfo { get; }
Visual C++
public:
virtual property DevicePadInfo PadInfo {
    DevicePadInfo get ();
}
JavaScript
function get_padInfo();

Implements

IePadCore..::.PadInfo

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


ProviderDescription Property

[image]

.NET Framework Class Library
ePadCore..::.ProviderDescription Property
ePadCore Class See Also Send Feedback

Gives the description of the particular ePad implementation.
The derived class (particular ePad implementation) should override this property to provide the specific description.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ProviderDescription As String
C#
public virtual string ProviderDescription { get; }
Visual C++
public:
virtual property String^ ProviderDescription {
    String^ get ();
}
JavaScript
function get_providerDescription();

Implements

IePadCore..::.ProviderDescription

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


SerialNumber Property

[image]

.NET Framework Class Library
ePadCore..::.SerialNumber Property
ePadCore Class See Also Send Feedback

The device serial number.

The derived classed should override it.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SerialNumber As String
C#
public virtual string SerialNumber { get; }
Visual C++
public:
virtual property String^ SerialNumber {
    String^ get ();
}
JavaScript
function get_serialNumber();

Implements

IePadCore..::.SerialNumber

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


SerialNumberGUID Property

[image]

.NET Framework Class Library
ePadCore..::.SerialNumberGUID Property
ePadCore Class See Also Send Feedback

The device serial nummber.

The derived classed should override it.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SerialNumberGUID As Guid
C#
public virtual Guid SerialNumberGUID { get; }
Visual C++
public:
virtual property Guid SerialNumberGUID {
    Guid get ();
}
JavaScript
function get_serialNumberGUID();

Implements

IePadCore..::.SerialNumberGUID

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


SignatureDataRange Property

[image]

.NET Framework Class Library
ePadCore..::.SignatureDataRange Property
ePadCore Class See Also Send Feedback

The signature data X-axis, Y-axis and pressure ranges.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SignatureDataRange As DeviceSignatureDataRange
C#
public virtual DeviceSignatureDataRange SignatureDataRange { get; }
Visual C++
public:
virtual property DeviceSignatureDataRange SignatureDataRange {
    DeviceSignatureDataRange get ();
}
JavaScript
function get_signatureDataRange();

Implements

IePadCore..::.SignatureDataRange

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace
Interlink.ePad.ePadCore..::.DeviceSignatureDataRange


ePadCore Events

[image] [image]

.NET Framework Class Library
ePadCore Events
ePadCore Class See Also Send Feedback

The ePadCore type exposes the following members.

Events

Name | Description
USBInDataReportEvent | Notifies the USB HID IN report.

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


USBInDataReportEvent Event

[image]

.NET Framework Class Library
ePadCore..::.USBInDataReportEvent Event
ePadCore Class See Also Send Feedback

Notifies the USB HID IN report.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Event USBInDataReportEvent As USBInReportDelegate
C#
public event USBInReportDelegate USBInDataReportEvent
Visual C++
public:
 event USBInReportDelegate^ USBInDataReportEvent {
    void add (USBInReportDelegate^ value);
    void remove (USBInReportDelegate^ value);
}
JavaScript
function add_usbInDataReportEvent(value);
function remove_usbInDataReportEvent(value);

See Also

ePadCore Class
Interlink.ePad.ePadCore Namespace


ePadException Class

[image]

.NET Framework Class Library
ePadException Class
See Also Send Feedback

Represent the abnormal event happened.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Class ePadException _
    Inherits Exception
C#
[ComVisibleAttribute(false)]
public class ePadException : Exception
Visual C++
[ComVisibleAttribute(false)]
public ref class ePadException : public Exception
JavaScript
Interlink.ePad.ePadCore.ePadException = function();

Type.createClass(
    'Interlink.ePad.ePadCore.ePadException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
Interlink.ePad.ePadCore..::.ePadException

See Also

Interlink.ePad.ePadCore Namespace


ePadException Constructor

[image]

.NET Framework Class Library
ePadException Constructor
ePadException Class See Also Send Feedback

ctor

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    hResult As HERROR _
)
C#
public ePadException(
    HERROR hResult
)
Visual C++
public:
ePadException(
    HERROR hResult
)
JavaScript
Interlink.ePad.ePadCore.ePadException = function(hResult);

Parameters

hResult
Type: Interlink.ePad.ePadCore..::.HERROR
The error code

See Also

ePadException Class
Interlink.ePad.ePadCore Namespace


ePadException Methods

[image] [image]

.NET Framework Class Library
ePadException Methods
ePadException Class See Also Send Feedback

The ePadException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Give the info in the string representation. (Overrides Exception..::.ToString()()().)

See Also

ePadException Class
Interlink.ePad.ePadCore Namespace


ToString Method

[image]

.NET Framework Class Library
ePadException..::.ToString Method
ePadException Class See Also Send Feedback

Give the info in the string representation.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

Implements

_Exception..::.ToString()()()

See Also

ePadException Class
Interlink.ePad.ePadCore Namespace


ePadException Properties

[image] [image]

.NET Framework Class Library
ePadException Properties
ePadException Class See Also Send Feedback

The ePadException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ePadException Class
Interlink.ePad.ePadCore Namespace


HERROR Enumeration

[image]

.NET Framework Class Library
HERROR Enumeration
See Also Send Feedback

The error code (HError) for the exception type ePadException

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration HERROR
C#
public enum HERROR
Visual C++
public enum class HERROR
JavaScript
Interlink.ePad.ePadCore.HERROR = function();
Interlink.ePad.ePadCore.HERROR.createEnum('Interlink.ePad.ePadCore.HERROR', false);

Members

Member name | Description
F_NOTOPEN | Device is not open.
F_INVALIDVALUE | Invalid data value
F_TOOLONG | The data is too long
F_INTERNAL_ERROR | Internal data is messed up.
F_USBAPI_ERROR | USB API returns error
F_SIF_ERROR | SIF Font file has invalid format
F_SIF_NOTFOUND | SIF Font file not found
F_STORAGEFULL | external storage medium space full
F_SIF_FONTSIZE_ERROR | XBF Font file not found
F_TIMEOUT | The action is terminated due to timeout

See Also

Interlink.ePad.ePadCore Namespace


IePadCore Interface

[image]

.NET Framework Class Library
IePadCore Interface
See Also Send Feedback

This interface defines device model independent functionality.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("2D972612-2DD8-4f73-B0D9-2885C161F357")> _
Public Interface IePadCore
C#
[GuidAttribute("2D972612-2DD8-4f73-B0D9-2885C161F357")]
public interface IePadCore
Visual C++
[GuidAttribute(L"2D972612-2DD8-4f73-B0D9-2885C161F357")]
public interface class IePadCore
JavaScript
Interlink.ePad.ePadCore.IePadCore = function();
Interlink.ePad.ePadCore.IePadCore.createInterface('Interlink.ePad.ePadCore.IePadCore');

See Also

Interlink.ePad.ePadCore Namespace


IePadCore Methods

[image] [image]

.NET Framework Class Library
IePadCore Methods
IePadCore Interface See Also Send Feedback

The IePadCore type exposes the following members.

Methods

Name | Description
Close | Close the device if applicable. This method does certain device relative actions. For example, it could turn off the LCD...
Open | Open a device specified by device index and reset it to its power-up status. At any time, only one device can be opened per instance. If there is any device opened before, this method will close it before opening other desired device. The device must be open firstly before calling any other methods to access the device functionality.
Reset | Restore the device to its power-up status.

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


Close Method

[image]

.NET Framework Class Library
IePadCore..::.Close Method
IePadCore Interface See Also Send Feedback

Close the device if applicable.

This method does certain device relative actions. For example, it could turn off the LCD...

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Close
C#
void Close()
Visual C++
void Close()
JavaScript
function close();

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


Open Method

[image]

.NET Framework Class Library
IePadCore..::.Open Method
IePadCore Interface See Also Send Feedback

Open a device specified by device index and reset it to its power-up status. At any time, only one device can be opened per instance.

If there is any device opened before, this method will close it before opening other desired device.

The device must be open firstly before calling any other methods to access the device functionality.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Open ( _
    deviceIndex As Byte _
)
C#
void Open(
    byte deviceIndex
)
Visual C++
void Open(
    unsigned char deviceIndex
)
JavaScript
function open(deviceIndex);

Parameters

deviceIndex
Type: System..::.Byte
The device index (0 basis).

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Couldn't open the device.

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


Reset Method

[image]

.NET Framework Class Library
IePadCore..::.Reset Method
IePadCore Interface See Also Send Feedback

Restore the device to its power-up status.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Reset
C#
void Reset()
Visual C++
void Reset()
JavaScript
function reset();

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


IePadCore Properties

[image] [image]

.NET Framework Class Library
IePadCore Properties
IePadCore Interface See Also Send Feedback

The IePadCore type exposes the following members.

Properties

Name | Description
DeviceCount | Gives the number of attached devices.
FWInfo | The FW identification info.
OpenedDeviceIndex | Gives the current opened device index (0-based). If There is no device opened, its value will be -1.
PadInfo | The device physical info.
ProviderDescription | Gives the description about the incurred particular .Net components. For example, if it is ePad-vision or other device component.
SerialNumber | The device serial number.
SerialNumberGUID | The device serail number in GUID format
SignatureDataRange | The signature data X-axis, Y-axis and pressure ranges.

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


DeviceCount Property

[image]

.NET Framework Class Library
IePadCore..::.DeviceCount Property
IePadCore Interface See Also Send Feedback

Gives the number of attached devices.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DeviceCount As Integer
C#
int DeviceCount { get; }
Visual C++
property int DeviceCount {
    int get ();
}
JavaScript
function get_deviceCount();

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


FWInfo Property

[image]

.NET Framework Class Library
IePadCore..::.FWInfo Property
IePadCore Interface See Also Send Feedback

The FW identification info.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FWInfo As DeviceFWInfo
C#
DeviceFWInfo FWInfo { get; }
Visual C++
property DeviceFWInfo FWInfo {
    DeviceFWInfo get ();
}
JavaScript
function get_fwInfo();

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


OpenedDeviceIndex Property

[image]

.NET Framework Class Library
IePadCore..::.OpenedDeviceIndex Property
IePadCore Interface See Also Send Feedback

Gives the current opened device index (0-based). If There is no device opened, its value will be -1.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property OpenedDeviceIndex As Integer
C#
int OpenedDeviceIndex { get; }
Visual C++
property int OpenedDeviceIndex {
    int get ();
}
JavaScript
function get_openedDeviceIndex();

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


PadInfo Property

[image]

.NET Framework Class Library
IePadCore..::.PadInfo Property
IePadCore Interface See Also Send Feedback

The device physical info.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PadInfo As DevicePadInfo
C#
DevicePadInfo PadInfo { get; }
Visual C++
property DevicePadInfo PadInfo {
    DevicePadInfo get ();
}
JavaScript
function get_padInfo();

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


ProviderDescription Property

[image]

.NET Framework Class Library
IePadCore..::.ProviderDescription Property
IePadCore Interface See Also Send Feedback

Gives the description about the incurred particular .Net components. For example, if it is ePad-vision or other device component.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ProviderDescription As String
C#
string ProviderDescription { get; }
Visual C++
property String^ ProviderDescription {
    String^ get ();
}
JavaScript
function get_providerDescription();

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


SerialNumber Property

[image]

.NET Framework Class Library
IePadCore..::.SerialNumber Property
IePadCore Interface See Also Send Feedback

The device serial number.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SerialNumber As String
C#
string SerialNumber { get; }
Visual C++
property String^ SerialNumber {
    String^ get ();
}
JavaScript
function get_serialNumber();

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


SerialNumberGUID Property

[image]

.NET Framework Class Library
IePadCore..::.SerialNumberGUID Property
IePadCore Interface See Also Send Feedback

The device serail number in GUID format

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SerialNumberGUID As Guid
C#
Guid SerialNumberGUID { get; }
Visual C++
property Guid SerialNumberGUID {
    Guid get ();
}
JavaScript
function get_serialNumberGUID();

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


SignatureDataRange Property

[image]

.NET Framework Class Library
IePadCore..::.SignatureDataRange Property
IePadCore Interface See Also Send Feedback

The signature data X-axis, Y-axis and pressure ranges.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SignatureDataRange As DeviceSignatureDataRange
C#
DeviceSignatureDataRange SignatureDataRange { get; }
Visual C++
property DeviceSignatureDataRange SignatureDataRange {
    DeviceSignatureDataRange get ();
}
JavaScript
function get_signatureDataRange();

See Also

IePadCore Interface
Interlink.ePad.ePadCore Namespace


IUSBInDataReportEvent Interface

[image]

.NET Framework Class Library
IUSBInDataReportEvent Interface
See Also Send Feedback

Defines an interface to process the USB HID IN report.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIDispatch)> _
<GuidAttribute("0F82C6F5-57AC-4663-9301-41DCC18E3F3B")> _
Public Interface IUSBInDataReportEvent
C#
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIDispatch)]
[GuidAttribute("0F82C6F5-57AC-4663-9301-41DCC18E3F3B")]
public interface IUSBInDataReportEvent
Visual C++
[InterfaceTypeAttribute(ComInterfaceType::InterfaceIsIDispatch)]
[GuidAttribute(L"0F82C6F5-57AC-4663-9301-41DCC18E3F3B")]
public interface class IUSBInDataReportEvent
JavaScript
Interlink.ePad.ePadCore.IUSBInDataReportEvent = function();
Interlink.ePad.ePadCore.IUSBInDataReportEvent.createInterface('Interlink.ePad.ePadCore.IUSBInDataReportEvent');

See Also

Interlink.ePad.ePadCore Namespace


IUSBInDataReportEvent Methods

[image] [image]

.NET Framework Class Library
IUSBInDataReportEvent Methods
IUSBInDataReportEvent Interface See Also Send Feedback

The IUSBInDataReportEvent type exposes the following members.

Methods

Name | Description
USBInDataReportEvent | Represents the method that will handle the USB HID IN arrival report.

See Also

IUSBInDataReportEvent Interface
Interlink.ePad.ePadCore Namespace


USBInDataReportEvent Method

[image]

.NET Framework Class Library
IUSBInDataReportEvent..::.USBInDataReportEvent Method
IUSBInDataReportEvent Interface See Also Send Feedback

Represents the method that will handle the USB HID IN arrival report.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub USBInDataReportEvent ( _
    rpt As Byte() _
)
C#
void USBInDataReportEvent(
    byte[] rpt
)
Visual C++
void USBInDataReportEvent(
    array<unsigned char>^ rpt
)
JavaScript
function usbInDataReportEvent(rpt);

Parameters

rpt
Type: array< System..::.Byte >[]()[]

See Also

IUSBInDataReportEvent Interface
Interlink.ePad.ePadCore Namespace


SignatureDataDelegate Delegate

[image]

.NET Framework Class Library
SignatureDataDelegate Delegate
See Also Send Feedback

Define the signature event handler.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Delegate Sub SignatureDataDelegate ( _
    xAxis As Integer, _
    yAxis As Integer, _
    pressure As Integer, _
    timeStamp As Integer _
)
C#
[ComVisibleAttribute(false)]
public delegate void SignatureDataDelegate(
    int xAxis,
    int yAxis,
    int pressure,
    int timeStamp
)
Visual C++
[ComVisibleAttribute(false)]
public delegate void SignatureDataDelegate(
    int xAxis,
    int yAxis,
    int pressure,
    int timeStamp
)
JavaScript
function(xAxis, yAxis, pressure, timeStamp);

Parameters

xAxis
Type: System..::.Int32
The signature point x coordinate value.
yAxis
Type: System..::.Int32
The signature point y coordinate value.
pressure
Type: System..::.Int32
The signature point pressure value.
timeStamp
Type: System..::.Int32
The signature point timestamp.

See Also

Interlink.ePad.ePadCore Namespace


USBInReportDelegate Delegate

[image]

.NET Framework Class Library
USBInReportDelegate Delegate
See Also Send Feedback

Declare a delegate mothod to process the USB HID IN report.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Delegate Sub USBInReportDelegate ( _
    rpt As Byte() _
)
C#
[ComVisibleAttribute(false)]
public delegate void USBInReportDelegate(
    byte[] rpt
)
Visual C++
[ComVisibleAttribute(false)]
public delegate void USBInReportDelegate(
    array<unsigned char>^ rpt
)
JavaScript
function(rpt);

Parameters

rpt
Type: array< System..::.Byte >[]()[]

See Also

Interlink.ePad.ePadCore Namespace


ValueRange Structure

[image]

.NET Framework Class Library
ValueRange Structure
See Also Send Feedback

Specify integer type data range.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure ValueRange
C#
public struct ValueRange
Visual C++
public value class ValueRange
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadCore Namespace


ValueRange Fields

[image] [image]

.NET Framework Class Library
ValueRange Fields
ValueRange Structure See Also Send Feedback

The ValueRange type exposes the following members.

Fields

Name | Description
Max | The maximum value.
Min | The minimum value.

See Also

ValueRange Structure
Interlink.ePad.ePadCore Namespace


Max Field

[image]

.NET Framework Class Library
ValueRange..::.Max Field
ValueRange Structure See Also Send Feedback

The maximum value.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Max As Integer
C#
public int Max
Visual C++
public:
int Max
JavaScript
max

See Also

ValueRange Structure
Interlink.ePad.ePadCore Namespace


Min Field

[image]

.NET Framework Class Library
ValueRange..::.Min Field
ValueRange Structure See Also Send Feedback

The minimum value.

Namespace: Interlink.ePad.ePadCore
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Min As Integer
C#
public int Min
Visual C++
public:
int Min
JavaScript
min

See Also

ValueRange Structure
Interlink.ePad.ePadCore Namespace


ValueRange Methods

[image] [image]

.NET Framework Class Library
ValueRange Methods
ValueRange Structure See Also Send Feedback

The ValueRange type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ValueRange Structure
Interlink.ePad.ePadCore Namespace


Interlink.ePad.ePadVision Namespace

[image]

.NET Framework Class Library
Interlink.ePad.ePadVision Namespace
Send Feedback

Classes

Class | Description
ePadVision | Provides the functionality to access ePad-vision device.
FontEntry | FontEntry class defines downloadable font detail info from ePad-vision external devices, RAM or FLASH.
FontList | FontList class implement a List of FontEntry and IFontList interface
ScreenSaver | Gives screensaver's settings
SIFonts | The SIF font operations.
SignaturePad | Represent the signature pad
Widgets | The widget management type.

Structures

Structure | Description
InkRegion | Define the signature area (Ink Region)
LCDColor | Define the LCD pixel color in Red, Green, Blue, and Alpha Blend
LCDExtents | Define the LCD physical extents in inches.
LCDPixelRange | Define the LCD range in pixel. The range is defined by its up left point and its width and height.
LCDPixels | Define the LCD X-axis and Y-axis pixel numbers.
LCDPoint | Define a LCD point in pixel
WidgetInfo | Define the Widget.

Interfaces

Interface | Description
IePadVision | This interface defines ePadVision particular functionality.
IFontEntry | IFontEntry defines the interface of FontEntry
IFontList | IFontList defines a wrapper for List collection of FontEntry
IPadVisionEvent | The event interface to pass the data to client (application).
IScreenSaver | Define the screensaver operations
ISIFont | Define Downloadable SIF font operations
ISignaturePad | Defines the signature pad characteristics.
IWidgets | Define widget management operations

Delegates

Delegate | Description
EventDataDelegate | Define the event handler.
WEventDataDelegate | Define the widget event handler.

Enumerations

Enumeration | Description
DeviceDefaults | The set flags to represent the device default settings.
EventCode | Represent widget events.
EventType | The event type indicator
ExternalDevice | Defines the external storage device for ePad-vision
FontID | Gives the font identifications. The name of each enumerator has the format XXX_Y_ZZ where XXX could be either SAN (stands for San Serif ), MON (stands for Monospaced), or COM (stands for Comic). Y could be with (R (stands for Regular) or B (stands for Bold). Z is the number represents the font size in pixel. There are maximum 25 downloadable font id, from DOWNLOAD_200 to DOWNLOAD_224, available to identify the downloaded font in the ePad-vision's external device.
ImageDisplayMode | Defines how the screensaver display the images.
PinPadControls | Defines the controls of Pin Pad Widget.
ReportRateIndicator | The signature point report rate indicator
Repository | Specify where is the repository (on device or host)
WidgetEffect | The widget appearance effect.
WidgetType | The widget type indicator


DeviceDefaults Enumeration

[image]

.NET Framework Class Library
DeviceDefaults Enumeration
See Also Send Feedback

The set flags to represent the device default settings.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration DeviceDefaults
C#
[FlagsAttribute]
public enum DeviceDefaults
Visual C++
[FlagsAttribute]
public enum class DeviceDefaults
JavaScript
Interlink.ePad.ePadVision.DeviceDefaults = function();
Interlink.ePad.ePadVision.DeviceDefaults.createEnum('Interlink.ePad.ePadVision.DeviceDefaults', true);

Members

Member name | Description
FACTORYDEFAULT | Factory default. It must be combined with other flag to indicate the desired defaults is factory defaults. If this flag is not presented, the desired defaults is the user customized defaults.
SYSCAL | The system calibration
RPTREATE | The signature point report rate
INKREGION | The inking region
BACKLIGHT | The LCD backlight
DESKTOPCOLORS | The LCD background and watermark color

See Also

Interlink.ePad.ePadVision Namespace
To retrieve the defaults.
To Save the customized defaults.


ePadVision Class

[image]

.NET Framework Class Library
ePadVision Class
See Also Send Feedback

Provides the functionality to access ePad-vision device.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("AC57EF90-C108-417f-A43B-E01613A93BD5")> _
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public Class ePadVision _
    Inherits ePadCore _
    Implements IePadVision
C#
[GuidAttribute("AC57EF90-C108-417f-A43B-E01613A93BD5")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ePadVision : ePadCore, IePadVision
Visual C++
[GuidAttribute(L"AC57EF90-C108-417f-A43B-E01613A93BD5")]
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class ePadVision : public ePadCore,
    IePadVision
JavaScript
Interlink.ePad.ePadVision.ePadVision = function();

Type.createClass(
    'Interlink.ePad.ePadVision.ePadVision',
    Interlink.ePad.ePadCore.ePadCore,
    Interlink.ePad.ePadVision.IePadVision);

Remarks

In Windows Terminal Server or Citrix Server remote access mode, it is required to call IDisposable::Dispose() method to release the TS/ICA virtual channel at the end of session.

Inheritance Hierarchy

System..::.Object
Interlink.ePad.ePadCore..::.ePadCore
Interlink.ePad.ePadVision..::.ePadVision

See Also

Interlink.ePad.ePadVision Namespace


ePadVision Constructor

[image]

.NET Framework Class Library
ePadVision Constructor
ePadVision Class See Also Send Feedback

ePadVision constructor

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ePadVision()
Visual C++
public:
ePadVision()
JavaScript
Interlink.ePad.ePadVision.ePadVision = function();

See Also

ePadVision Class


ePadVision Methods

[image] [image]

.NET Framework Class Library
ePadVision Methods
ePadVision Class See Also Send Feedback

The ePadVision type exposes the following members.

Methods

Name | Description
Close | Put the device into the idle mode and then close the connection. (Overrides ePadCore..::.Close()()().)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Finalizer (Inherited from ePadCore.)
GetFeature | Retrieve the HID feature report. (Overrides ePadCore..::.GetFeature(array<Byte>[]()[]).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Refer ePadCore.Open method to open the device and then put it into normal mode. (Overrides ePadCore..::.Open(Byte).)
RebootDevice | Force the device to reboot.
ReleaseMe | Release the ePad-Vision Object; Expose the IDisposal:Dispose method.
Reset | Set the device into its default status. Reload its default settings; Set it into NORMAL mode; Remove all widgets from desktop; Remove the signature trail; (Overrides ePadCore..::.Reset()()().)
ResetDefaults | Restore the device certain settings into their defaults.
ResetStorage | Reset the storage
SaveSettings | Save all current settings into NV area as the defaults. The savable settings are: Ink Region, Report Rate, Calibration, Desktop Colors, and the LCD backlight brightness level. When the LCD brightness level is set to 0, its value in NV will not be updated. The device treats the previous setting as default.
SetFeature | Send out the HID feature report. (Overrides ePadCore..::.SetFeature(array<Byte>[]()[]).)
SetFWUpgrade | Set the FW upgrade flag True of False. If the FW upgrade flag is True, in its next USB enumeration session the device will automatically talk to a specific application to get and install new FW. To force the device to enumerate, the client can call the method "RebootDevice().
ShowConfigurationDialog | Display a pop-up dialog box to configure the signature data report rate, inking region, backlight brightness, screen saver settings... The dialog box has OK, Cancel button to let user dismiss it. (Overrides ePadCore..::.ShowConfigurationDialog()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ePadVision Class


Close Method

[image]

.NET Framework Class Library
ePadVision..::.Close Method
ePadVision Class See Also Send Feedback

Put the device into the idle mode and then close the connection.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close
C#
public override void Close()
Visual C++
public:
virtual void Close() override
JavaScript
function close();

Implements

IePadVision..::.Close()()()
IePadCore..::.Close()()()

See Also

ePadVision Class


Dispose Method

[image] [image]

.NET Framework Class Library
ePadVision..::.Dispose Method
ePadVision Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Implement IDisposable. (Inherited from ePadCore.)
Dispose(Boolean) | The implementation of disposal. (Inherited from ePadCore.)

See Also

ePadVision Class


GetFeature Method

[image]

.NET Framework Class Library
ePadVision..::.GetFeature Method
ePadVision Class See Also Send Feedback

Retrieve the HID feature report.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overrides Sub GetFeature ( _
    lpReport As Byte() _
)
C#
[ComVisibleAttribute(false)]
public override void GetFeature(
    byte[] lpReport
)
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void GetFeature(
    array<unsigned char>^ lpReport
) override
JavaScript
function getFeature(lpReport);

Parameters

lpReport
Type: array< System..::.Byte >[]()[]
The byte array to hold the report.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the get report.

See Also

ePadVision Class


Open Method

[image]

.NET Framework Class Library
ePadVision..::.Open Method
ePadVision Class See Also Send Feedback

Refer ePadCore.Open method to open the device and then put it into normal mode.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Open ( _
    devIndex As Byte _
)
C#
public override void Open(
    byte devIndex
)
Visual C++
public:
virtual void Open(
    unsigned char devIndex
) override
JavaScript
function open(devIndex);

Parameters

devIndex
Type: System..::.Byte
The device index (0 basis).

Implements

IePadVision..::.Open(Byte)
IePadCore..::.Open(Byte)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Couldn't open the device. The device couldn't process the requests.

See Also

ePadVision Class


RebootDevice Method

[image]

.NET Framework Class Library
ePadVision..::.RebootDevice Method
ePadVision Class See Also Send Feedback

Force the device to reboot.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub RebootDevice
C#
public void RebootDevice()
Visual C++
public:
virtual void RebootDevice() sealed
JavaScript
function rebootDevice();

Implements

IePadVision..::.RebootDevice()()()

Remarks

It is designed for FW upgrade program. The return value only indicates whether the reboot request has been accepted or not. If the request has been accepted, the device will reboot itself and the connection will be lost.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Device access error or internal data is invalid.

See Also

ePadVision Class


ReleaseMe Method

[image]

.NET Framework Class Library
ePadVision..::.ReleaseMe Method
ePadVision Class See Also Send Feedback

Release the ePad-Vision Object; Expose the IDisposal:Dispose method.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReleaseMe
C#
public void ReleaseMe()
Visual C++
public:
virtual void ReleaseMe() sealed
JavaScript
function releaseMe();

Implements

IePadVision..::.ReleaseMe()()()

See Also

ePadVision Class


Reset Method

[image]

.NET Framework Class Library
ePadVision..::.Reset Method
ePadVision Class See Also Send Feedback

Set the device into its default status.
Reload its default settings;
Set it into NORMAL mode;
Remove all widgets from desktop;
Remove the signature trail;

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Reset
C#
public override void Reset()
Visual C++
public:
virtual void Reset() override
JavaScript
function reset();

Implements

IePadVision..::.Reset()()()
IePadCore..::.Reset()()()

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


ResetDefaults Method

[image]

.NET Framework Class Library
ePadVision..::.ResetDefaults Method
ePadVision Class See Also Send Feedback

Restore the device certain settings into their defaults.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub ResetDefaults ( _
    flags As DeviceDefaults _
)
C#
public void ResetDefaults(
    DeviceDefaults flags
)
Visual C++
public:
virtual void ResetDefaults(
    DeviceDefaults flags
) sealed
JavaScript
function resetDefaults(flags);

Parameters

flags
Type: Interlink.ePad.ePadVision..::.DeviceDefaults
The flag combination represents the desired defaults. The flag DeviceDefaults.FACTORYDEFAULT controls whether to restore the defaults to their unchangeable factory defaults or to the user customized defaults stored by the method SaveSettings().

The following table gives the device default flags and their unchangeable factory settings.

Default Flag | Unchangeable Factory Settings
DeviceDefaults.SYSCAL | No calibration at all.
DeviceDefaults.RPTRATE | 100 PPS
DeviceDefaults.INKREGION | Pen Width: 3 pixels; Ink Color: Black; Inking Auto-erase: 5 second, Ink Region: Entire LCD.
DeviceDefaults.BACKLIGHT | 100%
DeviceDefaults.DESKTOPCOLORS | LCD Background Color: light blue; Watermark: Red.

Implements

IePadVision..::.ResetDefaults(DeviceDefaults)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


ResetStorage Method

[image]

.NET Framework Class Library
ePadVision..::.ResetStorage Method
ePadVision Class See Also Send Feedback

Reset the storage

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ResetStorage ( _
    password As String _
)
C#
protected void ResetStorage(
    string password
)
Visual C++
protected:
void ResetStorage(
    String^ password
)
JavaScript
function resetStorage(password);

Parameters

password
Type: System..::.String
The password to grant the operation.

The password is stuck with the device. Normally the last 4 characters of the device serial number is the password. The serial number can be found on the bottom of the device or refer the method ePadVision::GetSerialNumber(out String sNo).

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests. Incorrect password.

See Also

ePadVision Class


SaveSettings Method

[image]

.NET Framework Class Library
ePadVision..::.SaveSettings Method
ePadVision Class See Also Send Feedback

Save all current settings into NV area as the defaults.

The savable settings are: Ink Region, Report Rate, Calibration, Desktop Colors, and the LCD backlight brightness level.

When the LCD brightness level is set to 0, its value in NV will not be updated. The device treats the previous setting as default.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveSettings
C#
public void SaveSettings()
Visual C++
public:
virtual void SaveSettings() sealed
JavaScript
function saveSettings();

Implements

IePadVision..::.SaveSettings()()()

Remarks

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


SetFeature Method

[image]

.NET Framework Class Library
ePadVision..::.SetFeature Method
ePadVision Class See Also Send Feedback

Send out the HID feature report.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Overrides Sub SetFeature ( _
    lpReport As Byte() _
)
C#
[ComVisibleAttribute(false)]
public override void SetFeature(
    byte[] lpReport
)
Visual C++
[ComVisibleAttribute(false)]
public:
virtual void SetFeature(
    array<unsigned char>^ lpReport
) override
JavaScript
function setFeature(lpReport);

Parameters

lpReport
Type: array< System..::.Byte >[]()[]
The byte array of feature report.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the set report.

See Also

ePadVision Class


SetFWUpgrade Method

[image]

.NET Framework Class Library
ePadVision..::.SetFWUpgrade Method
ePadVision Class See Also Send Feedback

Set the FW upgrade flag True of False. If the FW upgrade flag is True, in its next USB enumeration session the device will automatically talk to a specific application to get and install new FW. To force the device to enumerate, the client can call the method "RebootDevice().

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetFWUpgrade ( _
    fOn As Boolean, _
    password As String _
)
C#
public void SetFWUpgrade(
    bool fOn,
    string password
)
Visual C++
public:
virtual void SetFWUpgrade(
    bool fOn,
    String^ password
) sealed
JavaScript
function setFWUpgrade(fOn, password);

Parameters

fOn
Type: System..::.Boolean
Whether the FW upgrade is ON or OFF.
password
Type: System..::.String
The password to grant the operation.

The password is stuck with the device. Normally the last 4 characters of the device serial number is the password. The serial number can be found on the bottom of the device or refer the method ePadVision::GetSerialNumber(out String sNo).

Implements

IePadVision..::.SetFWUpgrade(Boolean, String)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The password is invalid. The device is not open or failed to process the requests.

See Also

ePadVision Class


ShowConfigurationDialog Method

[image]

.NET Framework Class Library
ePadVision..::.ShowConfigurationDialog Method
ePadVision Class See Also Send Feedback

Display a pop-up dialog box to configure the signature data report rate, inking region, backlight brightness, screen saver settings...
The dialog box has OK, Cancel button to let user dismiss it.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub ShowConfigurationDialog
C#
public override void ShowConfigurationDialog()
Visual C++
public:
virtual void ShowConfigurationDialog() override
JavaScript
function showConfigurationDialog();

Implements

IePadVision..::.ShowConfigurationDialog()()()

See Also

ePadVision Class


ePadVision Properties

[image] [image]

.NET Framework Class Library
ePadVision Properties
ePadVision Class See Also Send Feedback

The ePadVision type exposes the following members.

Properties

Name | Description
AvailableRAMSpace | How many storage space are available in the external RAM
AvailableStorageSpace | How many storage space are available in the external Flash
DeviceCount | Gives the number of attached ePad devices. (Inherited from ePadCore.)
FWInfo | Retrieve DeviceFWInfo from device (Overrides ePadCore..::.FWInfo.)
OpenedDeviceIndex | Gives the current opened device index (0-based). If There is no device opened, its value will be -1. (Inherited from ePadCore.)
PadInfo | Retrieve ePadInfo from device (Overrides ePadCore..::.PadInfo.)
ProviderDescription | Give the service provider specific description. (Overrides ePadCore..::.ProviderDescription.)
ScreenSaver | The screensaver instance implements IScreenSaver interface.
SerialNumber | Get the device serial number which has the format: ZZYYMMDDLLSSNNNN ZZ: 00: No external memory; 01: Have external memory; YY: Year; MM: Month; DD: Day of the month; LL: 00: IEUS; 01: Computyme, China; SS: 00: No Station ID; 01--FE: Station ID; FF: Reserved for developer usage; (Overrides ePadCore..::.SerialNumber.)
SerialNumberGUID | The device serial number in GUID format. The GUID number's first 8 bytes is predefined as 0x592883199f1f41b9 and its last 8 bytes have the same value as SerialNumber. (Overrides ePadCore..::.SerialNumberGUID.)
SIFonts | The Widgets Instance.
SignatureDataRange | Retrieve Signature Data Ranges (Overrides ePadCore..::.SignatureDataRange.)
SignaturePad | The pad instance implement ISignaturePad interface.
TotalFlashSpace | How many total storage space in the external Flash
TotalRAMSpace | How many total storage space in the external RAM
Widgets | The Widgets Instance.

See Also

ePadVision Class


AvailableRAMSpace Property

[image]

.NET Framework Class Library
ePadVision..::.AvailableRAMSpace Property
ePadVision Class See Also Send Feedback

How many storage space are available in the external RAM

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AvailableRAMSpace As Integer
C#
public int AvailableRAMSpace { get; }
Visual C++
public:
virtual property int AvailableRAMSpace {
    int get () sealed;
}
JavaScript
function get_availableRAMSpace();

Return Value

number of available space in external RAM in KB

Implements

IePadVision..::.AvailableRAMSpace

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


AvailableStorageSpace Property

[image]

.NET Framework Class Library
ePadVision..::.AvailableStorageSpace Property
ePadVision Class See Also Send Feedback

How many storage space are available in the external Flash

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AvailableStorageSpace As Integer
C#
public int AvailableStorageSpace { get; }
Visual C++
public:
virtual property int AvailableStorageSpace {
    int get () sealed;
}
JavaScript
function get_availableStorageSpace();

Return Value

number of available space in external Flash in KB

Implements

IePadVision..::.AvailableStorageSpace

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


FWInfo Property

[image]

.NET Framework Class Library
ePadVision..::.FWInfo Property
ePadVision Class See Also Send Feedback

Retrieve DeviceFWInfo from device

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FWInfo As DeviceFWInfo
C#
public override DeviceFWInfo FWInfo { get; }
Visual C++
public:
virtual property DeviceFWInfo FWInfo {
    DeviceFWInfo get () override;
}
JavaScript
function get_fwInfo();

Return Value

output DeviceFWInfo structure

Implements

IePadVision..::.FWInfo
IePadCore..::.FWInfo

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


PadInfo Property

[image]

.NET Framework Class Library
ePadVision..::.PadInfo Property
ePadVision Class See Also Send Feedback

Retrieve ePadInfo from device

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property PadInfo As DevicePadInfo
C#
public override DevicePadInfo PadInfo { get; }
Visual C++
public:
virtual property DevicePadInfo PadInfo {
    DevicePadInfo get () override;
}
JavaScript
function get_padInfo();

Return Value

output DevicePadInfo structure

Implements

IePadVision..::.PadInfo
IePadCore..::.PadInfo

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


ProviderDescription Property

[image]

.NET Framework Class Library
ePadVision..::.ProviderDescription Property
ePadVision Class See Also Send Feedback

Give the service provider specific description.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ProviderDescription As String
C#
public override string ProviderDescription { get; }
Visual C++
public:
virtual property String^ ProviderDescription {
    String^ get () override;
}
JavaScript
function get_providerDescription();

Implements

IePadVision..::.ProviderDescription
IePadCore..::.ProviderDescription

See Also

ePadVision Class


ScreenSaver Property

[image]

.NET Framework Class Library
ePadVision..::.ScreenSaver Property
ePadVision Class See Also Send Feedback

The screensaver instance implements IScreenSaver interface.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScreenSaver As ScreenSaver
C#
public ScreenSaver ScreenSaver { get; }
Visual C++
public:
virtual property ScreenSaver^ ScreenSaver {
    ScreenSaver^ get () sealed;
}
JavaScript
function get_screenSaver();

Implements

IePadVision..::.ScreenSaver

See Also

ePadVision Class


SerialNumber Property

[image]

.NET Framework Class Library
ePadVision..::.SerialNumber Property
ePadVision Class See Also Send Feedback

Get the device serial number which has the format:

ZZYYMMDDLLSSNNNN

ZZ:  00: No external memory; 01: Have external memory;
YY:  Year;
MM:  Month;
DD:  Day of the month;
LL:  00: IEUS; 01: Computyme, China;
SS:  00: No Station ID; 01--FE: Station ID; FF: Reserved for developer usage;

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property SerialNumber As String
C#
public override string SerialNumber { get; }
Visual C++
public:
virtual property String^ SerialNumber {
    String^ get () override;
}
JavaScript
function get_serialNumber();

Implements

IePadVision..::.SerialNumber
IePadCore..::.SerialNumber

See Also

ePadVision Class


SerialNumberGUID Property

[image]

.NET Framework Class Library
ePadVision..::.SerialNumberGUID Property
ePadVision Class See Also Send Feedback

The device serial number in GUID format.

The GUID number's first 8 bytes is predefined as 0x592883199f1f41b9 and its last 8 bytes have the same value as SerialNumber.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property SerialNumberGUID As Guid
C#
public override Guid SerialNumberGUID { get; }
Visual C++
public:
virtual property Guid SerialNumberGUID {
    Guid get () override;
}
JavaScript
function get_serialNumberGUID();

Implements

IePadVision..::.SerialNumberGUID
IePadCore..::.SerialNumberGUID

See Also

ePadVision Class


SIFonts Property

[image]

.NET Framework Class Library
ePadVision..::.SIFonts Property
ePadVision Class See Also Send Feedback

The Widgets Instance.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SIFonts As SIFonts
C#
public SIFonts SIFonts { get; }
Visual C++
public:
virtual property SIFonts^ SIFonts {
    SIFonts^ get () sealed;
}
JavaScript
function get_siFonts();

Implements

IePadVision..::.SIFonts

See Also

ePadVision Class


SignatureDataRange Property

[image]

.NET Framework Class Library
ePadVision..::.SignatureDataRange Property
ePadVision Class See Also Send Feedback

Retrieve Signature Data Ranges

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property SignatureDataRange As DeviceSignatureDataRange
C#
public override DeviceSignatureDataRange SignatureDataRange { get; }
Visual C++
public:
virtual property DeviceSignatureDataRange SignatureDataRange {
    DeviceSignatureDataRange get () override;
}
JavaScript
function get_signatureDataRange();

Implements

IePadVision..::.SignatureDataRange
IePadCore..::.SignatureDataRange

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


SignaturePad Property

[image]

.NET Framework Class Library
ePadVision..::.SignaturePad Property
ePadVision Class See Also Send Feedback

The pad instance implement ISignaturePad interface.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SignaturePad As SignaturePad
C#
public SignaturePad SignaturePad { get; }
Visual C++
public:
virtual property SignaturePad^ SignaturePad {
    SignaturePad^ get () sealed;
}
JavaScript
function get_signaturePad();

Implements

IePadVision..::.SignaturePad

See Also

ePadVision Class


TotalFlashSpace Property

[image]

.NET Framework Class Library
ePadVision..::.TotalFlashSpace Property
ePadVision Class See Also Send Feedback

How many total storage space in the external Flash

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalFlashSpace As Integer
C#
public int TotalFlashSpace { get; }
Visual C++
public:
virtual property int TotalFlashSpace {
    int get () sealed;
}
JavaScript
function get_totalFlashSpace();

Return Value

the number of total available space in Flash in KB

Implements

IePadVision..::.TotalFlashSpace

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


TotalRAMSpace Property

[image]

.NET Framework Class Library
ePadVision..::.TotalRAMSpace Property
ePadVision Class See Also Send Feedback

How many total storage space in the external RAM

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalRAMSpace As Integer
C#
public int TotalRAMSpace { get; }
Visual C++
public:
virtual property int TotalRAMSpace {
    int get () sealed;
}
JavaScript
function get_totalRAMSpace();

Return Value

number of total space in external RAM in KB

Implements

IePadVision..::.TotalRAMSpace

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


Widgets Property

[image]

.NET Framework Class Library
ePadVision..::.Widgets Property
ePadVision Class See Also Send Feedback

The Widgets Instance.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Widgets As Widgets
C#
public Widgets Widgets { get; }
Visual C++
public:
virtual property Widgets^ Widgets {
    Widgets^ get () sealed;
}
JavaScript
function get_widgets();

Implements

IePadVision..::.Widgets

See Also

ePadVision Class


ePadVision Events

[image] [image]

.NET Framework Class Library
ePadVision Events
ePadVision Class See Also Send Feedback

The ePadVision type exposes the following members.

Events

Name Description
NotificationDataEvent
Notifies the Widget or GUI relative events.

The event give the source of event (widget ID), the event type, the event code, and it supplement data if applicable.

For widget ID range, please refer CreateWidget(WidgetInfo).

For widget type, please refer EventType.

For event code, please refer EventCode.

The supplement data are in byte[] format.

SignatureDataEvent
Notifies the signature data.

The signature data are reported by a sequence of events and each event represents one sampling point.

The sampling point gives the X, Y coordinate position along with the pressure and the time stamp. The SignatureDataDelegate gives the definitions.

When the pressure value is not zero, the corresponding point is touched point (pen is down). The X, Y coordinate value gives the coordinate position.

When the pressure value is zero, the corresponding point in untouched point (pen is up). For untouched point, its X, Y values are meaningless. The current implementation always reports the untouched point X, Y value as 0.

Only the sampling point within the inking region (see SignaturePad.InkRegion) will be reported. When the pen moves out of inking region, the first out of inking region point will be reported as untouched point and all other out of inking region point will be discarded.

The timestamp gives the point sampling time.

The X, Y, pressure, and the timestamp range or unit defined in DeviceSignatureDataRange of DevicePadInfo given by PadInfo

USBInDataReportEvent
Notifies the USB HID IN report.
(Inherited from ePadCore.)
WgtEvent
Notifies the Widget or GUI relative events.

The event give the source of event (widget ID), the event type, the event code, and it supplement data if applicable.

For widget ID range, please refer CreateWidget(WidgetInfo).

For widget type, please refer EventType.

For event code, please refer EventCode.

See Also

ePadVision Class


NotificationDataEvent Event

[image]

.NET Framework Class Library
ePadVision..::.NotificationDataEvent Event
ePadVision Class See Also Send Feedback

Notifies the Widget or GUI relative events.

The event give the source of event (widget ID), the event type, the event code, and it supplement data if applicable.

For widget ID range, please refer CreateWidget(WidgetInfo).

For widget type, please refer EventType.

For event code, please refer EventCode.

The supplement data are in byte[] format.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Event NotificationDataEvent As EventDataDelegate
C#
public event EventDataDelegate NotificationDataEvent
Visual C++
public:
 event EventDataDelegate^ NotificationDataEvent {
    void add (EventDataDelegate^ value);
    void remove (EventDataDelegate^ value);
}
JavaScript
function add_notificationDataEvent(value);
function remove_notificationDataEvent(value);

See Also

ePadVision Class


SignatureDataEvent Event

[image]

.NET Framework Class Library
ePadVision..::.SignatureDataEvent Event
ePadVision Class See Also Send Feedback

Notifies the signature data.

The signature data are reported by a sequence of events and each event represents one sampling point.

The sampling point gives the X, Y coordinate position along with the pressure and the time stamp. The SignatureDataDelegate gives the definitions.

When the pressure value is not zero, the corresponding point is touched point (pen is down). The X, Y coordinate value gives the coordinate position.

When the pressure value is zero, the corresponding point in untouched point (pen is up). For untouched point, its X, Y values are meaningless. The current implementation always reports the untouched point X, Y value as 0.

Only the sampling point within the inking region (see SignaturePad.InkRegion) will be reported. When the pen moves out of inking region, the first out of inking region point will be reported as untouched point and all other out of inking region point will be discarded.

The timestamp gives the point sampling time.

The X, Y, pressure, and the timestamp range or unit defined in DeviceSignatureDataRange of DevicePadInfo given by PadInfo

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Event SignatureDataEvent As SignatureDataDelegate
C#
public event SignatureDataDelegate SignatureDataEvent
Visual C++
public:
 event SignatureDataDelegate^ SignatureDataEvent {
    void add (SignatureDataDelegate^ value);
    void remove (SignatureDataDelegate^ value);
}
JavaScript
function add_signatureDataEvent(value);
function remove_signatureDataEvent(value);

See Also

ePadVision Class


WgtEvent Event

[image]

.NET Framework Class Library
ePadVision..::.WgtEvent Event
ePadVision Class See Also Send Feedback

Notifies the Widget or GUI relative events.

The event give the source of event (widget ID), the event type, the event code, and it supplement data if applicable.

For widget ID range, please refer CreateWidget(WidgetInfo).

For widget type, please refer EventType.

For event code, please refer EventCode.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Event WgtEvent As WEventDataDelegate
C#
public event WEventDataDelegate WgtEvent
Visual C++
public:
 event WEventDataDelegate^ WgtEvent {
    void add (WEventDataDelegate^ value);
    void remove (WEventDataDelegate^ value);
}
JavaScript
function add_wgtEvent(value);
function remove_wgtEvent(value);

See Also

ePadVision Class


EventCode Enumeration

[image]

.NET Framework Class Library
EventCode Enumeration
See Also Send Feedback

Represent widget events.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration EventCode
C#
public enum EventCode
Visual C++
public enum class EventCode
JavaScript
Interlink.ePad.ePadVision.EventCode = function();
Interlink.ePad.ePadVision.EventCode.createEnum('Interlink.ePad.ePadVision.EventCode', false);

Members

Member name | Description
CREATE_SUCCEED | The widget has been create.
DELETE_DONE | The widget has been deleted.
CHECKED | The widget has been checked (checkbox, radio button)
UNCHECKED | The widget has been unchecked (checkbox, radio button)
CLICKED | The button has been clicked
MOVE_DONE | The widget has been moved.
RESIZE_DONE | The widget has been resized.
ENABLED | The widget has been enabled.
DISABLED | The widget has been disabled.
SHOW | The widget has been shown up
HIDE | The widget has been hidden.
TEXT_DONE | The widget text has been changed.
BKCOLOR_CHANGED | The widget background color has been changed.
FGCOLOR_CHANGED | The widget foreground color has been changed.
EFFECT_CHANGED | The widget appearance effect has been changed.
FONT_CHANGED | The widget font has been changed.
CAL_SUCCEED | The signature x/y axis calibration is done.
CAL_CANCEL | The signature x/y axis calibration has been canceled.
CAL_CANCEL_INVALID | The request to cancel the signature x/y axis calibration is invalid.
CAL_FAILED | The signature x/y axis calibration has been failed
CAL_SAMPLE_POINT_CENTER | The signature x/y axis calibration procedure is going to sample the center position.
CAL_SAMPLE_POINT_TOP | The signature x/y axis calibration procedure is going to sample the top position.
CAL_SAMPLE_POINT_BOTTOM | The signature x/y axis calibration procedure is going to sample the bottom position.
CAL_SAMPLE_POINT_LEFT | The signature x/y axis calibration procedure is going to sample the left position.
CAL_SAMPLE_POINT_RIGHT | The signature x/y axis calibration procedure is going to sample the right position.
INVALID_ID | The received widget ID is invalid.
INVALID_TYPE | Invalid widget type
INVALID_REQUEST | Invalid request (for example, check/uncheck text widget)
INVALID_FONT | Invalid font ID.
CREATE_FAILED | Failed to create widget

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


EventDataDelegate Delegate

[image]

.NET Framework Class Library
EventDataDelegate Delegate
See Also Send Feedback

Define the event handler.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Delegate Sub EventDataDelegate ( _
    widgetID As Byte, _
    widgetType As EventType, _
    eventCode As EventCode, _
    data As Byte() _
)
C#
[ComVisibleAttribute(false)]
public delegate void EventDataDelegate(
    byte widgetID,
    EventType widgetType,
    EventCode eventCode,
    byte[] data
)
Visual C++
[ComVisibleAttribute(false)]
public delegate void EventDataDelegate(
    unsigned char widgetID,
    EventType widgetType,
    EventCode eventCode,
    array<unsigned char>^ data
)
JavaScript
function(widgetID, widgetType, eventCode, data);

Parameters

widgetID
Type: System..::.Byte
The source entity (for example the widget) ID.
widgetType
Type: Interlink.ePad.ePadVision..::.EventType
The event type.
eventCode
Type: Interlink.ePad.ePadVision..::.EventCode
The incurred event code.
data
Type: array< System..::.Byte >[]()[]
The event extra data.

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


EventType Enumeration

[image]

.NET Framework Class Library
EventType Enumeration
See Also Send Feedback

The event type indicator

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration EventType
C#
public enum EventType
Visual C++
public enum class EventType
JavaScript
Interlink.ePad.ePadVision.EventType = function();
Interlink.ePad.ePadVision.EventType.createEnum('Interlink.ePad.ePadVision.EventType', false);

Members

Member name | Description
TEXT | Text widget
BUTTON | Push Button widget
CHECKBOX | Checkbox widget
RADIOBUTTON | Radio Button widget
CALIBRATION | Calibration Target

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


ExternalDevice Enumeration

[image]

.NET Framework Class Library
ExternalDevice Enumeration
See Also Send Feedback

Defines the external storage device for ePad-vision

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ExternalDevice
C#
public enum ExternalDevice
Visual C++
public enum class ExternalDevice
JavaScript
Interlink.ePad.ePadVision.ExternalDevice = function();
Interlink.ePad.ePadVision.ExternalDevice.createEnum('Interlink.ePad.ePadVision.ExternalDevice', false);

Members

Member name | Description
FLASH | Flash device, 8 MB capacity
PSRAM | PSRAM device, 8 MB capacity

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


FontEntry Class

[image]

.NET Framework Class Library
FontEntry Class
See Also Send Feedback

FontEntry class defines downloadable font detail info from ePad-vision external devices, RAM or FLASH.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
<GuidAttribute("4CBDFC67-B008-4761-8CD9-54C2C663B88C")> _
<ComVisibleAttribute(True)> _
Public Class FontEntry _
    Implements IFontEntry
C#
[ClassInterfaceAttribute(ClassInterfaceType.None)]
[GuidAttribute("4CBDFC67-B008-4761-8CD9-54C2C663B88C")]
[ComVisibleAttribute(true)]
public class FontEntry : IFontEntry
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::None)]
[GuidAttribute(L"4CBDFC67-B008-4761-8CD9-54C2C663B88C")]
[ComVisibleAttribute(true)]
public ref class FontEntry : IFontEntry
JavaScript
Interlink.ePad.ePadVision.FontEntry = function();

Type.createClass(
    'Interlink.ePad.ePadVision.FontEntry',
    null,
    Interlink.ePad.ePadVision.IFontEntry);

Inheritance Hierarchy

System..::.Object
Interlink.ePad.ePadVision..::.FontEntry

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


FontEntry Constructor

[image]

.NET Framework Class Library
FontEntry Constructor
FontEntry Class See Also Send Feedback

the fontentry overwrite constructor

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    id As Byte, _
    name As String, _
    size As Integer _
)
C#
public FontEntry(
    byte id,
    string name,
    int size
)
Visual C++
public:
FontEntry(
    unsigned char id,
    String^ name,
    int size
)
JavaScript
Interlink.ePad.ePadVision.FontEntry = function(id, name, size);

Parameters

id
Type: System..::.Byte
name
Type: System..::.String
size
Type: System..::.Int32

See Also

FontEntry Class


FontEntry Methods

[image] [image]

.NET Framework Class Library
FontEntry Methods
FontEntry Class See Also Send Feedback

The FontEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontEntry Class


FontEntry Properties

[image] [image]

.NET Framework Class Library
FontEntry Properties
FontEntry Class See Also Send Feedback

The FontEntry type exposes the following members.

Properties

Name | Description
id | the font id used in the RAM or index of the font list from Flash
name | the font name stored in the external device
size | the font size stored in the external device

See Also

FontEntry Class


id Property

[image]

.NET Framework Class Library
FontEntry..::.id Property
FontEntry Class See Also Send Feedback

the font id used in the RAM or index of the font list from Flash

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property id As Byte
C#
public byte id { get; }
Visual C++
public:
virtual property unsigned char id {
    unsigned char get () sealed;
}
JavaScript
function get_id();

Implements

IFontEntry..::.id

See Also

FontEntry Class


name Property

[image]

.NET Framework Class Library
FontEntry..::.name Property
FontEntry Class See Also Send Feedback

the font name stored in the external device

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property name As String
C#
public string name { get; }
Visual C++
public:
virtual property String^ name {
    String^ get () sealed;
}
JavaScript
function get_name();

Implements

IFontEntry..::.name

See Also

FontEntry Class


size Property

[image]

.NET Framework Class Library
FontEntry..::.size Property
FontEntry Class See Also Send Feedback

the font size stored in the external device

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property size As Integer
C#
public int size { get; }
Visual C++
public:
virtual property int size {
    int get () sealed;
}
JavaScript
function get_size();

Implements

IFontEntry..::.size

See Also

FontEntry Class


FontID Enumeration

[image]

.NET Framework Class Library
FontID Enumeration
See Also Send Feedback

Gives the font identifications. The name of each enumerator has the format XXX_Y_ZZ where

XXX could be either SAN (stands for San Serif ), MON (stands for Monospaced), or COM (stands for Comic).

Y could be with (R (stands for Regular) or B (stands for Bold).

Z is the number represents the font size in pixel.

There are maximum 25 downloadable font id, from DOWNLOAD_200 to DOWNLOAD_224, available to identify the downloaded font in the ePad-vision's external device.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FontID
C#
public enum FontID
Visual C++
public enum class FontID
JavaScript
Interlink.ePad.ePadVision.FontID = function();
Interlink.ePad.ePadVision.FontID.createEnum('Interlink.ePad.ePadVision.FontID', false);

Members

Member name | Description
SYS_FIRSTFONT_ID | The fist enumerator
SAN_R_13 | Normal San Serif font 13
SAN_B_13 | Bold San Serif font 13
SAN_R_16 | Normal San Serif font 16
SAN_B_16 | Bold San Serif font 16
SAN_R_20 | Normal San Serif font 20
SAN_B_20 | Bold San Serif font 20
SAN_R_24 | Normal San Serif font 24
SAN_B_24 | Bold San Serif font 24
SAN_R_32 | Normal San Serif font 32
SAN_B_32 | Bold San Serif font 32
MON_B_08 | Bold Monospaced font 8
MON_B_09 | Bold Monospaced font 9
MON_B_10 | Bold Monospaced spaced font 10
MON_B_12 | Bold Monospaced font 12
MON_R_13 | Normal Monospaced font 13
MON_B_15 | Bold Monospaced font 15
MON_B_16 | Bold Monospaced font 16
MON_B_17 | Bold Monospaced font 17
MON_B_18 | Bold Monospaced font 18
MON_B_48 | Bold Monospaced font 48
COM_B_18 | Bold Comic font 18
COM_B_24 | Bold Comic font 24
DOWNLOAD_200 | Downloadable font 200
DOWNLOAD_201 | Downloadable font 201
DOWNLOAD_202 | Downloadable font 202
DOWNLOAD_203 | Downloadable font 203
DOWNLOAD_204 | Downloadable font 204
DOWNLOAD_205 | Downloadable font 205
DOWNLOAD_206 | Downloadable font 206
DOWNLOAD_207 | Downloadable font 207
DOWNLOAD_208 | Downloadable font 208
DOWNLOAD_209 | Downloadable font 209
DOWNLOAD_210 | Downloadable font 210
DOWNLOAD_211 | Downloadable font 211
DOWNLOAD_212 | Downloadable font 212
DOWNLOAD_213 | Downloadable font 213
DOWNLOAD_214 | Downloadable font 214
DOWNLOAD_215 | Downloadable font 215
DOWNLOAD_216 | Downloadable font 216
DOWNLOAD_217 | Downloadable font 217
DOWNLOAD_218 | Downloadable font 218
DOWNLOAD_219 | Downloadable font 219
DOWNLOAD_220 | Downloadable font 220
DOWNLOAD_221 | Downloadable font 221
DOWNLOAD_222 | Downloadable font 222
DOWNLOAD_223 | Downloadable font 223
DOWNLOAD_224 | Downloadable font 224
SYS_LASTFONT_ID | The last enumerator

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


FontList Class

[image]

.NET Framework Class Library
FontList Class
See Also Send Feedback

FontList class implement a List of FontEntry and IFontList interface

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("05C548CF-370B-4fdc-BB66-B0701DDAE6CE")> _
<ComVisibleAttribute(True)> _
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public Class FontList _
    Inherits List(Of FontEntry) _
    Implements IFontList
C#
[GuidAttribute("05C548CF-370B-4fdc-BB66-B0701DDAE6CE")]
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FontList : List<FontEntry>,
    IFontList
Visual C++
[GuidAttribute(L"05C548CF-370B-4fdc-BB66-B0701DDAE6CE")]
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class FontList : public List<FontEntry^>,
    IFontList
JavaScript
Interlink.ePad.ePadVision.FontList = function();

Type.createClass(
    'Interlink.ePad.ePadVision.FontList',
    List`1,
    Interlink.ePad.ePadVision.IFontList);

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( FontEntry >)>)
Interlink.ePad.ePadVision..::.FontList

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


FontList Constructor

[image]

.NET Framework Class Library
FontList Constructor
FontList Class See Also Send Feedback

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FontList()
Visual C++
public:
FontList()
JavaScript
Interlink.ePad.ePadVision.FontList = function();

See Also

FontList Class


FontList Methods

[image] [image]

.NET Framework Class Library
FontList Methods
FontList Class See Also Send Feedback

The FontList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( FontEntry >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( FontEntry >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( FontEntry >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( FontEntry >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( FontEntry >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( FontEntry >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( FontEntry >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( FontEntry >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( FontEntry >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( FontEntry >)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | (Inherited from List <(Of <( FontEntry >)>).)
IFontList..::.Add |
IList..::.Contains | (Inherited from List <(Of <( FontEntry >)>).)
ICollection..::.CopyTo | (Inherited from List <(Of <( FontEntry >)>).)
IFontList..::.Get |
System#Collections#Generic#IEnumerable{T}#GetEnumerator | (Inherited from List <(Of <( FontEntry >)>).)
IEnumerable..::.GetEnumerator | (Inherited from List <(Of <( FontEntry >)>).)
IList..::.IndexOf | (Inherited from List <(Of <( FontEntry >)>).)
IList..::.Insert | (Inherited from List <(Of <( FontEntry >)>).)
IList..::.Remove | (Inherited from List <(Of <( FontEntry >)>).)
IFontList..::.Remove |

See Also

FontList Class


BinarySearch Method

[image] [image]

.NET Framework Class Library
FontList..::.BinarySearch Method
FontList Class See Also Send Feedback

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( FontEntry >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( FontEntry >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( FontEntry >)>).)

See Also

FontList Class


CopyTo Method

[image] [image]

.NET Framework Class Library
FontList..::.CopyTo Method
FontList Class See Also Send Feedback

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( FontEntry >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( FontEntry >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( FontEntry >)>).)

See Also

FontList Class


FindIndex Method

[image] [image]

.NET Framework Class Library
FontList..::.FindIndex Method
FontList Class See Also Send Feedback

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( FontEntry >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( FontEntry >)>).)

See Also

FontList Class


FindLastIndex Method

[image] [image]

.NET Framework Class Library
FontList..::.FindLastIndex Method
FontList Class See Also Send Feedback

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( FontEntry >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( FontEntry >)>).)

See Also

FontList Class


IFontList.Add Method

[image]

.NET Framework Class Library
FontList..::.IFontList..::.Add Method
FontList Class See Also Send Feedback

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Private Sub Add ( _
    obj As FontEntry _
) Implements IFontList.Add
C#
void IFontList.Add(
    FontEntry obj
)
Visual C++
private:
virtual void Add(
    FontEntry^ obj
) sealed = IFontList::Add
JavaScript
JavaScript does not support explicit interface implementations.

Parameters

obj
Type: Interlink.ePad.ePadVision..::.FontEntry

Implements

IFontList..::.Add(FontEntry)

See Also

FontList Class


IFontList.Get Method

[image]

.NET Framework Class Library
FontList..::.IFontList..::.Get Method
FontList Class See Also Send Feedback

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Private Function Get ( _
    index As Integer _
) As FontEntry Implements IFontList.Get
C#
FontEntry IFontList.Get(
    int index
)
Visual C++
private:
virtual FontEntry^ Get(
    int index
) sealed = IFontList::Get
JavaScript
JavaScript does not support explicit interface implementations.

Parameters

index
Type: System..::.Int32

Implements

IFontList..::.Get(Int32)

See Also

FontList Class


IFontList.Remove Method

[image]

.NET Framework Class Library
FontList..::.IFontList..::.Remove Method
FontList Class See Also Send Feedback

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Private Sub Remove ( _
    obj As FontEntry _
) Implements IFontList.Remove
C#
void IFontList.Remove(
    FontEntry obj
)
Visual C++
private:
virtual void Remove(
    FontEntry^ obj
) sealed = IFontList::Remove
JavaScript
JavaScript does not support explicit interface implementations.

Parameters

obj
Type: Interlink.ePad.ePadVision..::.FontEntry

Implements

IFontList..::.Remove(FontEntry)

See Also

FontList Class


IndexOf Method

[image] [image]

.NET Framework Class Library
FontList..::.IndexOf Method
FontList Class See Also Send Feedback

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( FontEntry >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( FontEntry >)>).)

See Also

FontList Class


LastIndexOf Method

[image] [image]

.NET Framework Class Library
FontList..::.LastIndexOf Method
FontList Class See Also Send Feedback

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( FontEntry >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( FontEntry >)>).)

See Also

FontList Class


Reverse Method

[image] [image]

.NET Framework Class Library
FontList..::.Reverse Method
FontList Class See Also Send Feedback

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( FontEntry >)>).)

See Also

FontList Class


Sort Method

[image] [image]

.NET Framework Class Library
FontList..::.Sort Method
FontList Class See Also Send Feedback

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( FontEntry >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( FontEntry >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( FontEntry >)>).)

See Also

FontList Class


FontList Properties

[image] [image]

.NET Framework Class Library
FontList Properties
FontList Class See Also Send Feedback

The FontList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( FontEntry >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( FontEntry >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( FontEntry >)>).)

Explicit Interface Implementations

Name | Description
IFontList..::.Count |
IList..::.IsFixedSize | (Inherited from List <(Of <( FontEntry >)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | (Inherited from List <(Of <( FontEntry >)>).)
IList..::.IsReadOnly | (Inherited from List <(Of <( FontEntry >)>).)
ICollection..::.IsSynchronized | (Inherited from List <(Of <( FontEntry >)>).)
IList..::.Item | (Inherited from List <(Of <( FontEntry >)>).)
ICollection..::.SyncRoot | (Inherited from List <(Of <( FontEntry >)>).)

See Also

FontList Class


IFontList.Count Property

[image]

.NET Framework Class Library
FontList..::.IFontList..::.Count Property
FontList Class See Also Send Feedback

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements IFontList.Count
C#
int IFontList.Count { get; }
Visual C++
private:
virtual property int Count {
    int get () sealed = IFontList::Count::get;
}
JavaScript
JavaScript does not support explicit interface implementations.

Implements

IFontList..::.Count

See Also

FontList Class


IePadVision Interface

[image]

.NET Framework Class Library
IePadVision Interface
See Also Send Feedback

This interface defines ePadVision particular functionality.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("C7C6B482-9F8A-4cfb-A8FD-668A60F3AAD9")> _
Public Interface IePadVision
C#
[GuidAttribute("C7C6B482-9F8A-4cfb-A8FD-668A60F3AAD9")]
public interface IePadVision
Visual C++
[GuidAttribute(L"C7C6B482-9F8A-4cfb-A8FD-668A60F3AAD9")]
public interface class IePadVision
JavaScript
Interlink.ePad.ePadVision.IePadVision = function();
Interlink.ePad.ePadVision.IePadVision.createInterface('Interlink.ePad.ePadVision.IePadVision');

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


IePadVision Methods

[image] [image]

.NET Framework Class Library
IePadVision Methods
IePadVision Interface See Also Send Feedback

The IePadVision type exposes the following members.

Methods

Name | Description
Close | Close the device if applicable. This method does certain device relative actions. For example, it could turn off the LCD...
Open | Open a device specified by device index and reset it to its power-up status. At any time, only one device can be opened per instance. If there is any device opened before, this method will close it before opening other desired device. The device must be open firstly before calling any other methods to access the device functionality.
RebootDevice | Force the device to reboot.
ReleaseMe | Force the ePad-vision Dispose to be called
Reset | Restore the device to its power-up status.
ResetDefaults | Reset the device certain settings into their defaults.
SaveSettings | Save all current settings into NV area as the defaults.
SetFWUpgrade | Set the FW upgrade flag True of False. If the FW upgrade flag is True, in its next USB enumeration session the device will automatically talk to a specific application to get and install new FW. To force the device to enumerate, the client can call the method "RebootDevice().
ShowConfigurationDialog | Display the ePad-vision device related configuration dialog box.

See Also

IePadVision Interface


Close Method

[image]

.NET Framework Class Library
IePadVision..::.Close Method
IePadVision Interface See Also Send Feedback

Close the device if applicable.

This method does certain device relative actions. For example, it could turn off the LCD...

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Close
C#
void Close()
Visual C++
void Close()
JavaScript
function close();

See Also

IePadVision Interface


Open Method

[image]

.NET Framework Class Library
IePadVision..::.Open Method
IePadVision Interface See Also Send Feedback

Open a device specified by device index and reset it to its power-up status. At any time, only one device can be opened per instance.

If there is any device opened before, this method will close it before opening other desired device.

The device must be open firstly before calling any other methods to access the device functionality.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Open ( _
    deviceIndex As Byte _
)
C#
void Open(
    byte deviceIndex
)
Visual C++
void Open(
    unsigned char deviceIndex
)
JavaScript
function open(deviceIndex);

Parameters

deviceIndex
Type: System..::.Byte
The device index (0 basis).

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Couldn't open the device.

See Also

IePadVision Interface


RebootDevice Method

[image]

.NET Framework Class Library
IePadVision..::.RebootDevice Method
IePadVision Interface See Also Send Feedback

Force the device to reboot.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub RebootDevice
C#
void RebootDevice()
Visual C++
void RebootDevice()
JavaScript
function rebootDevice();

Return Value

"true" if the device has accepted the request. Otherwise "false" is returned.

Remarks

It is designed for FW upgrade program. The return value only indicates whether the reboot request has been accepted or not. If the request has been accepted, the device will reboot itself and the connection will be lost.

See Also

IePadVision Interface


ReleaseMe Method

[image]

.NET Framework Class Library
IePadVision..::.ReleaseMe Method
IePadVision Interface See Also Send Feedback

Force the ePad-vision Dispose to be called

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub ReleaseMe
C#
void ReleaseMe()
Visual C++
void ReleaseMe()
JavaScript
function releaseMe();

See Also

IePadVision Interface


Reset Method

[image]

.NET Framework Class Library
IePadVision..::.Reset Method
IePadVision Interface See Also Send Feedback

Restore the device to its power-up status.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Reset
C#
void Reset()
Visual C++
void Reset()
JavaScript
function reset();

See Also

IePadVision Interface


ResetDefaults Method

[image]

.NET Framework Class Library
IePadVision..::.ResetDefaults Method
IePadVision Interface See Also Send Feedback

Reset the device certain settings into their defaults.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub ResetDefaults ( _
    flags As DeviceDefaults _
)
C#
void ResetDefaults(
    DeviceDefaults flags
)
Visual C++
void ResetDefaults(
    DeviceDefaults flags
)
JavaScript
function resetDefaults(flags);

Parameters

flags
Type: Interlink.ePad.ePadVision..::.DeviceDefaults
The flag combination to indicate the desired defaults.

See Also

IePadVision Interface


SaveSettings Method

[image]

.NET Framework Class Library
IePadVision..::.SaveSettings Method
IePadVision Interface See Also Send Feedback

Save all current settings into NV area as the defaults.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub SaveSettings
C#
void SaveSettings()
Visual C++
void SaveSettings()
JavaScript
function saveSettings();

See Also

IePadVision Interface


SetFWUpgrade Method

[image]

.NET Framework Class Library
IePadVision..::.SetFWUpgrade Method
IePadVision Interface See Also Send Feedback

Set the FW upgrade flag True of False. If the FW upgrade flag is True, in its next USB enumeration session the device will automatically talk to a specific application to get and install new FW. To force the device to enumerate, the client can call the method "RebootDevice().

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub SetFWUpgrade ( _
    fOn As Boolean, _
    password As String _
)
C#
void SetFWUpgrade(
    bool fOn,
    string password
)
Visual C++
void SetFWUpgrade(
    bool fOn,
    String^ password
)
JavaScript
function setFWUpgrade(fOn, password);

Parameters

fOn
Type: System..::.Boolean
Whether the FW upgrade is ON or OFF.
password
Type: System..::.String
A particular word to make sure the client intends to change the flag.

See Also

IePadVision Interface


ShowConfigurationDialog Method

[image]

.NET Framework Class Library
IePadVision..::.ShowConfigurationDialog Method
IePadVision Interface See Also Send Feedback

Display the ePad-vision device related configuration dialog box.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub ShowConfigurationDialog
C#
void ShowConfigurationDialog()
Visual C++
void ShowConfigurationDialog()
JavaScript
function showConfigurationDialog();

See Also

IePadVision Interface


IePadVision Properties

[image] [image]

.NET Framework Class Library
IePadVision Properties
IePadVision Interface See Also Send Feedback

The IePadVision type exposes the following members.

Properties

Name | Description
AvailableRAMSpace | How many storage space in the external RAM are available.
AvailableStorageSpace | How many storage space in the external Flash are available.
DeviceCount | Gives the number of attached devices.
FWInfo | The FW identification info.
OpenedDeviceIndex | Gives the current opened device index (0-based). If There is no device opened, its value will be -1.
PadInfo | The device physical info.
ProviderDescription | Gives the description about the incurred particular .Net components. For example, if it is ePad-vision or other device component.
ScreenSaver | The screensaver instance implements IScreenSaver interface.
SerialNumber | The device serial number.
SerialNumberGUID | The device serial number in GUID format
SIFonts | The SIF instance implement ISIFonts interface.
SignatureDataRange | The signature data X-axis, Y-axis and pressure ranges.
SignaturePad | The pad instance implement ISignaturePad interface.
TotalFlashSpace | Total storage space in the external Flash.
TotalRAMSpace | Total storage space in the external RAM.
Widgets | The widget management instance implements IWidgets interface.

See Also

IePadVision Interface


AvailableRAMSpace Property

[image]

.NET Framework Class Library
IePadVision..::.AvailableRAMSpace Property
IePadVision Interface See Also Send Feedback

How many storage space in the external RAM are available.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AvailableRAMSpace As Integer
C#
int AvailableRAMSpace { get; }
Visual C++
property int AvailableRAMSpace {
    int get ();
}
JavaScript
function get_availableRAMSpace();

See Also

IePadVision Interface


AvailableStorageSpace Property

[image]

.NET Framework Class Library
IePadVision..::.AvailableStorageSpace Property
IePadVision Interface See Also Send Feedback

How many storage space in the external Flash are available.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AvailableStorageSpace As Integer
C#
int AvailableStorageSpace { get; }
Visual C++
property int AvailableStorageSpace {
    int get ();
}
JavaScript
function get_availableStorageSpace();

See Also

IePadVision Interface


DeviceCount Property

[image]

.NET Framework Class Library
IePadVision..::.DeviceCount Property
IePadVision Interface See Also Send Feedback

Gives the number of attached devices.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DeviceCount As Integer
C#
int DeviceCount { get; }
Visual C++
property int DeviceCount {
    int get ();
}
JavaScript
function get_deviceCount();

See Also

IePadVision Interface


FWInfo Property

[image]

.NET Framework Class Library
IePadVision..::.FWInfo Property
IePadVision Interface See Also Send Feedback

The FW identification info.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FWInfo As DeviceFWInfo
C#
DeviceFWInfo FWInfo { get; }
Visual C++
property DeviceFWInfo FWInfo {
    DeviceFWInfo get ();
}
JavaScript
function get_fwInfo();

See Also

IePadVision Interface


OpenedDeviceIndex Property

[image]

.NET Framework Class Library
IePadVision..::.OpenedDeviceIndex Property
IePadVision Interface See Also Send Feedback

Gives the current opened device index (0-based). If There is no device opened, its value will be -1.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property OpenedDeviceIndex As Integer
C#
int OpenedDeviceIndex { get; }
Visual C++
property int OpenedDeviceIndex {
    int get ();
}
JavaScript
function get_openedDeviceIndex();

See Also

IePadVision Interface


PadInfo Property

[image]

.NET Framework Class Library
IePadVision..::.PadInfo Property
IePadVision Interface See Also Send Feedback

The device physical info.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PadInfo As DevicePadInfo
C#
DevicePadInfo PadInfo { get; }
Visual C++
property DevicePadInfo PadInfo {
    DevicePadInfo get ();
}
JavaScript
function get_padInfo();

See Also

IePadVision Interface


ProviderDescription Property

[image]

.NET Framework Class Library
IePadVision..::.ProviderDescription Property
IePadVision Interface See Also Send Feedback

Gives the description about the incurred particular .Net components. For example, if it is ePad-vision or other device component.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ProviderDescription As String
C#
string ProviderDescription { get; }
Visual C++
property String^ ProviderDescription {
    String^ get ();
}
JavaScript
function get_providerDescription();

See Also

IePadVision Interface


ScreenSaver Property

[image]

.NET Framework Class Library
IePadVision..::.ScreenSaver Property
IePadVision Interface See Also Send Feedback

The screensaver instance implements IScreenSaver interface.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ScreenSaver As ScreenSaver
C#
ScreenSaver ScreenSaver { get; }
Visual C++
property ScreenSaver^ ScreenSaver {
    ScreenSaver^ get ();
}
JavaScript
function get_screenSaver();

See Also

IePadVision Interface


SerialNumber Property

[image]

.NET Framework Class Library
IePadVision..::.SerialNumber Property
IePadVision Interface See Also Send Feedback

The device serial number.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SerialNumber As String
C#
string SerialNumber { get; }
Visual C++
property String^ SerialNumber {
    String^ get ();
}
JavaScript
function get_serialNumber();

See Also

IePadVision Interface


SerialNumberGUID Property

[image]

.NET Framework Class Library
IePadVision..::.SerialNumberGUID Property
IePadVision Interface See Also Send Feedback

The device serial number in GUID format

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SerialNumberGUID As Guid
C#
Guid SerialNumberGUID { get; }
Visual C++
property Guid SerialNumberGUID {
    Guid get ();
}
JavaScript
function get_serialNumberGUID();

See Also

IePadVision Interface


SIFonts Property

[image]

.NET Framework Class Library
IePadVision..::.SIFonts Property
IePadVision Interface See Also Send Feedback

The SIF instance implement ISIFonts interface.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SIFonts As SIFonts
C#
SIFonts SIFonts { get; }
Visual C++
property SIFonts^ SIFonts {
    SIFonts^ get ();
}
JavaScript
function get_siFonts();

See Also

IePadVision Interface


SignatureDataRange Property

[image]

.NET Framework Class Library
IePadVision..::.SignatureDataRange Property
IePadVision Interface See Also Send Feedback

The signature data X-axis, Y-axis and pressure ranges.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SignatureDataRange As DeviceSignatureDataRange
C#
DeviceSignatureDataRange SignatureDataRange { get; }
Visual C++
property DeviceSignatureDataRange SignatureDataRange {
    DeviceSignatureDataRange get ();
}
JavaScript
function get_signatureDataRange();

See Also

IePadVision Interface


SignaturePad Property

[image]

.NET Framework Class Library
IePadVision..::.SignaturePad Property
IePadVision Interface See Also Send Feedback

The pad instance implement ISignaturePad interface.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SignaturePad As SignaturePad
C#
SignaturePad SignaturePad { get; }
Visual C++
property SignaturePad^ SignaturePad {
    SignaturePad^ get ();
}
JavaScript
function get_signaturePad();

See Also

IePadVision Interface


TotalFlashSpace Property

[image]

.NET Framework Class Library
IePadVision..::.TotalFlashSpace Property
IePadVision Interface See Also Send Feedback

Total storage space in the external Flash.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TotalFlashSpace As Integer
C#
int TotalFlashSpace { get; }
Visual C++
property int TotalFlashSpace {
    int get ();
}
JavaScript
function get_totalFlashSpace();

See Also

IePadVision Interface


TotalRAMSpace Property

[image]

.NET Framework Class Library
IePadVision..::.TotalRAMSpace Property
IePadVision Interface See Also Send Feedback

Total storage space in the external RAM.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TotalRAMSpace As Integer
C#
int TotalRAMSpace { get; }
Visual C++
property int TotalRAMSpace {
    int get ();
}
JavaScript
function get_totalRAMSpace();

See Also

IePadVision Interface


Widgets Property

[image]

.NET Framework Class Library
IePadVision..::.Widgets Property
IePadVision Interface See Also Send Feedback

The widget management instance implements IWidgets interface.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Widgets As Widgets
C#
Widgets Widgets { get; }
Visual C++
property Widgets^ Widgets {
    Widgets^ get ();
}
JavaScript
function get_widgets();

See Also

IePadVision Interface


IFontEntry Interface

[image]

.NET Framework Class Library
IFontEntry Interface
See Also Send Feedback

IFontEntry defines the interface of FontEntry

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("384E0D04-94EA-4d3b-B974-D4BCF312BBF0")> _
<ComVisibleAttribute(True)> _
Public Interface IFontEntry
C#
[GuidAttribute("384E0D04-94EA-4d3b-B974-D4BCF312BBF0")]
[ComVisibleAttribute(true)]
public interface IFontEntry
Visual C++
[GuidAttribute(L"384E0D04-94EA-4d3b-B974-D4BCF312BBF0")]
[ComVisibleAttribute(true)]
public interface class IFontEntry
JavaScript
Interlink.ePad.ePadVision.IFontEntry = function();
Interlink.ePad.ePadVision.IFontEntry.createInterface('Interlink.ePad.ePadVision.IFontEntry');

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


IFontEntry Properties

[image] [image]

.NET Framework Class Library
IFontEntry Properties
IFontEntry Interface See Also Send Feedback

The IFontEntry type exposes the following members.

Properties

Name | Description
id | When getting font list from Flash, the id is the index within list. When getting font list from RAM, the id is the corresponding font id.
name | The name of font, should be less than 32 bytes long.
size | The file size of a font, in bytes.

See Also

IFontEntry Interface


id Property

[image]

.NET Framework Class Library
IFontEntry..::.id Property
IFontEntry Interface See Also Send Feedback

When getting font list from Flash, the id is the index within list. When getting font list from RAM, the id is the corresponding font id.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property id As Byte
C#
byte id { get; }
Visual C++
property unsigned char id {
    unsigned char get ();
}
JavaScript
function get_id();

See Also

IFontEntry Interface


name Property

[image]

.NET Framework Class Library
IFontEntry..::.name Property
IFontEntry Interface See Also Send Feedback

The name of font, should be less than 32 bytes long.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property name As String
C#
string name { get; }
Visual C++
property String^ name {
    String^ get ();
}
JavaScript
function get_name();

See Also

IFontEntry Interface


size Property

[image]

.NET Framework Class Library
IFontEntry..::.size Property
IFontEntry Interface See Also Send Feedback

The file size of a font, in bytes.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property size As Integer
C#
int size { get; }
Visual C++
property int size {
    int get ();
}
JavaScript
function get_size();

See Also

IFontEntry Interface


IFontList Interface

[image]

.NET Framework Class Library
IFontList Interface
See Also Send Feedback

IFontList defines a wrapper for List collection of FontEntry

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("04DF38F3-3C23-485d-8C9A-C33759BD8D86")> _
<ComVisibleAttribute(True)> _
Public Interface IFontList
C#
[GuidAttribute("04DF38F3-3C23-485d-8C9A-C33759BD8D86")]
[ComVisibleAttribute(true)]
public interface IFontList
Visual C++
[GuidAttribute(L"04DF38F3-3C23-485d-8C9A-C33759BD8D86")]
[ComVisibleAttribute(true)]
public interface class IFontList
JavaScript
Interlink.ePad.ePadVision.IFontList = function();
Interlink.ePad.ePadVision.IFontList.createInterface('Interlink.ePad.ePadVision.IFontList');

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


IFontList Methods

[image] [image]

.NET Framework Class Library
IFontList Methods
IFontList Interface See Also Send Feedback

The IFontList type exposes the following members.

Methods

Name | Description
Add | Provide method to add FontEntry into List
Get | Provide method to get FontEntry by using indexing from List
Remove | Provide method to remove FontEntry out of List

See Also

IFontList Interface


Add Method

[image]

.NET Framework Class Library
IFontList..::.Add Method
IFontList Interface See Also Send Feedback

Provide method to add FontEntry into List

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Add ( _
    obj As FontEntry _
)
C#
void Add(
    FontEntry obj
)
Visual C++
void Add(
    FontEntry^ obj
)
JavaScript
function add(obj);

Parameters

obj
Type: Interlink.ePad.ePadVision..::.FontEntry

See Also

IFontList Interface


Get Method

[image]

.NET Framework Class Library
IFontList..::.Get Method
IFontList Interface See Also Send Feedback

Provide method to get FontEntry by using indexing from List

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Function Get ( _
    indx As Integer _
) As FontEntry
C#
FontEntry Get(
    int indx
)
Visual C++
FontEntry^ Get(
    int indx
)
JavaScript
function get(indx);

Parameters

indx
Type: System..::.Int32

See Also

IFontList Interface


Remove Method

[image]

.NET Framework Class Library
IFontList..::.Remove Method
IFontList Interface See Also Send Feedback

Provide method to remove FontEntry out of List

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Remove ( _
    obj As FontEntry _
)
C#
void Remove(
    FontEntry obj
)
Visual C++
void Remove(
    FontEntry^ obj
)
JavaScript
function remove(obj);

Parameters

obj
Type: Interlink.ePad.ePadVision..::.FontEntry

See Also

IFontList Interface


IFontList Properties

[image] [image]

.NET Framework Class Library
IFontList Properties
IFontList Interface See Also Send Feedback

The IFontList type exposes the following members.

Properties

Name | Description
Count | return the number of member count in the Font List

See Also

IFontList Interface


Count Property

[image]

.NET Framework Class Library
IFontList..::.Count Property
IFontList Interface See Also Send Feedback

return the number of member count in the Font List

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
C#
int Count { get; }
Visual C++
property int Count {
    int get ();
}
JavaScript
function get_count();

See Also

IFontList Interface


ImageDisplayMode Enumeration

[image]

.NET Framework Class Library
ImageDisplayMode Enumeration
See Also Send Feedback

Defines how the screensaver display the images.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ImageDisplayMode
C#
public enum ImageDisplayMode
Visual C++
public enum class ImageDisplayMode
JavaScript
Interlink.ePad.ePadVision.ImageDisplayMode = function();
Interlink.ePad.ePadVision.ImageDisplayMode.createEnum('Interlink.ePad.ePadVision.ImageDisplayMode', false);

Members

Member name | Description
MOSAIC | Randomly mosaic
FROMTOP | Scan the image lines from top to bottom

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


InkRegion Structure

[image]

.NET Framework Class Library
InkRegion Structure
See Also Send Feedback

Define the signature area (Ink Region)

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure InkRegion
C#
public struct InkRegion
Visual C++
public value class InkRegion
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


InkRegion Fields

[image] [image]

.NET Framework Class Library
InkRegion Fields
InkRegion Structure See Also Send Feedback

The InkRegion type exposes the following members.

Fields

Name | Description
Enabled | The ink region enabled flag.
Height | The height of the signature sampling area in pixel.
InkTrailsTimeout | The timeout (in seconds) to auto clean up the signature trail. The zero value turns off the auto clean up feature.
Left | The x coordinate (in pixel) of the signature sampling area left top point.
PenColor | The pen color used to draw the signature trail
PenWidth | The pen width (in pixel) used to draw the signature trail.
ShowInkTrails | The ink trial On flag.
Top | The y coordinate (in pixel) of the signature sampling area left top point.
Transform | The flag to indicate whether to map the ink region to entire LCD area.
Width | The width of the signature sampling area in pixel.

See Also

InkRegion Structure


Enabled Field

[image]

.NET Framework Class Library
InkRegion..::.Enabled Field
InkRegion Structure See Also Send Feedback

The ink region enabled flag.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enabled As Boolean
C#
public bool Enabled
Visual C++
public:
bool Enabled
JavaScript
enabled

See Also

InkRegion Structure


Height Field

[image]

.NET Framework Class Library
InkRegion..::.Height Field
InkRegion Structure See Also Send Feedback

The height of the signature sampling area in pixel.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Height As Short
C#
public short Height
Visual C++
public:
short Height
JavaScript
height

See Also

InkRegion Structure


InkTrailsTimeout Field

[image]

.NET Framework Class Library
InkRegion..::.InkTrailsTimeout Field
InkRegion Structure See Also Send Feedback

The timeout (in seconds) to auto clean up the signature trail.

The zero value turns off the auto clean up feature.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public InkTrailsTimeout As Short
C#
public short InkTrailsTimeout
Visual C++
public:
short InkTrailsTimeout
JavaScript
inkTrailsTimeout

See Also

InkRegion Structure


Left Field

[image]

.NET Framework Class Library
InkRegion..::.Left Field
InkRegion Structure See Also Send Feedback

The x coordinate (in pixel) of the signature sampling area left top point.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Left As Short
C#
public short Left
Visual C++
public:
short Left
JavaScript
left

See Also

InkRegion Structure


PenColor Field

[image]

.NET Framework Class Library
InkRegion..::.PenColor Field
InkRegion Structure See Also Send Feedback

The pen color used to draw the signature trail

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public PenColor As LCDColor
C#
public LCDColor PenColor
Visual C++
public:
LCDColor PenColor
JavaScript
penColor

See Also

InkRegion Structure


PenWidth Field

[image]

.NET Framework Class Library
InkRegion..::.PenWidth Field
InkRegion Structure See Also Send Feedback

The pen width (in pixel) used to draw the signature trail.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public PenWidth As Short
C#
public short PenWidth
Visual C++
public:
short PenWidth
JavaScript
penWidth

See Also

InkRegion Structure


ShowInkTrails Field

[image]

.NET Framework Class Library
InkRegion..::.ShowInkTrails Field
InkRegion Structure See Also Send Feedback

The ink trial On flag.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ShowInkTrails As Boolean
C#
public bool ShowInkTrails
Visual C++
public:
bool ShowInkTrails
JavaScript
showInkTrails

See Also

InkRegion Structure


Top Field

[image]

.NET Framework Class Library
InkRegion..::.Top Field
InkRegion Structure See Also Send Feedback

The y coordinate (in pixel) of the signature sampling area left top point.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Top As Short
C#
public short Top
Visual C++
public:
short Top
JavaScript
top

See Also

InkRegion Structure


Transform Field

[image]

.NET Framework Class Library
InkRegion..::.Transform Field
InkRegion Structure See Also Send Feedback

The flag to indicate whether to map the ink region to entire LCD area.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Transform As Boolean
C#
public bool Transform
Visual C++
public:
bool Transform
JavaScript
transform

See Also

InkRegion Structure


Width Field

[image]

.NET Framework Class Library
InkRegion..::.Width Field
InkRegion Structure See Also Send Feedback

The width of the signature sampling area in pixel.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Width As Short
C#
public short Width
Visual C++
public:
short Width
JavaScript
width

See Also

InkRegion Structure


InkRegion Methods

[image] [image]

.NET Framework Class Library
InkRegion Methods
InkRegion Structure See Also Send Feedback

The InkRegion type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

InkRegion Structure


IPadVisionEvent Interface

[image]

.NET Framework Class Library
IPadVisionEvent Interface
See Also Send Feedback

The event interface to pass the data to client (application).

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("732CEF17-05C9-468b-A9D8-8C585E747330")> _
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIDispatch)> _
Public Interface IPadVisionEvent
C#
[GuidAttribute("732CEF17-05C9-468b-A9D8-8C585E747330")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsIDispatch)]
public interface IPadVisionEvent
Visual C++
[GuidAttribute(L"732CEF17-05C9-468b-A9D8-8C585E747330")]
[InterfaceTypeAttribute(ComInterfaceType::InterfaceIsIDispatch)]
public interface class IPadVisionEvent
JavaScript
Interlink.ePad.ePadVision.IPadVisionEvent = function();
Interlink.ePad.ePadVision.IPadVisionEvent.createInterface('Interlink.ePad.ePadVision.IPadVisionEvent');

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


IPadVisionEvent Methods

[image] [image]

.NET Framework Class Library
IPadVisionEvent Methods
IPadVisionEvent Interface See Also Send Feedback

The IPadVisionEvent type exposes the following members.

Methods

Name | Description
NotificationDataEvent | The protocol to pass the widget events to client.
SignatureDataEvent | The protocol to pass the signature points to client.
WgtEvent | The protocol to pass the widget events to client.

See Also

IPadVisionEvent Interface


NotificationDataEvent Method

[image]

.NET Framework Class Library
IPadVisionEvent..::.NotificationDataEvent Method
IPadVisionEvent Interface See Also Send Feedback

The protocol to pass the widget events to client.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub NotificationDataEvent ( _
    widgetID As Byte, _
    widgetType As EventType, _
    eventCode As EventCode, _
    data As Byte() _
)
C#
void NotificationDataEvent(
    byte widgetID,
    EventType widgetType,
    EventCode eventCode,
    byte[] data
)
Visual C++
void NotificationDataEvent(
    unsigned char widgetID,
    EventType widgetType,
    EventCode eventCode,
    array<unsigned char>^ data
)
JavaScript
function notificationDataEvent(widgetID, widgetType, eventCode, data);

Parameters

widgetID
Type: System..::.Byte
The incurred widget ID.
widgetType
Type: Interlink.ePad.ePadVision..::.EventType
The incurred widget type.
eventCode
Type: Interlink.ePad.ePadVision..::.EventCode
The event code identifying the event.
data
Type: array< System..::.Byte >[]()[]
The extra data for the event.

This field is not used right now and only for further. For example, if the keyboard widget is introduced, its inputted keystrokes will be saved here.

See Also

IPadVisionEvent Interface


SignatureDataEvent Method

[image]

.NET Framework Class Library
IPadVisionEvent..::.SignatureDataEvent Method
IPadVisionEvent Interface See Also Send Feedback

The protocol to pass the signature points to client.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub SignatureDataEvent ( _
    xAxis As Integer, _
    yAxis As Integer, _
    pressure As Integer, _
    timeStamp As Integer _
)
C#
void SignatureDataEvent(
    int xAxis,
    int yAxis,
    int pressure,
    int timeStamp
)
Visual C++
void SignatureDataEvent(
    int xAxis,
    int yAxis,
    int pressure,
    int timeStamp
)
JavaScript
function signatureDataEvent(xAxis, yAxis, pressure, timeStamp);

Parameters

xAxis
Type: System..::.Int32
The point x coordinate value.
yAxis
Type: System..::.Int32
The point y coordinate value.
pressure
Type: System..::.Int32
The point pressure value.
timeStamp
Type: System..::.Int32
The point sampling timestamp. It is device counter ticks.

See Also

IPadVisionEvent Interface


WgtEvent Method

[image]

.NET Framework Class Library
IPadVisionEvent..::.WgtEvent Method
IPadVisionEvent Interface See Also Send Feedback

The protocol to pass the widget events to client.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub WgtEvent ( _
    widgetID As Byte, _
    widgetType As EventType, _
    eventCode As EventCode _
)
C#
void WgtEvent(
    byte widgetID,
    EventType widgetType,
    EventCode eventCode
)
Visual C++
void WgtEvent(
    unsigned char widgetID,
    EventType widgetType,
    EventCode eventCode
)
JavaScript
function wgtEvent(widgetID, widgetType, eventCode);

Parameters

widgetID
Type: System..::.Byte
The incurred widget ID.
widgetType
Type: Interlink.ePad.ePadVision..::.EventType
The incurred widget type.
eventCode
Type: Interlink.ePad.ePadVision..::.EventCode
The event code identifying the event.

See Also

IPadVisionEvent Interface


IScreenSaver Interface

[image]

.NET Framework Class Library
IScreenSaver Interface
See Also Send Feedback

Define the screensaver operations

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("6991CE51-B9AF-4bba-B224-A4DB063336B5")> _
Public Interface IScreenSaver
C#
[GuidAttribute("6991CE51-B9AF-4bba-B224-A4DB063336B5")]
public interface IScreenSaver
Visual C++
[GuidAttribute(L"6991CE51-B9AF-4bba-B224-A4DB063336B5")]
public interface class IScreenSaver
JavaScript
Interlink.ePad.ePadVision.IScreenSaver = function();
Interlink.ePad.ePadVision.IScreenSaver.createInterface('Interlink.ePad.ePadVision.IScreenSaver');

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


IScreenSaver Methods

[image] [image]

.NET Framework Class Library
IScreenSaver Methods
IScreenSaver Interface See Also Send Feedback

The IScreenSaver type exposes the following members.

Methods

Name | Description
AddImage | Add an additional image
DeleteImage | Delete an image indexed by its position.
ImagePreview | Show the indexed image.
Reset | Remove all images and restore to default settings.
Resume | Resume the stopped screensaver
RetrieveSettings | Retrieve the images and other settings from the repository
Stop | Stop the screensaver if it is running.
StoreSettings | Save the screensaver settings

See Also

IScreenSaver Interface


AddImage Method

[image]

.NET Framework Class Library
IScreenSaver..::.AddImage Method
IScreenSaver Interface See Also Send Feedback

Add an additional image

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub AddImage ( _
    index As Integer, _
    imageData As Byte() _
)
C#
void AddImage(
    int index,
    byte[] imageData
)
Visual C++
void AddImage(
    int index,
    array<unsigned char>^ imageData
)
JavaScript
function addImage(index, imageData);

Parameters

index
Type: System..::.Int32
The image sequence position (0 basis)
imageData
Type: array< System..::.Byte >[]()[]
The image raw data

See Also

IScreenSaver Interface


DeleteImage Method

[image]

.NET Framework Class Library
IScreenSaver..::.DeleteImage Method
IScreenSaver Interface See Also Send Feedback

Delete an image indexed by its position.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub DeleteImage ( _
    index As Integer _
)
C#
void DeleteImage(
    int index
)
Visual C++
void DeleteImage(
    int index
)
JavaScript
function deleteImage(index);

Parameters

index
Type: System..::.Int32
The image position

See Also

IScreenSaver Interface


ImagePreview Method

[image]

.NET Framework Class Library
IScreenSaver..::.ImagePreview Method
IScreenSaver Interface See Also Send Feedback

Show the indexed image.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub ImagePreview ( _
    index As Integer _
)
C#
void ImagePreview(
    int index
)
Visual C++
void ImagePreview(
    int index
)
JavaScript
function imagePreview(index);

Parameters

index
Type: System..::.Int32

See Also

IScreenSaver Interface


Reset Method

[image]

.NET Framework Class Library
IScreenSaver..::.Reset Method
IScreenSaver Interface See Also Send Feedback

Remove all images and restore to default settings.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Reset
C#
void Reset()
Visual C++
void Reset()
JavaScript
function reset();

See Also

IScreenSaver Interface


Resume Method

[image]

.NET Framework Class Library
IScreenSaver..::.Resume Method
IScreenSaver Interface See Also Send Feedback

Resume the stopped screensaver

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Resume
C#
void Resume()
Visual C++
void Resume()
JavaScript
function resume();

See Also

IScreenSaver Interface


RetrieveSettings Method

[image]

.NET Framework Class Library
IScreenSaver..::.RetrieveSettings Method
IScreenSaver Interface See Also Send Feedback

Retrieve the images and other settings from the repository

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub RetrieveSettings ( _
    location As Repository _
)
C#
void RetrieveSettings(
    Repository location
)
Visual C++
void RetrieveSettings(
    Repository location
)
JavaScript
function retrieveSettings(location);

Parameters

location
Type: Interlink.ePad.ePadVision..::.Repository

Remarks

This one will not be implemented in FCS

See Also

IScreenSaver Interface


Stop Method

[image]

.NET Framework Class Library
IScreenSaver..::.Stop Method
IScreenSaver Interface See Also Send Feedback

Stop the screensaver if it is running.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Stop
C#
void Stop()
Visual C++
void Stop()
JavaScript
function stop();

See Also

IScreenSaver Interface


StoreSettings Method

[image]

.NET Framework Class Library
IScreenSaver..::.StoreSettings Method
IScreenSaver Interface See Also Send Feedback

Save the screensaver settings

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub StoreSettings ( _
    location As Repository _
)
C#
void StoreSettings(
    Repository location
)
Visual C++
void StoreSettings(
    Repository location
)
JavaScript
function storeSettings(location);

Parameters

location
Type: Interlink.ePad.ePadVision..::.Repository
The repository where to save the settings

See Also

IScreenSaver Interface


IScreenSaver Properties

[image] [image]

.NET Framework Class Library
IScreenSaver Properties
IScreenSaver Interface See Also Send Feedback

The IScreenSaver type exposes the following members.

Properties

Name Description
DefaultRepository
The repository where the default screensaver settings are stored

Remarks

This one will not be implemented in FCS
DisplayMode
Define how to display the images.

The supported mode will be defined later.

Enabled
Whether the screen saver is enabled
EnableStandAlone
To run the screensaver when the device is idle (no connection).
ImageCount
How many images added.
Interval
The interval (in 10 ms) for the image to stay.
IsRunning
Whether the screensaver is running right now.
TimeOut
The timeout value in 10 ms to launch screensaver.

See Also

IScreenSaver Interface


DefaultRepository Property

[image]

.NET Framework Class Library
IScreenSaver..::.DefaultRepository Property
IScreenSaver Interface See Also Send Feedback

The repository where the default screensaver settings are stored

Remarks

This one will not be implemented in FCS

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property DefaultRepository As Repository
C#
Repository DefaultRepository { get; set; }
Visual C++
property Repository DefaultRepository {
    Repository get ();
    void set (Repository value);
}
JavaScript
function get_defaultRepository();
function set_defaultRepository(value);

See Also

IScreenSaver Interface


DisplayMode Property

[image]

.NET Framework Class Library
IScreenSaver..::.DisplayMode Property
IScreenSaver Interface See Also Send Feedback

Define how to display the images.

The supported mode will be defined later.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property DisplayMode As ImageDisplayMode
C#
ImageDisplayMode DisplayMode { get; set; }
Visual C++
property ImageDisplayMode DisplayMode {
    ImageDisplayMode get ();
    void set (ImageDisplayMode value);
}
JavaScript
function get_displayMode();
function set_displayMode(value);

See Also

IScreenSaver Interface


Enabled Property

[image]

.NET Framework Class Library
IScreenSaver..::.Enabled Property
IScreenSaver Interface See Also Send Feedback

Whether the screen saver is enabled

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property Enabled As Boolean
C#
bool Enabled { get; set; }
Visual C++
property bool Enabled {
    bool get ();
    void set (bool value);
}
JavaScript
function get_enabled();
function set_enabled(value);

See Also

IScreenSaver Interface


EnableStandAlone Property

[image]

.NET Framework Class Library
IScreenSaver..::.EnableStandAlone Property
IScreenSaver Interface See Also Send Feedback

To run the screensaver when the device is idle (no connection).

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property EnableStandAlone As Boolean
C#
bool EnableStandAlone { get; set; }
Visual C++
property bool EnableStandAlone {
    bool get ();
    void set (bool value);
}
JavaScript
function get_enableStandAlone();
function set_enableStandAlone(value);

See Also

IScreenSaver Interface


ImageCount Property

[image]

.NET Framework Class Library
IScreenSaver..::.ImageCount Property
IScreenSaver Interface See Also Send Feedback

How many images added.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ImageCount As Integer
C#
int ImageCount { get; }
Visual C++
property int ImageCount {
    int get ();
}
JavaScript
function get_imageCount();

See Also

IScreenSaver Interface


Interval Property

[image]

.NET Framework Class Library
IScreenSaver..::.Interval Property
IScreenSaver Interface See Also Send Feedback

The interval (in 10 ms) for the image to stay.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property Interval As Short
C#
short Interval { get; set; }
Visual C++
property short Interval {
    short get ();
    void set (short value);
}
JavaScript
function get_interval();
function set_interval(value);

See Also

IScreenSaver Interface


IsRunning Property

[image]

.NET Framework Class Library
IScreenSaver..::.IsRunning Property
IScreenSaver Interface See Also Send Feedback

Whether the screensaver is running right now.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsRunning As Boolean
C#
bool IsRunning { get; }
Visual C++
property bool IsRunning {
    bool get ();
}
JavaScript
function get_isRunning();

See Also

IScreenSaver Interface


TimeOut Property

[image]

.NET Framework Class Library
IScreenSaver..::.TimeOut Property
IScreenSaver Interface See Also Send Feedback

The timeout value in 10 ms to launch screensaver.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property TimeOut As Integer
C#
int TimeOut { get; set; }
Visual C++
property int TimeOut {
    int get ();
    void set (int value);
}
JavaScript
function get_timeOut();
function set_timeOut(value);

See Also

IScreenSaver Interface


ISIFont Interface

[image]

.NET Framework Class Library
ISIFont Interface
See Also Send Feedback

Define Downloadable SIF font operations

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("062C2ED8-59BD-4c66-8C47-6E508CCDCB2E")> _
Public Interface ISIFont
C#
[GuidAttribute("062C2ED8-59BD-4c66-8C47-6E508CCDCB2E")]
public interface ISIFont
Visual C++
[GuidAttribute(L"062C2ED8-59BD-4c66-8C47-6E508CCDCB2E")]
public interface class ISIFont
JavaScript
Interlink.ePad.ePadVision.ISIFont = function();
Interlink.ePad.ePadVision.ISIFont.createInterface('Interlink.ePad.ePadVision.ISIFont');

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


ISIFont Methods

[image] [image]

.NET Framework Class Library
ISIFont Methods
ISIFont Interface See Also Send Feedback

The ISIFont type exposes the following members.

Methods

Name | Description
CreateSIF | Create a new Font from existing SIF font file in the flash and associated the new Font with fontId
DeleteSIF | Delete SIF font file to external device
DownloadSIF | Download SIF font file to external device with optional fontId

See Also

ISIFont Interface


CreateSIF Method

[image]

.NET Framework Class Library
ISIFont..::.CreateSIF Method
ISIFont Interface See Also Send Feedback

Create a new Font from existing SIF font file in the flash and associated the new Font with fontId

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Function CreateSIF ( _
    SIFfile As String, _
    fontId As Byte, _
    source As Byte _
) As Boolean
C#
bool CreateSIF(
    string SIFfile,
    byte fontId,
    byte source
)
Visual C++
bool CreateSIF(
    String^ SIFfile,
    unsigned char fontId,
    unsigned char source
)
JavaScript
function createSIF(SIFfile, fontId, source);

Parameters

SIFfile
Type: System..::.String
SIF font file name
fontId
Type: System..::.Byte
font id within DOWNLOAD_200 and DOWNLOAD_224
source
Type: System..::.Byte
Flash or RAM.

See Also

ISIFont Interface


DeleteSIF Method

[image]

.NET Framework Class Library
ISIFont..::.DeleteSIF Method
ISIFont Interface See Also Send Feedback

Delete SIF font file to external device

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Function DeleteSIF ( _
    SIFfile As String, _
    source As Byte _
) As Boolean
C#
bool DeleteSIF(
    string SIFfile,
    byte source
)
Visual C++
bool DeleteSIF(
    String^ SIFfile,
    unsigned char source
)
JavaScript
function deleteSIF(SIFfile, source);

Parameters

SIFfile
Type: System..::.String
SIF font file name
source
Type: System..::.Byte
Flash or RAM.

See Also

ISIFont Interface


DownloadSIF Method

[image]

.NET Framework Class Library
ISIFont..::.DownloadSIF Method
ISIFont Interface See Also Send Feedback

Download SIF font file to external device with optional fontId

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub DownloadSIF ( _
    SIFfile As String, _
    fontId As Byte, _
    destination As Byte _
)
C#
void DownloadSIF(
    string SIFfile,
    byte fontId,
    byte destination
)
Visual C++
void DownloadSIF(
    String^ SIFfile,
    unsigned char fontId,
    unsigned char destination
)
JavaScript
function downloadSIF(SIFfile, fontId, destination);

Parameters

SIFfile
Type: System..::.String
SIF font file name
fontId
Type: System..::.Byte
font id within DOWNLOAD_200 and DOWNLOAD_224
destination
Type: System..::.Byte
Flash or RAM.

See Also

ISIFont Interface


ISIFont Properties

[image] [image]

.NET Framework Class Library
ISIFont Properties
ISIFont Interface See Also Send Feedback

The ISIFont type exposes the following members.

Properties

Name | Description
GetFontListFromFlash | Get list of FontEntry from Flash external memory device
GetFontListFromRAM | Get list of FontEntry from RAM external memory device

See Also

ISIFont Interface


GetFontListFromFlash Property

[image]

.NET Framework Class Library
ISIFont..::.GetFontListFromFlash Property
ISIFont Interface See Also Send Feedback

Get list of FontEntry from Flash external memory device

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property GetFontListFromFlash As FontList
C#
FontList GetFontListFromFlash { get; }
Visual C++
property FontList^ GetFontListFromFlash {
    FontList^ get ();
}
JavaScript
function get_getFontListFromFlash();

See Also

ISIFont Interface


GetFontListFromRAM Property

[image]

.NET Framework Class Library
ISIFont..::.GetFontListFromRAM Property
ISIFont Interface See Also Send Feedback

Get list of FontEntry from RAM external memory device

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property GetFontListFromRAM As FontList
C#
FontList GetFontListFromRAM { get; }
Visual C++
property FontList^ GetFontListFromRAM {
    FontList^ get ();
}
JavaScript
function get_getFontListFromRAM();

See Also

ISIFont Interface


ISignaturePad Interface

[image]

.NET Framework Class Library
ISignaturePad Interface
See Also Send Feedback

Defines the signature pad characteristics.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("BBD3527E-F161-45cc-B499-C7C6AB791AC5")> _
Public Interface ISignaturePad
C#
[GuidAttribute("BBD3527E-F161-45cc-B499-C7C6AB791AC5")]
public interface ISignaturePad
Visual C++
[GuidAttribute(L"BBD3527E-F161-45cc-B499-C7C6AB791AC5")]
public interface class ISignaturePad
JavaScript
Interlink.ePad.ePadVision.ISignaturePad = function();
Interlink.ePad.ePadVision.ISignaturePad.createInterface('Interlink.ePad.ePadVision.ISignaturePad');

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


ISignaturePad Methods

[image] [image]

.NET Framework Class Library
ISignaturePad Methods
ISignaturePad Interface See Also Send Feedback

The ISignaturePad type exposes the following members.

Methods

Name | Description
CancelCalibration | Cancel the calibration if applicable
DoCalibration | Do the calibration and save the settings if successfully.
DrawImage | Draw the image at the range specified by parameter range.
Refresh | Refresh the LCD.
SetBackgroundImage | Set the background image
SetCustomizedBackgroundImage | Set the customized background image
SetInkRegion | The alternative to InkRegion (set).

See Also

ISignaturePad Interface


CancelCalibration Method

[image]

.NET Framework Class Library
ISignaturePad..::.CancelCalibration Method
ISignaturePad Interface See Also Send Feedback

Cancel the calibration if applicable

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub CancelCalibration
C#
void CancelCalibration()
Visual C++
void CancelCalibration()
JavaScript
function cancelCalibration();

Remarks

The events will be sent out to indicate whether the calibration is canceled or there is no calibration currently.

See Also

ISignaturePad Interface


DoCalibration Method

[image]

.NET Framework Class Library
ISignaturePad..::.DoCalibration Method
ISignaturePad Interface See Also Send Feedback

Do the calibration and save the settings if successfully.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub DoCalibration
C#
void DoCalibration()
Visual C++
void DoCalibration()
JavaScript
function doCalibration();

Remarks

During the calibration, the events will be sent out via the delegation WidgetDataEvent to inform the processing status.

The event code will be defined later.

If the calibration is successful, the new settings is automatically saved into the NV.

If the calibration is failed, the previous settings should be kept.

See Also

ISignaturePad Interface


DrawImage Method

[image]

.NET Framework Class Library
ISignaturePad..::.DrawImage Method
ISignaturePad Interface See Also Send Feedback

Draw the image at the range specified by parameter range.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub DrawImage ( _
    range As LCDPixelRange, _
    imageData As Byte() _
)
C#
void DrawImage(
    LCDPixelRange range,
    byte[] imageData
)
Visual C++
void DrawImage(
    LCDPixelRange range,
    array<unsigned char>^ imageData
)
JavaScript
function drawImage(range, imageData);

Parameters

range
Type: Interlink.ePad.ePadVision..::.LCDPixelRange
The LCD range.
imageData
Type: array< System..::.Byte >[]()[]
The image formatted data (for example JPG format).

Remarks

How to pass the image content? Via filename, byte array, I/O stream?

See Also

ISignaturePad Interface


Refresh Method

[image]

.NET Framework Class Library
ISignaturePad..::.Refresh Method
ISignaturePad Interface See Also Send Feedback

Refresh the LCD.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub Refresh
C#
void Refresh()
Visual C++
void Refresh()
JavaScript
function refresh();

See Also

ISignaturePad Interface


SetBackgroundImage Method

[image]

.NET Framework Class Library
ISignaturePad..::.SetBackgroundImage Method
ISignaturePad Interface See Also Send Feedback

Set the background image

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub SetBackgroundImage ( _
    range As LCDPixelRange, _
    imageData As Byte() _
)
C#
void SetBackgroundImage(
    LCDPixelRange range,
    byte[] imageData
)
Visual C++
void SetBackgroundImage(
    LCDPixelRange range,
    array<unsigned char>^ imageData
)
JavaScript
function setBackgroundImage(range, imageData);

Parameters

range
Type: Interlink.ePad.ePadVision..::.LCDPixelRange
The LCD range.
imageData
Type: array< System..::.Byte >[]()[]
The image formatted data (for example JPG format).

See Also

ISignaturePad Interface


SetCustomizedBackgroundImage Method

[image]

.NET Framework Class Library
ISignaturePad..::.SetCustomizedBackgroundImage Method
ISignaturePad Interface See Also Send Feedback

Set the customized background image

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub SetCustomizedBackgroundImage ( _
    imageID As Guid, _
    range As LCDPixelRange, _
    imageData As Byte() _
)
C#
void SetCustomizedBackgroundImage(
    Guid imageID,
    LCDPixelRange range,
    byte[] imageData
)
Visual C++
void SetCustomizedBackgroundImage(
    Guid imageID,
    LCDPixelRange range,
    array<unsigned char>^ imageData
)
JavaScript
function setCustomizedBackgroundImage(imageID, range, imageData);

Parameters

imageID
Type: System..::.Guid
The customized background image ID
range
Type: Interlink.ePad.ePadVision..::.LCDPixelRange
The LCD range.
imageData
Type: array< System..::.Byte >[]()[]
The image formatted data (for example JPG format).

See Also

ISignaturePad Interface


SetInkRegion Method

[image]

.NET Framework Class Library
ISignaturePad..::.SetInkRegion Method
ISignaturePad Interface See Also Send Feedback

The alternative to InkRegion (set).

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub SetInkRegion ( _
    ByRef ink As InkRegion _
)
C#
void SetInkRegion(
    ref InkRegion ink
)
Visual C++
void SetInkRegion(
    InkRegion% ink
)
JavaScript
function setInkRegion(ink);

Parameters

ink
Type: Interlink.ePad.ePadVision..::.InkRegion %

See Also

ISignaturePad Interface


ISignaturePad Properties

[image] [image]

.NET Framework Class Library
ISignaturePad Properties
ISignaturePad Interface See Also Send Feedback

The ISignaturePad type exposes the following members.

Properties

Name | Description
BackgroundColor | The LCD background color
BacklightLevel | The backlight bright percentage (0--100).
CustomizedBackgroundImageID | Give the stored customized background ID
EnableBackgroundImage | Enable to show the background image
EnableCustomizedBackgroundImage | Enable or disable the customized background image.
InkRegion | the ink region setting
LCDPixels | The LCD pixel number in x/y axis.
PadInfo | The pad physical info.
RptRate | the signature point report rate indicator
WatermarkColor | The watermark color

See Also

ISignaturePad Interface


BackgroundColor Property

[image]

.NET Framework Class Library
ISignaturePad..::.BackgroundColor Property
ISignaturePad Interface See Also Send Feedback

The LCD background color

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property BackgroundColor As LCDColor
C#
LCDColor BackgroundColor { get; set; }
Visual C++
property LCDColor BackgroundColor {
    LCDColor get ();
    void set (LCDColor value);
}
JavaScript
function get_backgroundColor();
function set_backgroundColor(value);

See Also

ISignaturePad Interface


BacklightLevel Property

[image]

.NET Framework Class Library
ISignaturePad..::.BacklightLevel Property
ISignaturePad Interface See Also Send Feedback

The backlight bright percentage (0--100).

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property BacklightLevel As Byte
C#
byte BacklightLevel { get; set; }
Visual C++
property unsigned char BacklightLevel {
    unsigned char get ();
    void set (unsigned char value);
}
JavaScript
function get_backlightLevel();
function set_backlightLevel(value);

See Also

ISignaturePad Interface


CustomizedBackgroundImageID Property

[image]

.NET Framework Class Library
ISignaturePad..::.CustomizedBackgroundImageID Property
ISignaturePad Interface See Also Send Feedback

Give the stored customized background ID

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CustomizedBackgroundImageID As Guid
C#
Guid CustomizedBackgroundImageID { get; }
Visual C++
property Guid CustomizedBackgroundImageID {
    Guid get ();
}
JavaScript
function get_customizedBackgroundImageID();

See Also

ISignaturePad Interface


EnableBackgroundImage Property

[image]

.NET Framework Class Library
ISignaturePad..::.EnableBackgroundImage Property
ISignaturePad Interface See Also Send Feedback

Enable to show the background image

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property EnableBackgroundImage As Boolean
C#
bool EnableBackgroundImage { get; set; }
Visual C++
property bool EnableBackgroundImage {
    bool get ();
    void set (bool value);
}
JavaScript
function get_enableBackgroundImage();
function set_enableBackgroundImage(value);

See Also

ISignaturePad Interface


EnableCustomizedBackgroundImage Property

[image]

.NET Framework Class Library
ISignaturePad..::.EnableCustomizedBackgroundImage Property
ISignaturePad Interface See Also Send Feedback

Enable or disable the customized background image.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property EnableCustomizedBackgroundImage As Boolean
C#
bool EnableCustomizedBackgroundImage { get; set; }
Visual C++
property bool EnableCustomizedBackgroundImage {
    bool get ();
    void set (bool value);
}
JavaScript
function get_enableCustomizedBackgroundImage();
function set_enableCustomizedBackgroundImage(value);

See Also

ISignaturePad Interface


InkRegion Property

[image]

.NET Framework Class Library
ISignaturePad..::.InkRegion Property
ISignaturePad Interface See Also Send Feedback

the ink region setting

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property InkRegion As InkRegion
C#
InkRegion InkRegion { get; set; }
Visual C++
property InkRegion InkRegion {
    InkRegion get ();
    void set (InkRegion value);
}
JavaScript
function get_inkRegion();
function set_inkRegion(value);

See Also

ISignaturePad Interface


LCDPixels Property

[image]

.NET Framework Class Library
ISignaturePad..::.LCDPixels Property
ISignaturePad Interface See Also Send Feedback

The LCD pixel number in x/y axis.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LCDPixels As LCDPixels
C#
LCDPixels LCDPixels { get; }
Visual C++
property LCDPixels LCDPixels {
    LCDPixels get ();
}
JavaScript
function get_lcdPixels();

See Also

ISignaturePad Interface


PadInfo Property

[image]

.NET Framework Class Library
ISignaturePad..::.PadInfo Property
ISignaturePad Interface See Also Send Feedback

The pad physical info.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PadInfo As DevicePadInfo
C#
DevicePadInfo PadInfo { get; }
Visual C++
property DevicePadInfo PadInfo {
    DevicePadInfo get ();
}
JavaScript
function get_padInfo();

See Also

ISignaturePad Interface


RptRate Property

[image]

.NET Framework Class Library
ISignaturePad..::.RptRate Property
ISignaturePad Interface See Also Send Feedback

the signature point report rate indicator

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property RptRate As ReportRateIndicator
C#
ReportRateIndicator RptRate { get; set; }
Visual C++
property ReportRateIndicator RptRate {
    ReportRateIndicator get ();
    void set (ReportRateIndicator value);
}
JavaScript
function get_rptRate();
function set_rptRate(value);

See Also

ISignaturePad Interface


WatermarkColor Property

[image]

.NET Framework Class Library
ISignaturePad..::.WatermarkColor Property
ISignaturePad Interface See Also Send Feedback

The watermark color

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Property WatermarkColor As LCDColor
C#
LCDColor WatermarkColor { get; set; }
Visual C++
property LCDColor WatermarkColor {
    LCDColor get ();
    void set (LCDColor value);
}
JavaScript
function get_watermarkColor();
function set_watermarkColor(value);

See Also

ISignaturePad Interface


IWidgets Interface

[image]

.NET Framework Class Library
IWidgets Interface
See Also Send Feedback

Define widget management operations

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("F551E8B4-071C-481a-827D-4740E8D21D77")> _
Public Interface IWidgets
C#
[GuidAttribute("F551E8B4-071C-481a-827D-4740E8D21D77")]
public interface IWidgets
Visual C++
[GuidAttribute(L"F551E8B4-071C-481a-827D-4740E8D21D77")]
public interface class IWidgets
JavaScript
Interlink.ePad.ePadVision.IWidgets = function();
Interlink.ePad.ePadVision.IWidgets.createInterface('Interlink.ePad.ePadVision.IWidgets');

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


IWidgets Methods

[image] [image]

.NET Framework Class Library
IWidgets Methods
IWidgets Interface See Also Send Feedback

The IWidgets type exposes the following members.

Methods

Name | Description
CreateWidget | Create a widget
DeleteWidget | Delete a widget identified by its ID.
DisplayPinPad | Display the Pin Pad widget
DisplayPinPadEx | Display the Pin Pad widget
EnableWidget | Enable or disable a widget.
LoadWidgetLayout | Layout the desktop with ink region, watermark (image), buttons (widgets)...
MoveWidget | Move the widget to the specified location.
RemoveAllWidgets | Remove all widgets from desktop permanently.
SetWidgetChecked | Set the widget to checked or unchecked. It is designed for check box or radio button. And it has no effective for other widgets.
SetWidgetText | Set the text to the widget. It is used to set the content to Text widget, the caption to button...
ShowWidget | Show or hide a widget
UniCreateWidget | Create a widget with Unicode text string embedded in the WidgetInfo structure
UniSetWidgetText | Set the text in the widget as Unicode string

See Also

IWidgets Interface


CreateWidget Method

[image]

.NET Framework Class Library
IWidgets..::.CreateWidget Method
IWidgets Interface See Also Send Feedback

Create a widget

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub CreateWidget ( _
    wInfo As WidgetInfo _
)
C#
void CreateWidget(
    WidgetInfo wInfo
)
Visual C++
void CreateWidget(
    WidgetInfo wInfo
)
JavaScript
function createWidget(wInfo);

Parameters

wInfo
Type: Interlink.ePad.ePadVision..::.WidgetInfo
The widget info

Remarks

The device will send out event to inform the creating status.

See Also

IWidgets Interface


DeleteWidget Method

[image]

.NET Framework Class Library
IWidgets..::.DeleteWidget Method
IWidgets Interface See Also Send Feedback

Delete a widget identified by its ID.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub DeleteWidget ( _
    widgetID As Byte _
)
C#
void DeleteWidget(
    byte widgetID
)
Visual C++
void DeleteWidget(
    unsigned char widgetID
)
JavaScript
function deleteWidget(widgetID);

Parameters

widgetID
Type: System..::.Byte
The ID of the widget to be deleted.

Remarks

The device will send out event to inform deleting status.

See Also

IWidgets Interface


DisplayPinPad Method

[image]

.NET Framework Class Library
IWidgets..::.DisplayPinPad Method
IWidgets Interface See Also Send Feedback

Display the Pin Pad widget

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub DisplayPinPad ( _
    XMLData As String, _
    timeOut As Integer, _
    <OutAttribute> ByRef output As String _
)
C#
void DisplayPinPad(
    string XMLData,
    int timeOut,
    out string output
)
Visual C++
void DisplayPinPad(
    String^ XMLData,
    int timeOut,
    [OutAttribute] String^% output
)
JavaScript
function displayPinPad(XMLData, timeOut, output);

Parameters

XMLData
Type: System..::.String
The XML document describing the Pin Pad layout
timeOut
Type: System..::.Int32
The pinpad widget timeout in seconds
output
Type: System..::.String %
The user inputted string

Remarks

Please refer to the WPinPad.xml file at the ePad\Images\ePad-vision\XML for detail description of PinPad layout.

See Also

IWidgets Interface


DisplayPinPadEx Method

[image]

.NET Framework Class Library
IWidgets..::.DisplayPinPadEx Method
IWidgets Interface See Also Send Feedback

Display the Pin Pad widget

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub DisplayPinPadEx ( _
    XMLData As String, _
    timeOut As Integer, _
    <OutAttribute> ByRef output As String, _
    <OutAttribute> ByRef result As Integer _
)
C#
void DisplayPinPadEx(
    string XMLData,
    int timeOut,
    out string output,
    out int result
)
Visual C++
void DisplayPinPadEx(
    String^ XMLData,
    int timeOut,
    [OutAttribute] String^% output,
    [OutAttribute] int% result
)
JavaScript
function displayPinPadEx(XMLData, timeOut, output, result);

Parameters

XMLData
Type: System..::.String
The XML document describing the Pin Pad layout
timeOut
Type: System..::.Int32
The pinpad widget timeout in seconds
output
Type: System..::.String %
The user inputted string
result
Type: System..::.Int32 %
The PinPad function result, 1 for success

Remarks

Please refer to the WPinPad.xml file at the ePad\Images\ePad-vision\XML for detail description of PinPad layout. This method will not throw F_TIMEOUT exception

See Also

IWidgets Interface


EnableWidget Method

[image]

.NET Framework Class Library
IWidgets..::.EnableWidget Method
IWidgets Interface See Also Send Feedback

Enable or disable a widget.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub EnableWidget ( _
    widgetID As Byte, _
    bEnable As Boolean _
)
C#
void EnableWidget(
    byte widgetID,
    bool bEnable
)
Visual C++
void EnableWidget(
    unsigned char widgetID,
    bool bEnable
)
JavaScript
function enableWidget(widgetID, bEnable);

Parameters

widgetID
Type: System..::.Byte
The ID of the target widget.
bEnable
Type: System..::.Boolean
The flag whether to enable (when it is "true") or disable (when it is "false") the target widget.

Remarks

The device will send out event to inform the operation status.

See Also

IWidgets Interface


LoadWidgetLayout Method

[image]

.NET Framework Class Library
IWidgets..::.LoadWidgetLayout Method
IWidgets Interface See Also Send Feedback

Layout the desktop with ink region, watermark (image), buttons (widgets)...

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub LoadWidgetLayout ( _
    XMLDocument As String _
)
C#
void LoadWidgetLayout(
    string XMLDocument
)
Visual C++
void LoadWidgetLayout(
    String^ XMLDocument
)
JavaScript
function loadWidgetLayout(XMLDocument);

Parameters

XMLDocument
Type: System..::.String
The XML document defining the desktop layout.

Remarks

The schema of XML document will be defined later.

See Also

IWidgets Interface


MoveWidget Method

[image]

.NET Framework Class Library
IWidgets..::.MoveWidget Method
IWidgets Interface See Also Send Feedback

Move the widget to the specified location.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub MoveWidget ( _
    widgetID As Byte, _
    xPos As Short, _
    yPos As Short _
)
C#
void MoveWidget(
    byte widgetID,
    short xPos,
    short yPos
)
Visual C++
void MoveWidget(
    unsigned char widgetID,
    short xPos,
    short yPos
)
JavaScript
function moveWidget(widgetID, xPos, yPos);

Parameters

widgetID
Type: System..::.Byte
The desired widget ID.
xPos
Type: System..::.Int16
The x axis value of the top left point of the destination.
yPos
Type: System..::.Int16
The y axis value of the top left point of the destination.

See Also

IWidgets Interface


RemoveAllWidgets Method

[image]

.NET Framework Class Library
IWidgets..::.RemoveAllWidgets Method
IWidgets Interface See Also Send Feedback

Remove all widgets from desktop permanently.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub RemoveAllWidgets
C#
void RemoveAllWidgets()
Visual C++
void RemoveAllWidgets()
JavaScript
function removeAllWidgets();

Remarks

The device will send out events to inform the deleting status.

See Also

IWidgets Interface


SetWidgetChecked Method

[image]

.NET Framework Class Library
IWidgets..::.SetWidgetChecked Method
IWidgets Interface See Also Send Feedback

Set the widget to checked or unchecked.

It is designed for check box or radio button. And it has no effective for other widgets.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub SetWidgetChecked ( _
    widgetID As Byte, _
    check As Boolean _
)
C#
void SetWidgetChecked(
    byte widgetID,
    bool check
)
Visual C++
void SetWidgetChecked(
    unsigned char widgetID,
    bool check
)
JavaScript
function setWidgetChecked(widgetID, check);

Parameters

widgetID
Type: System..::.Byte
The desired widget ID.
check
Type: System..::.Boolean
The desired checked/unchecked flag.

See Also

IWidgets Interface


SetWidgetText Method

[image]

.NET Framework Class Library
IWidgets..::.SetWidgetText Method
IWidgets Interface See Also Send Feedback

Set the text to the widget. It is used to set the content to Text widget, the caption to button...

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub SetWidgetText ( _
    widgetID As Byte, _
    text As String _
)
C#
void SetWidgetText(
    byte widgetID,
    string text
)
Visual C++
void SetWidgetText(
    unsigned char widgetID,
    String^ text
)
JavaScript
function setWidgetText(widgetID, text);

Parameters

widgetID
Type: System..::.Byte
The ID of the destination widget.
text
Type: System..::.String
The text to be send to the widget.

Remarks

The device will send out event to inform the setting text status.

Remarks

The maximum text length is 960 bytes.

See Also

IWidgets Interface


ShowWidget Method

[image]

.NET Framework Class Library
IWidgets..::.ShowWidget Method
IWidgets Interface See Also Send Feedback

Show or hide a widget

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub ShowWidget ( _
    widgetID As Byte, _
    bShow As Boolean _
)
C#
void ShowWidget(
    byte widgetID,
    bool bShow
)
Visual C++
void ShowWidget(
    unsigned char widgetID,
    bool bShow
)
JavaScript
function showWidget(widgetID, bShow);

Parameters

widgetID
Type: System..::.Byte
The ID of the target widget.
bShow
Type: System..::.Boolean
The flag whether to show (when it is "true") or hide (when it is "false") the target widget.

Remarks

The device will send out event to inform the operation status.

See Also

IWidgets Interface


UniCreateWidget Method

[image]

.NET Framework Class Library
IWidgets..::.UniCreateWidget Method
IWidgets Interface See Also Send Feedback

Create a widget with Unicode text string embedded in the WidgetInfo structure

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub UniCreateWidget ( _
    info As WidgetInfo _
)
C#
void UniCreateWidget(
    WidgetInfo info
)
Visual C++
void UniCreateWidget(
    WidgetInfo info
)
JavaScript
function uniCreateWidget(info);

Parameters

info
Type: Interlink.ePad.ePadVision..::.WidgetInfo
WigetInfo structure defines widget id, widget type, font id etc. required fields to create a widget. The text field will be treated as Unicode string.

See Also

IWidgets Interface


UniSetWidgetText Method

[image]

.NET Framework Class Library
IWidgets..::.UniSetWidgetText Method
IWidgets Interface See Also Send Feedback

Set the text in the widget as Unicode string

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Sub UniSetWidgetText ( _
    widgetID As Byte, _
    text As String _
)
C#
void UniSetWidgetText(
    byte widgetID,
    string text
)
Visual C++
void UniSetWidgetText(
    unsigned char widgetID,
    String^ text
)
JavaScript
function uniSetWidgetText(widgetID, text);

Parameters

widgetID
Type: System..::.Byte
The ID of the destination widget.
text
Type: System..::.String
The text to be send to the widget.

Remarks

The device will send out event to inform the setting text status.

Remarks

The maximum text length is 960 bytes.

See Also

IWidgets Interface


LCDColor Structure

[image]

.NET Framework Class Library
LCDColor Structure
See Also Send Feedback

Define the LCD pixel color in Red, Green, Blue, and Alpha Blend

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure LCDColor
C#
public struct LCDColor
Visual C++
public value class LCDColor
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


LCDColor Fields

[image] [image]

.NET Framework Class Library
LCDColor Fields
LCDColor Structure See Also Send Feedback

The LCDColor type exposes the following members.

Fields

Name | Description
Alpha | The alpha blend value.
Blue | The blue element.
DarkGreen | The predefined color More colors will be defined.
Green | The green element.
Red | The red element.

See Also

LCDColor Structure


Alpha Field

[image]

.NET Framework Class Library
LCDColor..::.Alpha Field
LCDColor Structure See Also Send Feedback

The alpha blend value.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Alpha As Byte
C#
public byte Alpha
Visual C++
public:
unsigned char Alpha
JavaScript
alpha

See Also

LCDColor Structure


Blue Field

[image]

.NET Framework Class Library
LCDColor..::.Blue Field
LCDColor Structure See Also Send Feedback

The blue element.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Blue As Byte
C#
public byte Blue
Visual C++
public:
unsigned char Blue
JavaScript
blue

See Also

LCDColor Structure


DarkGreen Field

[image]

.NET Framework Class Library
LCDColor..::.DarkGreen Field
LCDColor Structure See Also Send Feedback

The predefined color

More colors will be defined.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DarkGreen As LCDColor
C#
public static readonly LCDColor DarkGreen
Visual C++
public:
static initonly LCDColor DarkGreen
JavaScript
Interlink.ePad.ePadVision.LCDColor.darkGreen

See Also

LCDColor Structure


Green Field

[image]

.NET Framework Class Library
LCDColor..::.Green Field
LCDColor Structure See Also Send Feedback

The green element.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Green As Byte
C#
public byte Green
Visual C++
public:
unsigned char Green
JavaScript
green

See Also

LCDColor Structure


Red Field

[image]

.NET Framework Class Library
LCDColor..::.Red Field
LCDColor Structure See Also Send Feedback

The red element.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Red As Byte
C#
public byte Red
Visual C++
public:
unsigned char Red
JavaScript
red

See Also

LCDColor Structure


LCDColor Methods

[image] [image]

.NET Framework Class Library
LCDColor Methods
LCDColor Structure See Also Send Feedback

The LCDColor type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

LCDColor Structure


LCDExtents Structure

[image]

.NET Framework Class Library
LCDExtents Structure
See Also Send Feedback

Define the LCD physical extents in inches.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure LCDExtents
C#
public struct LCDExtents
Visual C++
public value class LCDExtents
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


LCDExtents Fields

[image] [image]

.NET Framework Class Library
LCDExtents Fields
LCDExtents Structure See Also Send Feedback

The LCDExtents type exposes the following members.

Fields

Name | Description
Height | The LCD height in inch.
Width | The LCD width in inch.

See Also

LCDExtents Structure


Height Field

[image]

.NET Framework Class Library
LCDExtents..::.Height Field
LCDExtents Structure See Also Send Feedback

The LCD height in inch.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Height As Double
C#
public double Height
Visual C++
public:
double Height
JavaScript
height

See Also

LCDExtents Structure


Width Field

[image]

.NET Framework Class Library
LCDExtents..::.Width Field
LCDExtents Structure See Also Send Feedback

The LCD width in inch.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Width As Double
C#
public double Width
Visual C++
public:
double Width
JavaScript
width

See Also

LCDExtents Structure


LCDExtents Methods

[image] [image]

.NET Framework Class Library
LCDExtents Methods
LCDExtents Structure See Also Send Feedback

The LCDExtents type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

LCDExtents Structure


LCDPixelRange Structure

[image]

.NET Framework Class Library
LCDPixelRange Structure
See Also Send Feedback

Define the LCD range in pixel. The range is defined by its up left point and its width and height.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure LCDPixelRange
C#
public struct LCDPixelRange
Visual C++
public value class LCDPixelRange
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


LCDPixelRange Fields

[image] [image]

.NET Framework Class Library
LCDPixelRange Fields
LCDPixelRange Structure See Also Send Feedback

The LCDPixelRange type exposes the following members.

Fields

Name | Description
Height | The range height in pixel.
Width | The range width in pixel.
X | The x-axis pixel index (0-basis) of the up-left point.
Y | The y-axis pixel index (0-basis) of the up-left point.

See Also

LCDPixelRange Structure


Height Field

[image]

.NET Framework Class Library
LCDPixelRange..::.Height Field
LCDPixelRange Structure See Also Send Feedback

The range height in pixel.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Height As Short
C#
public short Height
Visual C++
public:
short Height
JavaScript
height

See Also

LCDPixelRange Structure


Width Field

[image]

.NET Framework Class Library
LCDPixelRange..::.Width Field
LCDPixelRange Structure See Also Send Feedback

The range width in pixel.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Width As Short
C#
public short Width
Visual C++
public:
short Width
JavaScript
width

See Also

LCDPixelRange Structure


X Field

[image]

.NET Framework Class Library
LCDPixelRange..::.X Field
LCDPixelRange Structure See Also Send Feedback

The x-axis pixel index (0-basis) of the up-left point.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public X As Short
C#
public short X
Visual C++
public:
short X
JavaScript
x

See Also

LCDPixelRange Structure


Y Field

[image]

.NET Framework Class Library
LCDPixelRange..::.Y Field
LCDPixelRange Structure See Also Send Feedback

The y-axis pixel index (0-basis) of the up-left point.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Y As Short
C#
public short Y
Visual C++
public:
short Y
JavaScript
y

See Also

LCDPixelRange Structure


LCDPixelRange Methods

[image] [image]

.NET Framework Class Library
LCDPixelRange Methods
LCDPixelRange Structure See Also Send Feedback

The LCDPixelRange type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

LCDPixelRange Structure


LCDPixels Structure

[image]

.NET Framework Class Library
LCDPixels Structure
See Also Send Feedback

Define the LCD X-axis and Y-axis pixel numbers.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure LCDPixels
C#
public struct LCDPixels
Visual C++
public value class LCDPixels
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


LCDPixels Fields

[image] [image]

.NET Framework Class Library
LCDPixels Fields
LCDPixels Structure See Also Send Feedback

The LCDPixels type exposes the following members.

Fields

Name | Description
XPixels | The x-coordinate pixel number
YPixels | The y-coordinate pixel number

See Also

LCDPixels Structure


XPixels Field

[image]

.NET Framework Class Library
LCDPixels..::.XPixels Field
LCDPixels Structure See Also Send Feedback

The x-coordinate pixel number

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public XPixels As Short
C#
public short XPixels
Visual C++
public:
short XPixels
JavaScript
xPixels

See Also

LCDPixels Structure


YPixels Field

[image]

.NET Framework Class Library
LCDPixels..::.YPixels Field
LCDPixels Structure See Also Send Feedback

The y-coordinate pixel number

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public YPixels As Short
C#
public short YPixels
Visual C++
public:
short YPixels
JavaScript
yPixels

See Also

LCDPixels Structure


LCDPixels Methods

[image] [image]

.NET Framework Class Library
LCDPixels Methods
LCDPixels Structure See Also Send Feedback

The LCDPixels type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

LCDPixels Structure


LCDPoint Structure

[image]

.NET Framework Class Library
LCDPoint Structure
See Also Send Feedback

Define a LCD point in pixel

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure LCDPoint
C#
public struct LCDPoint
Visual C++
public value class LCDPoint
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


LCDPoint Fields

[image] [image]

.NET Framework Class Library
LCDPoint Fields
LCDPoint Structure See Also Send Feedback

The LCDPoint type exposes the following members.

Fields

Name | Description
X | The point x axis value in pixel.
Y | The point y axis value in pixel.

See Also

LCDPoint Structure


X Field

[image]

.NET Framework Class Library
LCDPoint..::.X Field
LCDPoint Structure See Also Send Feedback

The point x axis value in pixel.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public X As Integer
C#
public int X
Visual C++
public:
int X
JavaScript
x

See Also

LCDPoint Structure


Y Field

[image]

.NET Framework Class Library
LCDPoint..::.Y Field
LCDPoint Structure See Also Send Feedback

The point y axis value in pixel.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Y As Integer
C#
public int Y
Visual C++
public:
int Y
JavaScript
y

See Also

LCDPoint Structure


LCDPoint Methods

[image] [image]

.NET Framework Class Library
LCDPoint Methods
LCDPoint Structure See Also Send Feedback

The LCDPoint type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

LCDPoint Structure


PinPadControls Enumeration

[image]

.NET Framework Class Library
PinPadControls Enumeration
See Also Send Feedback

Defines the controls of Pin Pad Widget.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PinPadControls
C#
public enum PinPadControls
Visual C++
public enum class PinPadControls
JavaScript
Interlink.ePad.ePadVision.PinPadControls = function();
Interlink.ePad.ePadVision.PinPadControls.createEnum('Interlink.ePad.ePadVision.PinPadControls', false);

Members

Member name | Description
NUM_0 | The numberic key for number 0.
NUM_1 | The numberic key for number 1.
NUM_2 | The numberic key for number 2.
NUM_3 | The numberic key for number 3.
NUM_4 | The numberic key for number 4.
NUM_5 | The numberic key for number 5.
NUM_6 | The numberic key for number 6.
NUM_7 | The numberic key for number 7.
NUM_8 | The numberic key for number 8.
NUM_9 | The numberic key for number 9.
FUN_BACKSPACE | The functional key to backspce.
FUN_SEC | The fuctional checkbox to show the entered numbers as asterisks (optional item).
FUN_OK | The functional button to accept and dismiss the Pin Pad.
FUN_CANCEL | The functional button to cancel and dismiss the Pin Pad.
CAPTION | The text field to show the customized caption (optional item).
CONTENT | The text filed to display the entered numberic string.
IMAGE | The customized image (optional item).

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


ReportRateIndicator Enumeration

[image]

.NET Framework Class Library
ReportRateIndicator Enumeration
See Also Send Feedback

The signature point report rate indicator

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ReportRateIndicator
C#
public enum ReportRateIndicator
Visual C++
public enum class ReportRateIndicator
JavaScript
Interlink.ePad.ePadVision.ReportRateIndicator = function();
Interlink.ePad.ePadVision.ReportRateIndicator.createEnum('Interlink.ePad.ePadVision.ReportRateIndicator', false);

Members

Member name | Description
RPT400PS | 400 points per second.
RPT200PS | 200 points per second.
RPT100PS | 100 points per second.

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


Repository Enumeration

[image]

.NET Framework Class Library
Repository Enumeration
See Also Send Feedback

Specify where is the repository (on device or host)

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration Repository
C#
public enum Repository
Visual C++
public enum class Repository
JavaScript
Interlink.ePad.ePadVision.Repository = function();
Interlink.ePad.ePadVision.Repository.createEnum('Interlink.ePad.ePadVision.Repository', false);

Members

Member name | Description
DEVICE | On device
HOST | On host

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


ScreenSaver Class

[image]

.NET Framework Class Library
ScreenSaver Class
See Also Send Feedback

Gives screensaver's settings

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("CDF356D9-BB29-4cc9-BB84-E417A9D39B72")> _
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public Class ScreenSaver _
    Implements IScreenSaver
C#
[GuidAttribute("CDF356D9-BB29-4cc9-BB84-E417A9D39B72")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ScreenSaver : IScreenSaver
Visual C++
[GuidAttribute(L"CDF356D9-BB29-4cc9-BB84-E417A9D39B72")]
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class ScreenSaver : IScreenSaver
JavaScript
Interlink.ePad.ePadVision.ScreenSaver = function();

Type.createClass(
    'Interlink.ePad.ePadVision.ScreenSaver',
    null,
    Interlink.ePad.ePadVision.IScreenSaver);

Inheritance Hierarchy

System..::.Object
Interlink.ePad.ePadVision..::.ScreenSaver

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


ScreenSaver Methods

[image] [image]

.NET Framework Class Library
ScreenSaver Methods
ScreenSaver Class See Also Send Feedback

The ScreenSaver type exposes the following members.

Methods

Name | Description
AddImage | Add an additional image. Any size image will be resized to the full LCD in pixels. It is recommended to supply the image with the same size as LCD (480*272 Pixels). It is also recommended to have the image with the uncompressed format.
DeleteImage | Delete an image indexed by its position.
Dispose | Stop and discard the internal working thread.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ImagePreview | Show the image of the stored settings onto the device. The image is indexed by index. It is suggested to turn off the inking auto-erasing and stop the screensaver before call this method to show the image. Otherwise the shown image could be erased soon.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Reset | Remove all images and restore to default settings. The restored settings are not applied the device. Call the method StoreSettings(...) to transfer and save settings to device.
Resume | Resume the stopped screensaver
RetrieveSettings | Retrieve the screensaver settings from the repository. Only the screensaver parameters will be retrieved. The image are not retrieved yet.
Stop | Stop the screensaver if it is running. This method doesn't disable the screensaver. The screensaver will be restored after certain amount time (defined by Interval).
StoreSettings | Save the screensaver settings into the repository. If there are no images added before, only the screensaver parameters will be stored and the previous stored images will be kept. The stored settings takes effective immediately.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScreenSaver Class


AddImage Method

[image]

.NET Framework Class Library
ScreenSaver..::.AddImage Method
ScreenSaver Class See Also Send Feedback

Add an additional image.

Any size image will be resized to the full LCD in pixels. It is recommended to supply the image with the same size as LCD (480*272 Pixels). It is also recommended to have the image with the uncompressed format.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddImage ( _
    index As Integer, _
    imageData As Byte() _
)
C#
public void AddImage(
    int index,
    byte[] imageData
)
Visual C++
public:
virtual void AddImage(
    int index,
    array<unsigned char>^ imageData
) sealed
JavaScript
function addImage(index, imageData);

Parameters

index
Type: System..::.Int32
The image sequence position (0 basis)
imageData
Type: array< System..::.Byte >[]()[]
The image raw data. It could be any .Net supported image format

Implements

IScreenSaver..::.AddImage(Int32, array<Byte>[]()[])

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | When there are already 10 images added before.

See Also

ScreenSaver Class


DeleteImage Method

[image]

.NET Framework Class Library
ScreenSaver..::.DeleteImage Method
ScreenSaver Class See Also Send Feedback

Delete an image indexed by its position.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteImage ( _
    index As Integer _
)
C#
public void DeleteImage(
    int index
)
Visual C++
public:
virtual void DeleteImage(
    int index
) sealed
JavaScript
function deleteImage(index);

Parameters

index
Type: System..::.Int32
The image position

Implements

IScreenSaver..::.DeleteImage(Int32)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The image index is invalid.

See Also

ScreenSaver Class


Dispose Method

[image]

.NET Framework Class Library
ScreenSaver..::.Dispose Method
ScreenSaver Class See Also Send Feedback

Stop and discard the internal working thread.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose
C#
public virtual void Dispose()
Visual C++
public:
virtual void Dispose()
JavaScript
function dispose();

See Also

ScreenSaver Class


ImagePreview Method

[image]

.NET Framework Class Library
ScreenSaver..::.ImagePreview Method
ScreenSaver Class See Also Send Feedback

Show the image of the stored settings onto the device. The image is indexed by index.

It is suggested to turn off the inking auto-erasing and stop the screensaver before call this method to show the image. Otherwise the shown image could be erased soon.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub ImagePreview ( _
    index As Integer _
)
C#
public void ImagePreview(
    int index
)
Visual C++
public:
virtual void ImagePreview(
    int index
) sealed
JavaScript
function imagePreview(index);

Parameters

index
Type: System..::.Int32
The image index (0 based).

Implements

IScreenSaver..::.ImagePreview(Int32)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

ScreenSaver Class


Reset Method

[image]

.NET Framework Class Library
ScreenSaver..::.Reset Method
ScreenSaver Class See Also Send Feedback

Remove all images and restore to default settings.

The restored settings are not applied the device. Call the method StoreSettings(...) to transfer and save settings to device.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub Reset
C#
public void Reset()
Visual C++
public:
virtual void Reset() sealed
JavaScript
function reset();

Implements

IScreenSaver..::.Reset()()()

See Also

ScreenSaver Class


Resume Method

[image]

.NET Framework Class Library
ScreenSaver..::.Resume Method
ScreenSaver Class See Also Send Feedback

Resume the stopped screensaver

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub Resume
C#
public void Resume()
Visual C++
public:
virtual void Resume() sealed
JavaScript
function resume();

Implements

IScreenSaver..::.Resume()()()

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

ScreenSaver Class


RetrieveSettings Method

[image]

.NET Framework Class Library
ScreenSaver..::.RetrieveSettings Method
ScreenSaver Class See Also Send Feedback

Retrieve the screensaver settings from the repository.

Only the screensaver parameters will be retrieved. The image are not retrieved yet.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub RetrieveSettings ( _
    location As Repository _
)
C#
public void RetrieveSettings(
    Repository location
)
Visual C++
public:
virtual void RetrieveSettings(
    Repository location
) sealed
JavaScript
function retrieveSettings(location);

Parameters

location
Type: Interlink.ePad.ePadVision..::.Repository
The repository where to save the settings

Implements

IScreenSaver..::.RetrieveSettings(Repository)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | When the repository is not valid. The device is not open or failed to process the request.

See Also

ScreenSaver Class


Stop Method

[image]

.NET Framework Class Library
ScreenSaver..::.Stop Method
ScreenSaver Class See Also Send Feedback

Stop the screensaver if it is running.

This method doesn't disable the screensaver. The screensaver will be restored after certain amount time (defined by Interval).

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub Stop
C#
public void Stop()
Visual C++
public:
virtual void Stop() sealed
JavaScript
function stop();

Implements

IScreenSaver..::.Stop()()()

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

ScreenSaver Class


StoreSettings Method

[image]

.NET Framework Class Library
ScreenSaver..::.StoreSettings Method
ScreenSaver Class See Also Send Feedback

Save the screensaver settings into the repository.

If there are no images added before, only the screensaver parameters will be stored and the previous stored images will be kept.

The stored settings takes effective immediately.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub StoreSettings ( _
    location As Repository _
)
C#
public void StoreSettings(
    Repository location
)
Visual C++
public:
virtual void StoreSettings(
    Repository location
) sealed
JavaScript
function storeSettings(location);

Parameters

location
Type: Interlink.ePad.ePadVision..::.Repository
The repository where to save the settings

Implements

IScreenSaver..::.StoreSettings(Repository)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | When the repository is not valid. The device is not open or failed to process the request.

See Also

ScreenSaver Class


ScreenSaver Properties

[image] [image]

.NET Framework Class Library
ScreenSaver Properties
ScreenSaver Class See Also Send Feedback

The ScreenSaver type exposes the following members.

Properties

Name Description
DefaultRepository
The Repository where the default screensaver settings are stored

Remarks

This one will not been implemented in FCS
DisplayMode
Define how to display the images.

The supported mode will be defined later.

Enabled
Enable/Disable the screen saver.
EnableStandAlone
To run the screensaver when the device is idle (no connection).
ImageCount
How many images added.
Interval
The interval for the image to stay.
IsRunning
Whether the screensaver is running right now.
TimeOut
The timeout value in second to launch screensaver.

See Also

ScreenSaver Class


DefaultRepository Property

[image]

.NET Framework Class Library
ScreenSaver..::.DefaultRepository Property
ScreenSaver Class See Also Send Feedback

The Repository where the default screensaver settings are stored

Remarks

This one will not been implemented in FCS

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultRepository As Repository
C#
public Repository DefaultRepository { get; set; }
Visual C++
public:
virtual property Repository DefaultRepository {
    Repository get () sealed;
    void set (Repository value) sealed;
}
JavaScript
function get_defaultRepository();
function set_defaultRepository(value);

Implements

IScreenSaver..::.DefaultRepository

See Also

ScreenSaver Class


DisplayMode Property

[image]

.NET Framework Class Library
ScreenSaver..::.DisplayMode Property
ScreenSaver Class See Also Send Feedback

Define how to display the images.

The supported mode will be defined later.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As ImageDisplayMode
C#
public ImageDisplayMode DisplayMode { get; set; }
Visual C++
public:
virtual property ImageDisplayMode DisplayMode {
    ImageDisplayMode get () sealed;
    void set (ImageDisplayMode value) sealed;
}
JavaScript
function get_displayMode();
function set_displayMode(value);

Implements

IScreenSaver..::.DisplayMode

See Also

ScreenSaver Class


Enabled Property

[image]

.NET Framework Class Library
ScreenSaver..::.Enabled Property
ScreenSaver Class See Also Send Feedback

Enable/Disable the screen saver.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled { get; set; }
Visual C++
public:
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_enabled();
function set_enabled(value);

Implements

IScreenSaver..::.Enabled

Remarks

By default, this property is true.

See Also

ScreenSaver Class


EnableStandAlone Property

[image]

.NET Framework Class Library
ScreenSaver..::.EnableStandAlone Property
ScreenSaver Class See Also Send Feedback

To run the screensaver when the device is idle (no connection).

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableStandAlone As Boolean
C#
public bool EnableStandAlone { get; set; }
Visual C++
public:
virtual property bool EnableStandAlone {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_enableStandAlone();
function set_enableStandAlone(value);

Implements

IScreenSaver..::.EnableStandAlone

Remarks

By default, this property is true.

See Also

ScreenSaver Class


ImageCount Property

[image]

.NET Framework Class Library
ScreenSaver..::.ImageCount Property
ScreenSaver Class See Also Send Feedback

How many images added.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ImageCount As Integer
C#
public int ImageCount { get; }
Visual C++
public:
virtual property int ImageCount {
    int get () sealed;
}
JavaScript
function get_imageCount();

Implements

IScreenSaver..::.ImageCount

Remarks

The added images may not be saved onto repository yet.

See Also

ScreenSaver Class


Interval Property

[image]

.NET Framework Class Library
ScreenSaver..::.Interval Property
ScreenSaver Class See Also Send Feedback

The interval for the image to stay.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property Interval As Short
C#
public short Interval { get; set; }
Visual C++
public:
virtual property short Interval {
    short get () sealed;
    void set (short value) sealed;
}
JavaScript
function get_interval();
function set_interval(value);

Implements

IScreenSaver..::.Interval

Remarks

By default, this property is 5 seconds.

Its valid range is 1--60.

See Also

ScreenSaver Class


IsRunning Property

[image]

.NET Framework Class Library
ScreenSaver..::.IsRunning Property
ScreenSaver Class See Also Send Feedback

Whether the screensaver is running right now.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRunning As Boolean
C#
public bool IsRunning { get; }
Visual C++
public:
virtual property bool IsRunning {
    bool get () sealed;
}
JavaScript
function get_isRunning();

Implements

IScreenSaver..::.IsRunning

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

ScreenSaver Class


TimeOut Property

[image]

.NET Framework Class Library
ScreenSaver..::.TimeOut Property
ScreenSaver Class See Also Send Feedback

The timeout value in second to launch screensaver.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property TimeOut As Integer
C#
public int TimeOut { get; set; }
Visual C++
public:
virtual property int TimeOut {
    int get () sealed;
    void set (int value) sealed;
}
JavaScript
function get_timeOut();
function set_timeOut(value);

Implements

IScreenSaver..::.TimeOut

Remarks

By default, this property is 30 seconds.

Its valid range is 1--60.

See Also

ScreenSaver Class


SIFonts Class

[image]

.NET Framework Class Library
SIFonts Class
See Also Send Feedback

The SIF font operations.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("B5102CAE-EBF5-4edb-BB45-61C3984E8408")> _
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public Class SIFonts _
    Implements ISIFont
C#
[GuidAttribute("B5102CAE-EBF5-4edb-BB45-61C3984E8408")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SIFonts : ISIFont
Visual C++
[GuidAttribute(L"B5102CAE-EBF5-4edb-BB45-61C3984E8408")]
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class SIFonts : ISIFont
JavaScript
Interlink.ePad.ePadVision.SIFonts = function();

Type.createClass(
    'Interlink.ePad.ePadVision.SIFonts',
    null,
    Interlink.ePad.ePadVision.ISIFont);

Inheritance Hierarchy

System..::.Object
Interlink.ePad.ePadVision..::.SIFonts

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


SIFonts Methods

[image] [image]

.NET Framework Class Library
SIFonts Methods
SIFonts Class See Also Send Feedback

The SIFonts type exposes the following members.

Methods

Name | Description
CreateSIF | Create a new Font from existing SIF font file in the flash and associated the new Font with fontId
DeleteSIF | delete a SIF file from ePad-vision external Flash or purge all the fonts in RAM
DownloadSIF | Read the SIF format file then loaded it into ePad-vision external device
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SIFonts Class


CreateSIF Method

[image]

.NET Framework Class Library
SIFonts..::.CreateSIF Method
SIFonts Class See Also Send Feedback

Create a new Font from existing SIF font file in the flash and associated the new Font with fontId

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSIF ( _
    SIFfile As String, _
    fontId As Byte, _
    source As Byte _
) As Boolean
C#
public bool CreateSIF(
    string SIFfile,
    byte fontId,
    byte source
)
Visual C++
public:
virtual bool CreateSIF(
    String^ SIFfile,
    unsigned char fontId,
    unsigned char source
) sealed
JavaScript
function createSIF(SIFfile, fontId, source);

Parameters

SIFfile
Type: System..::.String
The filename of an existing System Independent Font(SIF) file in the flash.

The SIF file already downloaed to the ePad-vision through DownloadSIF() API.

fontId
Type: System..::.Byte
fontId within downlaodable fonts range, please refer FontID

The font id assoicated with SIF file for Widget operations.

source
Type: System..::.Byte
Currently only support from Flash, please refer ExternalDevice

Implements

ISIFont..::.CreateSIF(String, Byte, Byte)

Remarks

Copy the SIF font file from FLASH to PSRAM and create a SIF font in PSRAM and associated the fontId with it.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or Invalid path to the SIF or SIF could not be found in the Flash or Invalid font id or font id already in use or Invalid source value

See Also

SIFonts Class


DeleteSIF Method

[image]

.NET Framework Class Library
SIFonts..::.DeleteSIF Method
SIFonts Class See Also Send Feedback

delete a SIF file from ePad-vision external Flash or purge all the fonts in RAM

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Function DeleteSIF ( _
    SIFfile As String, _
    source As Byte _
) As Boolean
C#
public bool DeleteSIF(
    string SIFfile,
    byte source
)
Visual C++
public:
virtual bool DeleteSIF(
    String^ SIFfile,
    unsigned char source
) sealed
JavaScript
function deleteSIF(SIFfile, source);

Parameters

SIFfile
Type: System..::.String
The file name of an existing System Indepenece Font(SIF) file.

The SIF file has been downloaded to ePad-vision external Flash.

The SIF file could be null, if the source is RAM.

source
Type: System..::.Byte
please ref to ExternalDevice

Implements

ISIFont..::.DeleteSIF(String, Byte)

Remarks

If the source is the Flash, an existing SIFfile will be deleted. If the source is the PSRAM, all the fonts will be purged.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or SIF not existed or Invalid source value ///

See Also

SIFonts Class


DownloadSIF Method

[image]

.NET Framework Class Library
SIFonts..::.DownloadSIF Method
SIFonts Class See Also Send Feedback

Read the SIF format file then loaded it into ePad-vision external device

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub DownloadSIF ( _
    SIFfile As String, _
    fontId As Byte, _
    destination As Byte _
)
C#
public void DownloadSIF(
    string SIFfile,
    byte fontId,
    byte destination
)
Visual C++
public:
virtual void DownloadSIF(
    String^ SIFfile,
    unsigned char fontId,
    unsigned char destination
) sealed
JavaScript
function downloadSIF(SIFfile, fontId, destination);

Parameters

SIFfile
Type: System..::.String
The absolute full path to an existing SIF font file.

A SIF format file could be generated through font converter application by ePadLink.

fontId
Type: System..::.Byte
0 or 220 to 224. Please ref to FontID

destination
Type: System..::.Byte
Please ref to ExternalDevice

Implements

ISIFont..::.DownloadSIF(String, Byte, Byte)

Remarks

If the destination is the Flash and the font id within 220-224, the SIF font will be downloaded into Flash and a new FONT will be created in the PSRAM as well. This configuration combined font downloading and creation in one call.

If the destination is Flash and the font id is 0, the font will be downloaded into Flash only. This font could be created through CreateSIF() later.

"/>

If the destination is PSRAM and font id must be in the DOWNLOAD_FONT range, the SIF font will be downloaded and created in PSRAM.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or Invalid path to the SIF or Invalid SIF format or Invalid fontId or Not enough space or fontId already in use or Invalid destination value

See Also

SIFonts Class


SIFonts Properties

[image] [image]

.NET Framework Class Library
SIFonts Properties
SIFonts Class See Also Send Feedback

The SIFonts type exposes the following members.

Properties

Name | Description
GetFontListFromFlash | Get a list of downloaded font from the ePad-vision external Flash
GetFontListFromRAM | Get a list of downloaded font from the ePad-vision external RAM

See Also

SIFonts Class


GetFontListFromFlash Property

[image]

.NET Framework Class Library
SIFonts..::.GetFontListFromFlash Property
SIFonts Class See Also Send Feedback

Get a list of downloaded font from the ePad-vision external Flash

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GetFontListFromFlash As FontList
C#
public FontList GetFontListFromFlash { get; }
Visual C++
public:
virtual property FontList^ GetFontListFromFlash {
    FontList^ get () sealed;
}
JavaScript
function get_getFontListFromFlash();

Return Value

a list of FontEntry stored in the external Flash

Implements

ISIFont..::.GetFontListFromFlash

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

SIFonts Class


GetFontListFromRAM Property

[image]

.NET Framework Class Library
SIFonts..::.GetFontListFromRAM Property
SIFonts Class See Also Send Feedback

Get a list of downloaded font from the ePad-vision external RAM

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GetFontListFromRAM As FontList
C#
public FontList GetFontListFromRAM { get; }
Visual C++
public:
virtual property FontList^ GetFontListFromRAM {
    FontList^ get () sealed;
}
JavaScript
function get_getFontListFromRAM();

Return Value

a list of FontEntry stored in the external RAM

Implements

ISIFont..::.GetFontListFromRAM

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

SIFonts Class


SignaturePad Class

[image]

.NET Framework Class Library
SignaturePad Class
See Also Send Feedback

Represent the signature pad

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("C3E289E8-57A4-4ce6-9B5B-C907F88258FE")> _
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public Class SignaturePad _
    Implements ISignaturePad
C#
[GuidAttribute("C3E289E8-57A4-4ce6-9B5B-C907F88258FE")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SignaturePad : ISignaturePad
Visual C++
[GuidAttribute(L"C3E289E8-57A4-4ce6-9B5B-C907F88258FE")]
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class SignaturePad : ISignaturePad
JavaScript
Interlink.ePad.ePadVision.SignaturePad = function();

Type.createClass(
    'Interlink.ePad.ePadVision.SignaturePad',
    null,
    Interlink.ePad.ePadVision.ISignaturePad);

Inheritance Hierarchy

System..::.Object
Interlink.ePad.ePadVision..::.SignaturePad

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


SignaturePad Constructor

[image]

.NET Framework Class Library
SignaturePad Constructor
SignaturePad Class See Also Send Feedback

The constructor

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    provider As ePadVision _
)
C#
public SignaturePad(
    ePadVision provider
)
Visual C++
public:
SignaturePad(
    ePadVision^ provider
)
JavaScript
Interlink.ePad.ePadVision.SignaturePad = function(provider);

Parameters

provider
Type: Interlink.ePad.ePadVision..::.ePadVision
The instance of ePadVision

See Also

SignaturePad Class


SignaturePad Methods

[image] [image]

.NET Framework Class Library
SignaturePad Methods
SignaturePad Class See Also Send Feedback

The SignaturePad type exposes the following members.

Methods

Name | Description
CancelCalibration | Cancel the current calibration procedure if applicable.
DoCalibration | Do the calibration and save the settings if successfully.
DrawImage | Draw the image at the range specified by parameter range. Any size image will be resized to the sized defined by range . It is recommended to supply the image with the exact size. It is also recommended to have the image with the uncompressed format.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Refresh | Refresh the LCD. The ink tail and the temporary drawn images will be removed.
SetBackgroundImage | Set the background image. Any size image will be resized to the sized defined by width and height . It is recommended to supply the image with the exact size. It is also recommended to have the image with the uncompressed format.
SetCustomizedBackgroundImage | Set the customized background image. There is only one customized image allowed. If there is customized background image existed before, it will be replaced. When the customized background image has been set, it stays on device permanently until it has been set again. It is recommended that application uses the const GUID to identify its specific customized background image. Before the application sets its own customized background image, it is better to check if it is already on device by comparing its const GUID with the one from the property CustomizedBackgroundImageID.
SetInkRegion | Set the ink region. It does the same thing as property InkRegion (set) and it is designed for VB6 user to set the structure type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SignaturePad Class


CancelCalibration Method

[image]

.NET Framework Class Library
SignaturePad..::.CancelCalibration Method
SignaturePad Class See Also Send Feedback

Cancel the current calibration procedure if applicable.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelCalibration
C#
public void CancelCalibration()
Visual C++
public:
virtual void CancelCalibration() sealed
JavaScript
function cancelCalibration();

Implements

ISignaturePad..::.CancelCalibration()()()

See Also

SignaturePad Class


DoCalibration Method

[image]

.NET Framework Class Library
SignaturePad..::.DoCalibration Method
SignaturePad Class See Also Send Feedback

Do the calibration and save the settings if successfully.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub DoCalibration
C#
public void DoCalibration()
Visual C++
public:
virtual void DoCalibration() sealed
JavaScript
function doCalibration();

Implements

ISignaturePad..::.DoCalibration()()()

Remarks

The return value only indicates whether the calibration request has been accepted or not. When the device finishes calibration, it will send out notification message via HID IN channel to inform the client whether the calibration is successful or failed.

If the calibration is successful, the new settings is automatically saved into the NV.

If the calibration is failed, the previous settings should be kept.

In the middle of calibration, an exception will be raised if the application calls any other method/property that could change the device internal state. For example, change the ink region, report rate...

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class


DrawImage Method

[image]

.NET Framework Class Library
SignaturePad..::.DrawImage Method
SignaturePad Class See Also Send Feedback

Draw the image at the range specified by parameter range.

Any size image will be resized to the sized defined by

range

. It is recommended to supply the image with the exact size. It is also recommended to have the image with the uncompressed format.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub DrawImage ( _
    range As LCDPixelRange, _
    imageData As Byte() _
)
C#
public void DrawImage(
    LCDPixelRange range,
    byte[] imageData
)
Visual C++
public:
virtual void DrawImage(
    LCDPixelRange range,
    array<unsigned char>^ imageData
) sealed
JavaScript
function drawImage(range, imageData);

Parameters

range
Type: Interlink.ePad.ePadVision..::.LCDPixelRange
The LCD range.
imageData
Type: array< System..::.Byte >[]()[]
The image data. It could be any .Net supported image format

Implements

ISignaturePad..::.DrawImage(LCDPixelRange, array<Byte>[]()[])

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class


Refresh Method

[image]

.NET Framework Class Library
SignaturePad..::.Refresh Method
SignaturePad Class See Also Send Feedback

Refresh the LCD. The ink tail and the temporary drawn images will be removed.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub Refresh
C#
public void Refresh()
Visual C++
public:
virtual void Refresh() sealed
JavaScript
function refresh();

Implements

ISignaturePad..::.Refresh()()()

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class


SetBackgroundImage Method

[image]

.NET Framework Class Library
SignaturePad..::.SetBackgroundImage Method
SignaturePad Class See Also Send Feedback

Set the background image.

Any size image will be resized to the sized defined by

width

and

height

. It is recommended to supply the image with the exact size. It is also recommended to have the image with the uncompressed format.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetBackgroundImage ( _
    range As LCDPixelRange, _
    imageData As Byte() _
)
C#
public void SetBackgroundImage(
    LCDPixelRange range,
    byte[] imageData
)
Visual C++
public:
virtual void SetBackgroundImage(
    LCDPixelRange range,
    array<unsigned char>^ imageData
) sealed
JavaScript
function setBackgroundImage(range, imageData);

Parameters

range
Type: Interlink.ePad.ePadVision..::.LCDPixelRange
The LCD range.
imageData
Type: array< System..::.Byte >[]()[]
The image formatted data (for example JPG format).

Implements

ISignaturePad..::.SetBackgroundImage(LCDPixelRange, array<Byte>[]()[])

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class


SetCustomizedBackgroundImage Method

[image]

.NET Framework Class Library
SignaturePad..::.SetCustomizedBackgroundImage Method
SignaturePad Class See Also Send Feedback

Set the customized background image.

There is only one customized image allowed. If there is customized background image existed before, it will be replaced.

When the customized background image has been set, it stays on device permanently until it has been set again.

It is recommended that application uses the const GUID to identify its specific customized background image. Before the application sets its own customized background image, it is better to check if it is already on device by comparing its const GUID with the one from the property CustomizedBackgroundImageID.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetCustomizedBackgroundImage ( _
    imageID As Guid, _
    range As LCDPixelRange, _
    imageData As Byte() _
)
C#
public void SetCustomizedBackgroundImage(
    Guid imageID,
    LCDPixelRange range,
    byte[] imageData
)
Visual C++
public:
virtual void SetCustomizedBackgroundImage(
    Guid imageID,
    LCDPixelRange range,
    array<unsigned char>^ imageData
) sealed
JavaScript
function setCustomizedBackgroundImage(imageID, range, imageData);

Parameters

imageID
Type: System..::.Guid
The customized background image ID (GUID). It must be valid GUID.
range
Type: Interlink.ePad.ePadVision..::.LCDPixelRange
The LCD range.
imageData
Type: array< System..::.Byte >[]()[]
The image formatted data (for example JPG format).

Implements

ISignaturePad..::.SetCustomizedBackgroundImage(Guid, LCDPixelRange, array<Byte>[]()[])

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request. The image ID is not valid GUID number (all fields are zeroed).

See Also

SignaturePad Class


SetInkRegion Method

[image]

.NET Framework Class Library
SignaturePad..::.SetInkRegion Method
SignaturePad Class See Also Send Feedback

Set the ink region.

It does the same thing as property InkRegion (set) and it is designed for VB6 user to set the structure type.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetInkRegion ( _
    ByRef ink As InkRegion _
)
C#
public void SetInkRegion(
    ref InkRegion ink
)
Visual C++
public:
virtual void SetInkRegion(
    InkRegion% ink
) sealed
JavaScript
function setInkRegion(ink);

Parameters

ink
Type: Interlink.ePad.ePadVision..::.InkRegion %
The desired ink region settings

Implements

ISignaturePad..::.SetInkRegion(InkRegion%)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request. The pen width is less than 1 or large than 10.

See Also

SignaturePad Class


SignaturePad Properties

[image] [image]

.NET Framework Class Library
SignaturePad Properties
SignaturePad Class See Also Send Feedback

The SignaturePad type exposes the following members.

Properties

Name | Description
BackgroundColor | The LCD background color.
BacklightLevel | The LCD backlight brightness level (0--10). 0: The LCD is totally dark; 10: The LCD is the brightest level;
CustomizedBackgroundImageID | Give the stored customized background ID (Guid). Only one customized image could be stored in device. If there is no customized background image on device, the Guid with all zeros will be given;
EnableBackgroundImage | Enable to show the background image. After opening the device, this property is true by default.
EnableCustomizedBackgroundImage | Enable or disable the customized background image. After opening the device, this property is false by default.
InkRegion | the ink region settings.
LCDPixels | The LCD pixel number in x/y axis.
PadInfo | The pad physical info.
RptRate | the signature point report rate indicator
WatermarkColor | The watermark color.

See Also

SignaturePad Class


BackgroundColor Property

[image]

.NET Framework Class Library
SignaturePad..::.BackgroundColor Property
SignaturePad Class See Also Send Feedback

The LCD background color.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property BackgroundColor As LCDColor
C#
public LCDColor BackgroundColor { get; set; }
Visual C++
public:
virtual property LCDColor BackgroundColor {
    LCDColor get () sealed;
    void set (LCDColor value) sealed;
}
JavaScript
function get_backgroundColor();
function set_backgroundColor(value);

Implements

ISignaturePad..::.BackgroundColor

Remarks

If it wasn't set before, its default color is light blue (Red: 0xA2, Green: 0xA2; Blue: 0xFF).

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class


BacklightLevel Property

[image]

.NET Framework Class Library
SignaturePad..::.BacklightLevel Property
SignaturePad Class See Also Send Feedback

The LCD backlight brightness level (0--10).

0: The LCD is totally dark;

10: The LCD is the brightest level;

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property BacklightLevel As Byte
C#
public byte BacklightLevel { get; set; }
Visual C++
public:
virtual property unsigned char BacklightLevel {
    unsigned char get () sealed;
    void set (unsigned char value) sealed;
}
JavaScript
function get_backlightLevel();
function set_backlightLevel(value);

Implements

ISignaturePad..::.BacklightLevel

Remarks

If it wasn't set before, its default value is 10.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request. Invalid brightness level.

See Also

SignaturePad Class


CustomizedBackgroundImageID Property

[image]

.NET Framework Class Library
SignaturePad..::.CustomizedBackgroundImageID Property
SignaturePad Class See Also Send Feedback

Give the stored customized background ID (Guid).

Only one customized image could be stored in device. If there is no customized background image on device, the Guid with all zeros will be given;

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomizedBackgroundImageID As Guid
C#
public Guid CustomizedBackgroundImageID { get; }
Visual C++
public:
virtual property Guid CustomizedBackgroundImageID {
    Guid get () sealed;
}
JavaScript
function get_customizedBackgroundImageID();

Implements

ISignaturePad..::.CustomizedBackgroundImageID

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class


EnableBackgroundImage Property

[image]

.NET Framework Class Library
SignaturePad..::.EnableBackgroundImage Property
SignaturePad Class See Also Send Feedback

Enable to show the background image.

After opening the device, this property is true by default.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableBackgroundImage As Boolean
C#
public bool EnableBackgroundImage { get; set; }
Visual C++
public:
virtual property bool EnableBackgroundImage {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_enableBackgroundImage();
function set_enableBackgroundImage(value);

Implements

ISignaturePad..::.EnableBackgroundImage

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class
Interlink.ePad.ePadVision Namespace
When the customized background image is available and enabled, the regular background image is depressed.


EnableCustomizedBackgroundImage Property

[image]

.NET Framework Class Library
SignaturePad..::.EnableCustomizedBackgroundImage Property
SignaturePad Class See Also Send Feedback

Enable or disable the customized background image.

After opening the device, this property is false by default.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableCustomizedBackgroundImage As Boolean
C#
public bool EnableCustomizedBackgroundImage { get; set; }
Visual C++
public:
virtual property bool EnableCustomizedBackgroundImage {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_enableCustomizedBackgroundImage();
function set_enableCustomizedBackgroundImage(value);

Implements

ISignaturePad..::.EnableCustomizedBackgroundImage

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open, failed to process the request, or there is no customized background image.

See Also

SignaturePad Class
Interlink.ePad.ePadVision Namespace
When the customized background image is available and enabled, the regular background image is depressed.


InkRegion Property

[image]

.NET Framework Class Library
SignaturePad..::.InkRegion Property
SignaturePad Class See Also Send Feedback

the ink region settings.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property InkRegion As InkRegion
C#
public InkRegion InkRegion { get; set; }
Visual C++
public:
virtual property InkRegion InkRegion {
    InkRegion get () sealed;
    void set (InkRegion value) sealed;
}
JavaScript
function get_inkRegion();
function set_inkRegion(value);

Implements

ISignaturePad..::.InkRegion

Remarks

If it wasn't set before, the following default settings will be applied.

Pen Width: 3 pixels; Ink Color: Black (Red: 0x00, Green: 0x00, Blue: 0x00); Inking Auto-erase: 5 seconds, Ink Region: Entire LCD.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request. The pen width is less than 1 or large than 10.

See Also

SignaturePad Class


LCDPixels Property

[image]

.NET Framework Class Library
SignaturePad..::.LCDPixels Property
SignaturePad Class See Also Send Feedback

The LCD pixel number in x/y axis.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LCDPixels As LCDPixels
C#
public LCDPixels LCDPixels { get; }
Visual C++
public:
virtual property LCDPixels LCDPixels {
    LCDPixels get () sealed;
}
JavaScript
function get_lcdPixels();

Implements

ISignaturePad..::.LCDPixels

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class


PadInfo Property

[image]

.NET Framework Class Library
SignaturePad..::.PadInfo Property
SignaturePad Class See Also Send Feedback

The pad physical info.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadInfo As DevicePadInfo
C#
public DevicePadInfo PadInfo { get; }
Visual C++
public:
virtual property DevicePadInfo PadInfo {
    DevicePadInfo get () sealed;
}
JavaScript
function get_padInfo();

Implements

ISignaturePad..::.PadInfo

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class


RptRate Property

[image]

.NET Framework Class Library
SignaturePad..::.RptRate Property
SignaturePad Class See Also Send Feedback

the signature point report rate indicator

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property RptRate As ReportRateIndicator
C#
public ReportRateIndicator RptRate { get; set; }
Visual C++
public:
virtual property ReportRateIndicator RptRate {
    ReportRateIndicator get () sealed;
    void set (ReportRateIndicator value) sealed;
}
JavaScript
function get_rptRate();
function set_rptRate(value);

Implements

ISignaturePad..::.RptRate

Remarks

If it wasn't set before, its default value is RPT100PS (100 Point Per Second).

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class


WatermarkColor Property

[image]

.NET Framework Class Library
SignaturePad..::.WatermarkColor Property
SignaturePad Class See Also Send Feedback

The watermark color.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Property WatermarkColor As LCDColor
C#
public LCDColor WatermarkColor { get; set; }
Visual C++
public:
virtual property LCDColor WatermarkColor {
    LCDColor get () sealed;
    void set (LCDColor value) sealed;
}
JavaScript
function get_watermarkColor();
function set_watermarkColor(value);

Implements

ISignaturePad..::.WatermarkColor

Remarks

If it wasn't set before, its default color is Red (Red: 0xFF, Green: 0x00; Blue: 0x00).

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request.

See Also

SignaturePad Class


WEventDataDelegate Delegate

[image]

.NET Framework Class Library
WEventDataDelegate Delegate
See Also Send Feedback

Define the widget event handler.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)> _
Public Delegate Sub WEventDataDelegate ( _
    widgetID As Byte, _
    widgetType As EventType, _
    eventCode As EventCode _
)
C#
[ComVisibleAttribute(false)]
public delegate void WEventDataDelegate(
    byte widgetID,
    EventType widgetType,
    EventCode eventCode
)
Visual C++
[ComVisibleAttribute(false)]
public delegate void WEventDataDelegate(
    unsigned char widgetID,
    EventType widgetType,
    EventCode eventCode
)
JavaScript
function(widgetID, widgetType, eventCode);

Parameters

widgetID
Type: System..::.Byte
The source entity (for example the widget) ID.
widgetType
Type: Interlink.ePad.ePadVision..::.EventType
The event type.
eventCode
Type: Interlink.ePad.ePadVision..::.EventCode
The incurred event code.

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


WidgetEffect Enumeration

[image]

.NET Framework Class Library
WidgetEffect Enumeration
See Also Send Feedback

The widget appearance effect.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration WidgetEffect
C#
public enum WidgetEffect
Visual C++
public enum class WidgetEffect
JavaScript
Interlink.ePad.ePadVision.WidgetEffect = function();
Interlink.ePad.ePadVision.WidgetEffect.createEnum('Interlink.ePad.ePadVision.WidgetEffect', false);

Members

Member name | Description
THREED | 3D appearance
SIMPLE | Simple appearance
NONE | No appearance effect

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


WidgetInfo Structure

[image]

.NET Framework Class Library
WidgetInfo Structure
See Also Send Feedback

Define the Widget.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Structure WidgetInfo
C#
public struct WidgetInfo
Visual C++
public value class WidgetInfo
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


WidgetInfo Fields

[image] [image]

.NET Framework Class Library
WidgetInfo Fields
WidgetInfo Structure See Also Send Feedback

The WidgetInfo type exposes the following members.

Fields

Name | Description
BgColor | The background color
Effect | The widget appearance effect.
FgColor | the foreground color
FontID | The font ID
GroupID | When the widgetType is WidgetType.RadioButton, it defines the group that the radio button located. Within the group, the button is exclusive. The valid group ID is 1--255. If the 0 is given, the incurred radio button will not be grouped to any others. For any other widget type, it will be ignored.
Height | The widget's height, from 20 up to 272 pixels
Left | The x coordinate value of widget's top-left point
Text | The widget text.
Top | The y coordinate value of widget's top-left point
WidgetID | The widget ID
WidgetType | The widget type
Width | The widget's width, from 40 up to 480 pixels

See Also

WidgetInfo Structure


BgColor Field

[image]

.NET Framework Class Library
WidgetInfo..::.BgColor Field
WidgetInfo Structure See Also Send Feedback

The background color

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public BgColor As LCDColor
C#
public LCDColor BgColor
Visual C++
public:
LCDColor BgColor
JavaScript
bgColor

See Also

WidgetInfo Structure


Effect Field

[image]

.NET Framework Class Library
WidgetInfo..::.Effect Field
WidgetInfo Structure See Also Send Feedback

The widget appearance effect.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Effect As WidgetEffect
C#
public WidgetEffect Effect
Visual C++
public:
WidgetEffect Effect
JavaScript
effect

See Also

WidgetInfo Structure


FgColor Field

[image]

.NET Framework Class Library
WidgetInfo..::.FgColor Field
WidgetInfo Structure See Also Send Feedback

the foreground color

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public FgColor As LCDColor
C#
public LCDColor FgColor
Visual C++
public:
LCDColor FgColor
JavaScript
fgColor

See Also

WidgetInfo Structure


FontID Field

[image]

.NET Framework Class Library
WidgetInfo..::.FontID Field
WidgetInfo Structure See Also Send Feedback

The font ID

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public FontID As Byte
C#
public byte FontID
Visual C++
public:
unsigned char FontID
JavaScript
fontID

See Also

WidgetInfo Structure


GroupID Field

[image]

.NET Framework Class Library
WidgetInfo..::.GroupID Field
WidgetInfo Structure See Also Send Feedback

When the widgetType is WidgetType.RadioButton, it defines the group that the radio button located.

Within the group, the button is exclusive.

The valid group ID is 1--255. If the 0 is given, the incurred radio button will not be grouped to any others.

For any other widget type, it will be ignored.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public GroupID As Byte
C#
public byte GroupID
Visual C++
public:
unsigned char GroupID
JavaScript
groupID

See Also

WidgetInfo Structure


Height Field

[image]

.NET Framework Class Library
WidgetInfo..::.Height Field
WidgetInfo Structure See Also Send Feedback

The widget's height, from 20 up to 272 pixels

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Height As Short
C#
public short Height
Visual C++
public:
short Height
JavaScript
height

See Also

WidgetInfo Structure


Left Field

[image]

.NET Framework Class Library
WidgetInfo..::.Left Field
WidgetInfo Structure See Also Send Feedback

The x coordinate value of widget's top-left point

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Left As Short
C#
public short Left
Visual C++
public:
short Left
JavaScript
left

See Also

WidgetInfo Structure


Text Field

[image]

.NET Framework Class Library
WidgetInfo..::.Text Field
WidgetInfo Structure See Also Send Feedback

The widget text.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Text As String
C#
public string Text
Visual C++
public:
String^ Text
JavaScript
text

See Also

WidgetInfo Structure


Top Field

[image]

.NET Framework Class Library
WidgetInfo..::.Top Field
WidgetInfo Structure See Also Send Feedback

The y coordinate value of widget's top-left point

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Top As Short
C#
public short Top
Visual C++
public:
short Top
JavaScript
top

See Also

WidgetInfo Structure


WidgetID Field

[image]

.NET Framework Class Library
WidgetInfo..::.WidgetID Field
WidgetInfo Structure See Also Send Feedback

The widget ID

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public WidgetID As Byte
C#
public byte WidgetID
Visual C++
public:
unsigned char WidgetID
JavaScript
widgetID

See Also

WidgetInfo Structure


WidgetType Field

[image]

.NET Framework Class Library
WidgetInfo..::.WidgetType Field
WidgetInfo Structure See Also Send Feedback

The widget type

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public WidgetType As WidgetType
C#
public WidgetType WidgetType
Visual C++
public:
WidgetType WidgetType
JavaScript
widgetType

See Also

WidgetInfo Structure


Width Field

[image]

.NET Framework Class Library
WidgetInfo..::.Width Field
WidgetInfo Structure See Also Send Feedback

The widget's width, from 40 up to 480 pixels

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Width As Short
C#
public short Width
Visual C++
public:
short Width
JavaScript
width

See Also

WidgetInfo Structure


WidgetInfo Methods

[image] [image]

.NET Framework Class Library
WidgetInfo Methods
WidgetInfo Structure See Also Send Feedback

The WidgetInfo type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

WidgetInfo Structure


Widgets Class

[image]

.NET Framework Class Library
Widgets Class
See Also Send Feedback

The widget management type.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
<GuidAttribute("FECBBF04-BF10-41e5-8F4E-E98BEE980587")> _
Public Class Widgets _
    Implements IWidgets
C#
[ClassInterfaceAttribute(ClassInterfaceType.None)]
[GuidAttribute("FECBBF04-BF10-41e5-8F4E-E98BEE980587")]
public class Widgets : IWidgets
Visual C++
[ClassInterfaceAttribute(ClassInterfaceType::None)]
[GuidAttribute(L"FECBBF04-BF10-41e5-8F4E-E98BEE980587")]
public ref class Widgets : IWidgets
JavaScript
Interlink.ePad.ePadVision.Widgets = function();

Type.createClass(
    'Interlink.ePad.ePadVision.Widgets',
    null,
    Interlink.ePad.ePadVision.IWidgets);

Inheritance Hierarchy

System..::.Object
Interlink.ePad.ePadVision..::.Widgets

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


Widgets Methods

[image] [image]

.NET Framework Class Library
Widgets Methods
Widgets Class See Also Send Feedback

The Widgets type exposes the following members.

Methods

Name | Description
CreateWidget | Create a widget.
DeleteWidget | Delete a widget identified by its ID.
DisplayPinPad | Display the Pin Pad widget
DisplayPinPadEx | Display the Pin Pad widget
EnableWidget | Enable or disable a widget.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadWidgetLayout | Layout the desktop with ink region, watermark (image), buttons (widgets)...
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveWidget | Move the widget to the specified location.
RemoveAllWidgets | Remove all widgets from desktop permanently.
SetWidgetChecked | Set the widget to checked or unchecked. It is designed for check box or radio button. And it has no effective for other widgets.
SetWidgetText | Set the text to the widget. It is used to set the content to Text widget, the caption to button...
ShowWidget | Show or hide a widget
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UniCreateWidget | Create a widget with Unicode text string embedded in the WidgetInfo structure
UniSetWidgetText | Set the text in the widget as Unicode string

See Also

Widgets Class


CreateWidget Method

[image]

.NET Framework Class Library
Widgets..::.CreateWidget Method
Widgets Class See Also Send Feedback

Create a widget.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateWidget ( _
    wInfo As WidgetInfo _
)
C#
public void CreateWidget(
    WidgetInfo wInfo
)
Visual C++
public:
virtual void CreateWidget(
    WidgetInfo wInfo
) sealed
JavaScript
function createWidget(wInfo);

Parameters

wInfo
Type: Interlink.ePad.ePadVision..::.WidgetInfo
The widget info

Implements

IWidgets..::.CreateWidget(WidgetInfo)

Remarks

The device will send out events to inform the requestor the status of the widget creation request. Please see EventDataDelegate for detailed info.

The widget ID must be between 1--200.

The widget's text in each widget can have up to 960 characters (bytes).

Each widget uses a certain amount of memory in the device, which depends on the widget type and the widget text size. When the amount of available memory is very low, a create widget request could either fail or be only partially displayed, e.g., there may be no text in the widget or the text could be incomplete.

It is recommended that you test your widget layout to see if the device can support it. As a guideline, the following table shows the number of widgets that can be created for certain text sizes (tested on a device with bcd #: 1.0).

Widget Type | Widget Text Size | The available widget numbers
Text | 2 | 66
Button | 2 | 86
Checkbox | 2 | 82
Radio Button | 2 | 68
Text | 89 | 33
Button | 89 | 61
Checkbox | 89 | 59
Radio Button | 89 | 51

When the text in a TEXT widget is too long to fit on one line, ePad-vision will automatically insert line breaks to wrap the text to the next lines. When the total text height is greater than the widget height, ePad-vision will insert a vertical scrollbar on the right side of the widget.

In some situations where the height of the text and the height of the widget are very close, a superfluous scrollbar is drawn in the TEXT widget. Touching the TEXT widget redraws the TEXT widget and removes the unnecessary scrollbar. This situation can be avoided by increasing the height of the TEXT widget by a small number of pixels.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Device access error or internal data is invalid. The widget parameter is invalid.

See Also

Widgets Class


DeleteWidget Method

[image]

.NET Framework Class Library
Widgets..::.DeleteWidget Method
Widgets Class See Also Send Feedback

Delete a widget identified by its ID.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteWidget ( _
    widgetID As Byte _
)
C#
public void DeleteWidget(
    byte widgetID
)
Visual C++
public:
virtual void DeleteWidget(
    unsigned char widgetID
) sealed
JavaScript
function deleteWidget(widgetID);

Parameters

widgetID
Type: System..::.Byte
The ID of the widget to be deleted.

Implements

IWidgets..::.DeleteWidget(Byte)

Remarks

The device will send out event to inform deleting status.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Device access error or internal data is invalid.

See Also

Widgets Class


DisplayPinPad Method

[image]

.NET Framework Class Library
Widgets..::.DisplayPinPad Method
Widgets Class See Also Send Feedback

Display the Pin Pad widget

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub DisplayPinPad ( _
    XMLData As String, _
    timeOut As Integer, _
    <OutAttribute> ByRef output As String _
)
C#
public void DisplayPinPad(
    string XMLData,
    int timeOut,
    out string output
)
Visual C++
public:
virtual void DisplayPinPad(
    String^ XMLData,
    int timeOut,
    [OutAttribute] String^% output
) sealed
JavaScript
function displayPinPad(XMLData, timeOut, output);

Parameters

XMLData
Type: System..::.String
The XML document describing the Pin Pad layout.
timeOut
Type: System..::.Int32
The pinpad widget timeout in seconds
output
Type: System..::.String %
The user inputted string

Implements

IWidgets..::.DisplayPinPad(String, Int32, String%)

Remarks

Please refer to the WPinPad.xml file at the ePad\Images\ePad-vision\XML for detail description of PinPad layout. It is recommand to stop the screen saver and remove all the widgets on the ePad-vision and wait for all the widgets completely removed then calling DisplayPinPad.

See Also

Widgets Class


DisplayPinPadEx Method

[image]

.NET Framework Class Library
Widgets..::.DisplayPinPadEx Method
Widgets Class See Also Send Feedback

Display the Pin Pad widget

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub DisplayPinPadEx ( _
    XMLData As String, _
    timeOut As Integer, _
    <OutAttribute> ByRef output As String, _
    <OutAttribute> ByRef result As Integer _
)
C#
public void DisplayPinPadEx(
    string XMLData,
    int timeOut,
    out string output,
    out int result
)
Visual C++
public:
virtual void DisplayPinPadEx(
    String^ XMLData,
    int timeOut,
    [OutAttribute] String^% output,
    [OutAttribute] int% result
) sealed
JavaScript
function displayPinPadEx(XMLData, timeOut, output, result);

Parameters

XMLData
Type: System..::.String
The XML document describing the Pin Pad layout.
timeOut
Type: System..::.Int32
The pinpad widget timeout in seconds
output
Type: System..::.String %
The user inputted string
result
Type: System..::.Int32 %
The PinPad function result, 1 for success

Implements

IWidgets..::.DisplayPinPadEx(String, Int32, String%, Int32%)

Remarks

Please refer to the WPinPad.xml file at the ePad\Images\ePad-vision\XML for detail description of PinPad layout. It is recommand to stop the screen saver and remove all the widgets on the ePad-vision and wait for all the widgets completely removed then calling DisplayPinPad.

See Also

Widgets Class


EnableWidget Method

[image]

.NET Framework Class Library
Widgets..::.EnableWidget Method
Widgets Class See Also Send Feedback

Enable or disable a widget.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub EnableWidget ( _
    widgetID As Byte, _
    bEnable As Boolean _
)
C#
public void EnableWidget(
    byte widgetID,
    bool bEnable
)
Visual C++
public:
virtual void EnableWidget(
    unsigned char widgetID,
    bool bEnable
) sealed
JavaScript
function enableWidget(widgetID, bEnable);

Parameters

widgetID
Type: System..::.Byte
The ID of the target widget.
bEnable
Type: System..::.Boolean
The flag whether to enable (when it is "true") or disable (when it is "false") the target widget.

Implements

IWidgets..::.EnableWidget(Byte, Boolean)

Remarks

The device will send out event to inform the operation status.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Device access error or internal data is invalid.

See Also

Widgets Class


LoadWidgetLayout Method

[image]

.NET Framework Class Library
Widgets..::.LoadWidgetLayout Method
Widgets Class See Also Send Feedback

Layout the desktop with ink region, watermark (image), buttons (widgets)...

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadWidgetLayout ( _
    XMLDocument As String _
)
C#
public void LoadWidgetLayout(
    string XMLDocument
)
Visual C++
public:
virtual void LoadWidgetLayout(
    String^ XMLDocument
) sealed
JavaScript
function loadWidgetLayout(XMLDocument);

Parameters

XMLDocument
Type: System..::.String
The XML document defining the desktop layout.

Implements

IWidgets..::.LoadWidgetLayout(String)

Remarks

The schema of XML document will be defined later.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Device access error or internal data is invalid.

See Also

Widgets Class


MoveWidget Method

[image]

.NET Framework Class Library
Widgets..::.MoveWidget Method
Widgets Class See Also Send Feedback

Move the widget to the specified location.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub MoveWidget ( _
    widgetID As Byte, _
    xPos As Short, _
    yPos As Short _
)
C#
public void MoveWidget(
    byte widgetID,
    short xPos,
    short yPos
)
Visual C++
public:
virtual void MoveWidget(
    unsigned char widgetID,
    short xPos,
    short yPos
) sealed
JavaScript
function moveWidget(widgetID, xPos, yPos);

Parameters

widgetID
Type: System..::.Byte
The desired widget ID.
xPos
Type: System..::.Int16
The x axis value of the top left point of the destination.
yPos
Type: System..::.Int16
The y axis value of the top left point of the destination.

Implements

IWidgets..::.MoveWidget(Byte, Int16, Int16)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Device access error or internal data is invalid.

See Also

Widgets Class


RemoveAllWidgets Method

[image]

.NET Framework Class Library
Widgets..::.RemoveAllWidgets Method
Widgets Class See Also Send Feedback

Remove all widgets from desktop permanently.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAllWidgets
C#
public void RemoveAllWidgets()
Visual C++
public:
virtual void RemoveAllWidgets() sealed
JavaScript
function removeAllWidgets();

Implements

IWidgets..::.RemoveAllWidgets()()()

Remarks

The device will send out events to inform the deleting status.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Device access error or internal data is invalid.

See Also

Widgets Class


SetWidgetChecked Method

[image]

.NET Framework Class Library
Widgets..::.SetWidgetChecked Method
Widgets Class See Also Send Feedback

Set the widget to checked or unchecked.

It is designed for check box or radio button. And it has no effective for other widgets.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWidgetChecked ( _
    widgetID As Byte, _
    check As Boolean _
)
C#
public void SetWidgetChecked(
    byte widgetID,
    bool check
)
Visual C++
public:
virtual void SetWidgetChecked(
    unsigned char widgetID,
    bool check
) sealed
JavaScript
function setWidgetChecked(widgetID, check);

Parameters

widgetID
Type: System..::.Byte
The desired widget ID.
check
Type: System..::.Boolean
The desired checked/unchecked flag.

Return Value

"true" if the request has been accepted. Otherwise "false" is returned.

Implements

IWidgets..::.SetWidgetChecked(Byte, Boolean)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Device access error or internal data is invalid.

See Also

Widgets Class


SetWidgetText Method

[image]

.NET Framework Class Library
Widgets..::.SetWidgetText Method
Widgets Class See Also Send Feedback

Set the text to the widget. It is used to set the content to Text widget, the caption to button...

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWidgetText ( _
    widgetID As Byte, _
    text As String _
)
C#
public void SetWidgetText(
    byte widgetID,
    string text
)
Visual C++
public:
virtual void SetWidgetText(
    unsigned char widgetID,
    String^ text
) sealed
JavaScript
function setWidgetText(widgetID, text);

Parameters

widgetID
Type: System..::.Byte
The ID of the destination widget.
text
Type: System..::.String
The text to be send to the widget.

Implements

IWidgets..::.SetWidgetText(Byte, String)

Remarks

The device will send out an event to inform the requestor the status of the set widget text request. Please see EventDataDelegate for detailed info.

The text in each widget can have up to 960 characters(bytes).

Each widget uses a certain amount of memory in the device, which depends on the widget type and the widget text size. When the amount of available memory is very low, a set widget text request could either fail or the text may be only partially displayed.

For additional information, please go to CreateWidget(WidgetInfo).

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Device access error or internal data is invalid.

See Also

Widgets Class


ShowWidget Method

[image]

.NET Framework Class Library
Widgets..::.ShowWidget Method
Widgets Class See Also Send Feedback

Show or hide a widget

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub ShowWidget ( _
    widgetID As Byte, _
    bShow As Boolean _
)
C#
public void ShowWidget(
    byte widgetID,
    bool bShow
)
Visual C++
public:
virtual void ShowWidget(
    unsigned char widgetID,
    bool bShow
) sealed
JavaScript
function showWidget(widgetID, bShow);

Parameters

widgetID
Type: System..::.Byte
The ID of the target widget.
bShow
Type: System..::.Boolean
The flag whether to show (when it is "true") or hide (when it is "false") the target widget.

Implements

IWidgets..::.ShowWidget(Byte, Boolean)

Remarks

The device will send out event to inform the operation status.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | Device access error or internal data is invalid.

See Also

Widgets Class


UniCreateWidget Method

[image]

.NET Framework Class Library
Widgets..::.UniCreateWidget Method
Widgets Class See Also Send Feedback

Create a widget with Unicode text string embedded in the WidgetInfo structure

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub UniCreateWidget ( _
    info As WidgetInfo _
)
C#
public void UniCreateWidget(
    WidgetInfo info
)
Visual C++
public:
virtual void UniCreateWidget(
    WidgetInfo info
) sealed
JavaScript
function uniCreateWidget(info);

Parameters

info
Type: Interlink.ePad.ePadVision..::.WidgetInfo
WigetInfo structure defines widget id, widget type, font id etc. required fields to create a widget. The text field will be treated as Unicode string.

Implements

IWidgets..::.UniCreateWidget(WidgetInfo)

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request or invalid widget info value

See Also

Widgets Class


UniSetWidgetText Method

[image]

.NET Framework Class Library
Widgets..::.UniSetWidgetText Method
Widgets Class See Also Send Feedback

Set the text in the widget as Unicode string

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub UniSetWidgetText ( _
    widgetID As Byte, _
    text As String _
)
C#
public void UniSetWidgetText(
    byte widgetID,
    string text
)
Visual C++
public:
virtual void UniSetWidgetText(
    unsigned char widgetID,
    String^ text
) sealed
JavaScript
function uniSetWidgetText(widgetID, text);

Parameters

widgetID
Type: System..::.Byte
an existing widget id.
text
Type: System..::.String
Unicode string

Implements

IWidgets..::.UniSetWidgetText(Byte, String)

Remarks

set the text in an existing widget as Unicode string

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request or text is null or widgetid is invalid

See Also

Widgets Class


WidgetType Enumeration

[image]

.NET Framework Class Library
WidgetType Enumeration
See Also Send Feedback

The widget type indicator

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration WidgetType
C#
public enum WidgetType
Visual C++
public enum class WidgetType
JavaScript
Interlink.ePad.ePadVision.WidgetType = function();
Interlink.ePad.ePadVision.WidgetType.createEnum('Interlink.ePad.ePadVision.WidgetType', false);

Members

Member name | Description
TEXT | Text widget
BUTTON | Push Button widget
CHECKBOX | Checkbox widget
RADIOBUTTON | Radio Button widget

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


ProducerConsumer Constructor

[image]

.NET Framework Class Library
ProducerConsumer Constructor
ProducerConsumer Class See Also Send Feedback

Namespace: Interlink.ePad
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProducerConsumer()
Visual C++
public:
ProducerConsumer()
JavaScript
Interlink.ePad.ProducerConsumer = function();

See Also

ProducerConsumer Class
Interlink.ePad Namespace


DownloadFontDialog Events

[image] [image]

.NET Framework Class Library
DownloadFontDialog Events
DownloadFontDialog Class See Also Send Feedback

The DownloadFontDialog type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DownloadFontDialog Class


id Field

[image]

.NET Framework Class Library
FontEntry..::.id Field
FontEntry Class See Also Send Feedback

When getting font list from Flash, the id is the index within list. When getting font list from PSRAM, the id is the corresponding font id.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public id As Byte
C#
public byte id
Visual C++
public:
unsigned char id
JavaScript
id

See Also

FontEntry Class


name Field

[image]

.NET Framework Class Library
FontEntry..::.name Field
FontEntry Class See Also Send Feedback

The name of font, should be less than 32 bytes long.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public name As String
C#
public string name
Visual C++
public:
String^ name
JavaScript
name

See Also

FontEntry Class


size Field

[image]

.NET Framework Class Library
FontEntry..::.size Field
FontEntry Class See Also Send Feedback

The file size of font in bytes.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public size As Integer
C#
public int size
Visual C++
public:
int size
JavaScript
size

See Also

FontEntry Class


FontEntry Fields

[image] [image]

.NET Framework Class Library
FontEntry Fields
FontEntry Class See Also Send Feedback

The FontEntry type exposes the following members.

Fields

Name | Description
id | When getting font list from Flash, the id is the index within list. When getting font list from PSRAM, the id is the corresponding font id.
name | The name of font, should be less than 32 bytes long.
size | The file size of font in bytes.

See Also

FontEntry Class


Dispose Method (Boolean)

[image]

.NET Framework Class Library
DownloadFontDialog..::.Dispose Method (Boolean)
DownloadFontDialog Class See Also Send Feedback

Clean up any resources being used.

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override
JavaScript
function dispose(disposing);

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DownloadFontDialog Class
Dispose Overload


CreateSIF Method

[image]

.NET Framework Class Library
ePadVision..::.CreateSIF Method
ePadVision Class See Also Send Feedback

Create a new Font from existing SIF font file in the flash and associated the new Font with fontId

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSIF ( _
    SIFfile As String, _
    fontId As Byte, _
    source As Byte _
) As Boolean
C#
public bool CreateSIF(
    string SIFfile,
    byte fontId,
    byte source
)
Visual C++
public:
bool CreateSIF(
    String^ SIFfile,
    unsigned char fontId,
    unsigned char source
)
JavaScript
function createSIF(SIFfile, fontId, source);

Parameters

SIFfile
Type: System..::.String
The filename of an existing System Independent Font(SIF) file in the flash.

The SIF file already downloaed to the ePad-vision through DownloadSIF() API.

fontId
Type: System..::.Byte
fontId within downlaodable fonts range, please refer FontID

The font id assoicated with SIF file for Widget operations.

source
Type: System..::.Byte
Currently only support from Flash, please refer ExternalDevice

Remarks

Copy the SIF font file from FLASH to PSRAM and create a SIF font in PSRAM and associated the fontId with it.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or Invalid path to the SIF or SIF could not be found in the Flash or Invalid font id or font id already in use or Invalid source value

See Also

ePadVision Class


DeleteSIF Method

[image]

.NET Framework Class Library
ePadVision..::.DeleteSIF Method
ePadVision Class See Also Send Feedback

delete a SIF file from ePad-vision external Flash or purge all the fonts in RAM

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Function DeleteSIF ( _
    SIFfile As String, _
    source As Byte _
) As Boolean
C#
public bool DeleteSIF(
    string SIFfile,
    byte source
)
Visual C++
public:
bool DeleteSIF(
    String^ SIFfile,
    unsigned char source
)
JavaScript
function deleteSIF(SIFfile, source);

Parameters

SIFfile
Type: System..::.String
The file name of an existing System Indepenece Font(SIF) file.

The SIF file has been downloaded to ePad-vision external Flash.

The SIF file could be null, if the source is RAM.

source
Type: System..::.Byte
please ref to ExternalDevice

Remarks

If the source is the Flash, an existing SIFfile will be deleted. If the source is the PSRAM, all the fonts will be purged.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or SIF not existed or Invalid source value ///

See Also

ePadVision Class


DownloadSIF Method

[image]

.NET Framework Class Library
ePadVision..::.DownloadSIF Method
ePadVision Class See Also Send Feedback

Read the SIF format file then loaded it into ePad-vision external device

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Function DownloadSIF ( _
    SIFfile As String, _
    fontId As Byte, _
    destination As Byte _
) As Boolean
C#
public bool DownloadSIF(
    string SIFfile,
    byte fontId,
    byte destination
)
Visual C++
public:
bool DownloadSIF(
    String^ SIFfile,
    unsigned char fontId,
    unsigned char destination
)
JavaScript
function downloadSIF(SIFfile, fontId, destination);

Parameters

SIFfile
Type: System..::.String
The absolute full path to an existing SIF font file.

A SIF format file could be generated through font converter application by ePadLink.

fontId
Type: System..::.Byte
0 or 220 to 224. Please ref to FontID

destination
Type: System..::.Byte
Please ref to ExternalDevice

Remarks

If the destination is the Flash and the font id within 220-224, the SIF font will be downloaded into Flash and a new FONT will be created in the PSRAM as well. This configuration combined font downloading and creation in one call.

If the destination is Flash and the font id is 0, the font will be downloaded into Flash only. This font could be created through CreateSIF() later.

"/>

If the destination is PSRAM and font id must be in the DOWNLOAD_FONT range, the SIF font will be downloaded and created in PSRAM.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or Invalid path to the SIF or Invalid SIF format or Invalid fontId or Not enough space or fontId already in use or Invalid destination value

See Also

ePadVision Class


UniCreateWidget Method

[image]

.NET Framework Class Library
ePadVision..::.UniCreateWidget Method
ePadVision Class See Also Send Feedback

Create a widget with Unicode text string embedded in the WidgetInfo structure

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub UniCreateWidget ( _
    info As WidgetInfo _
)
C#
public void UniCreateWidget(
    WidgetInfo info
)
Visual C++
public:
void UniCreateWidget(
    WidgetInfo info
)
JavaScript
function uniCreateWidget(info);

Parameters

info
Type: Interlink.ePad.ePadVision..::.WidgetInfo
WigetInfo structure defines widget id, widget type, font id etc. required fields to create a widget. The text field will be treated as Unicode string.

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request or invalid widget info value

See Also

ePadVision Class


UniSetWidgetText Method

[image]

.NET Framework Class Library
ePadVision..::.UniSetWidgetText Method
ePadVision Class See Also Send Feedback

Set the text in the widget as Unicode string

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub UniSetWidgetText ( _
    widgetID As Byte, _
    text As String _
)
C#
public void UniSetWidgetText(
    byte widgetID,
    string text
)
Visual C++
public:
void UniSetWidgetText(
    unsigned char widgetID,
    String^ text
)
JavaScript
function uniSetWidgetText(widgetID, text);

Parameters

widgetID
Type: System..::.Byte
an existing widget id.
text
Type: System..::.String
Unicode string

Remarks

set the text in an existing widget as Unicode string

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the request or text is null or widgetid is invalid

See Also

ePadVision Class


Consume Method

[image]

.NET Framework Class Library
ProducerConsumer..::.Consume Method
ProducerConsumer Class See Also Send Feedback

Namespace: Interlink.ePad
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Function Consume As Byte()
C#
public byte[] Consume()
Visual C++
public:
array<unsigned char>^ Consume()
JavaScript
function consume();

See Also

ProducerConsumer Class
Interlink.ePad Namespace


Count Method

[image]

.NET Framework Class Library
ProducerConsumer..::.Count Method
ProducerConsumer Class See Also Send Feedback

Namespace: Interlink.ePad
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Function Count As Integer
C#
public int Count()
Visual C++
public:
int Count()
JavaScript
function count();

See Also

ProducerConsumer Class
Interlink.ePad Namespace


Produce Method

[image]

.NET Framework Class Library
ProducerConsumer..::.Produce Method
ProducerConsumer Class See Also Send Feedback

Namespace: Interlink.ePad
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Sub Produce ( _
    o As Byte() _
)
C#
public void Produce(
    byte[] o
)
Visual C++
public:
void Produce(
    array<unsigned char>^ o
)
JavaScript
function produce(o);

Parameters

o
Type: array< System..::.Byte >[]()[]

See Also

ProducerConsumer Class
Interlink.ePad Namespace


DownloadFontDialog Methods

[image] [image]

.NET Framework Class Library
DownloadFontDialog Methods
DownloadFontDialog Class See Also Send Feedback

The DownloadFontDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

DownloadFontDialog Class


ProducerConsumer Methods

[image] [image]

.NET Framework Class Library
ProducerConsumer Methods
ProducerConsumer Class See Also Send Feedback

The ProducerConsumer type exposes the following members.

Methods

Name | Description
Consume |
Count |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Produce |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProducerConsumer Class
Interlink.ePad Namespace


Interlink.ePad Namespace

[image]

.NET Framework Class Library
Interlink.ePad Namespace
Send Feedback

Classes

Class | Description
ProducerConsumer |


AccessibilityNotifyClients Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.AccessibilityNotifyClients Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DownloadFontDialog Class


BeginInvoke Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.BeginInvoke Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DownloadFontDialog Class


Dispose Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.Dispose Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

DownloadFontDialog Class


GetChildAtPoint Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.GetChildAtPoint Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DownloadFontDialog Class


Invalidate Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.Invalidate Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DownloadFontDialog Class


Invoke Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.Invoke Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DownloadFontDialog Class


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.MemberwiseClone Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DownloadFontDialog Class


PerformLayout Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.PerformLayout Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DownloadFontDialog Class


ResumeLayout Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.ResumeLayout Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DownloadFontDialog Class


RtlTranslateAlignment Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.RtlTranslateAlignment Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DownloadFontDialog Class


Scale Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.Scale Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

DownloadFontDialog Class


Select Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.Select Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

DownloadFontDialog Class


SetBounds Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.SetBounds Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DownloadFontDialog Class


Show Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.Show Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

DownloadFontDialog Class


ShowDialog Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.ShowDialog Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

DownloadFontDialog Class


UpdateBounds Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.UpdateBounds Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DownloadFontDialog Class


Validate Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.Validate Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DownloadFontDialog Class


ValidateChildren Method

[image] [image]

.NET Framework Class Library
DownloadFontDialog..::.ValidateChildren Method
DownloadFontDialog Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

DownloadFontDialog Class


GetFontListFromFlash Property

[image]

.NET Framework Class Library
ePadVision..::.GetFontListFromFlash Property
ePadVision Class See Also Send Feedback

Get a list of downloaded font from the ePad-vision external Flash

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GetFontListFromFlash As List(Of FontEntry)
C#
public List<FontEntry> GetFontListFromFlash { get; }
Visual C++
public:
property List<FontEntry^>^ GetFontListFromFlash {
    List<FontEntry^>^ get ();
}
JavaScript
function get_getFontListFromFlash();

Return Value

a list of FontEntry stored in the external Flash

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


GetFontListFromRAM Property

[image]

.NET Framework Class Library
ePadVision..::.GetFontListFromRAM Property
ePadVision Class See Also Send Feedback

Get a list of downloaded font from the ePad-vision external RAM

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GetFontListFromRAM As List(Of FontEntry)
C#
public List<FontEntry> GetFontListFromRAM { get; }
Visual C++
public:
property List<FontEntry^>^ GetFontListFromRAM {
    List<FontEntry^>^ get ();
}
JavaScript
function get_getFontListFromRAM();

Return Value

a list of FontEntry stored in the external RAM

Exceptions

Exception | Condition
Interlink.ePad.ePadCore..::.ePadException | The device is not open or failed to process the requests.

See Also

ePadVision Class


DownloadFontDialog Properties

[image] [image]

.NET Framework Class Library
DownloadFontDialog Properties
DownloadFontDialog Class See Also Send Feedback

The DownloadFontDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

DownloadFontDialog Class


DownloadFontDialog Class

[image]

.NET Framework Class Library
DownloadFontDialog Class
See Also Send Feedback

dialog to perform download font function

Namespace: Interlink.ePad.ePadVision
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Class DownloadFontDialog _
    Inherits Form
C#
public class DownloadFontDialog : Form
Visual C++
public ref class DownloadFontDialog : public Form
JavaScript
Interlink.ePad.ePadVision.DownloadFontDialog = function();

Type.createClass(
    'Interlink.ePad.ePadVision.DownloadFontDialog',
    Form);

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
Interlink.ePad.ePadVision..::.DownloadFontDialog

See Also

Interlink.ePad.ePadVision Namespace
Send feedback on this topic to Microsoft.


ProducerConsumer Class

[image]

.NET Framework Class Library
ProducerConsumer Class
See Also Send Feedback

Namespace: Interlink.ePad
Assembly: ePadService (in ePadService.dll)

Syntax

Visual Basic (Declaration)
Public Class ProducerConsumer
C#
public class ProducerConsumer
Visual C++
public ref class ProducerConsumer
JavaScript
Interlink.ePad.ProducerConsumer = function();

Type.createClass(
    'Interlink.ePad.ProducerConsumer');

Inheritance Hierarchy

System..::.Object
Interlink.ePad..::.ProducerConsumer

See Also

Interlink.ePad Namespace